DRC showing Unconnected only when mouse leaves DRC window

Bug #1606849 reported by Novak Tamas on 2016-07-27
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Jeff Young

Bug Description

In pcbnew, OpenGL mode, I run DRC, then click on an item of Unconnected tab's list.
Board in the background (below DRC window) is changing only when mouse puts off the DRC window.

This bug together with the missing crosshair cursor (#1606832) makes harder using DRC to eliminate unconnected pins (very short ratsnets lines are hard to spot)

Application: kicad
Version: (2016-06-15 BZR 6936, Git 3f2b157)-product, release build
Libraries: wxWidgets 3.0.2
           libcurl/7.46.0 OpenSSL/1.0.2d zlib/1.2.8 libidn/1.32 libssh2/1.6.0 librtmp/2.3
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
- Build Info -
wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.57.0
Curl: 7.46.0
KiCad - Compiler: GCC 5.2.0 with C++ ABI 1009
        Settings: USE_WX_GRAPHICS_CONTEXT=OFF
                  USE_WX_OVERLAY=OFF
                  KICAD_SCRIPTING=ON
                  KICAD_SCRIPTING_MODULES=ON
                  KICAD_SCRIPTING_WXPYTHON=ON
                  USE_FP_LIB_TABLE=HARD_CODED_ON
                  BUILD_GITHUB_PLUGIN=ON

Hasan Yavuz Özderya (hyozd) wrote :

This isn't specific to the "unconnected item" errors. Usual markers also has the same behavior. I think this is caused by canvas only refreshing when mouse moves over it.

Jeff Young (jeyjey) wrote :
Changed in kicad:
status: New → Triaged
assignee: nobody → Jeff Young (jeyjey)
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 3d177e9c2ace1e7b7211cc2ec1f3d78c2ef33ceb
https://git.launchpad.net/kicad/patch/?id=3d177e9c2ace1e7b7211cc2ec1f3d78c2ef33ceb

Changed in kicad:
status: Triaged → Fix Committed
Maciej Suminski (orsonmmz) wrote :

Thank you Jeff, I pushed your patch with a few code formatting fixes applied.

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers