PCBNEW crashes on loading a file exported from Gerbview

Bug #1598809 reported by Aurabindo J on 2016-07-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
High
Unassigned

Bug Description

Opened standard Gerber files in GerberView, downloaded from Oshpark: https://644db4de3505c40a0444-327723bce298e3ff5813fb42baeefbaa.ssl.cf1.rackcdn.com/089a8690bce9a78447d1b756c34613c0.zip

These files were exported to Pcbnew from GerberView.

When opening the exported file from Pcbnew, it crashes.

BackTrace: https://paste.gnome.org/puwvz9pjv

Converted kicad_pcb file : https://www.dropbox.com/s/3y7wq46ht7wmak7/teensy_3.2_footprint.kicad_pcb?dl=0

Version Information:
Application: kicad
Version: 4.0.2-1.fc23-product release build
wxWidgets: Version 3.0.2 (debug,wchar_t,compiler with C++ ABI 1008,GCC 5.3.1,wx containers,compatible with 2.8)
Platform: Linux 4.5.7-203.pf.haswell.fc23.x86_64 x86_64, 64 bit, Little endian, wxGTK
Boost version: 1.58.0
         USE_WX_GRAPHICS_CONTEXT=OFF
         USE_WX_OVERLAY=OFF
         KICAD_SCRIPTING=OFF
         KICAD_SCRIPTING_MODULES=OFF
         KICAD_SCRIPTING_WXPYTHON=OFF
         USE_FP_LIB_TABLE=HARD_CODED_ON
         BUILD_GITHUB_PLUGIN=ON

Related branches

tags: added: gerbview pcbnew segfault
Changed in kicad:
importance: Undecided → High

It does not happen in the current testing branch, so I tag it a fix committed.

Changed in kicad:
status: New → Fix Committed
Aurabindo J (jay-aurabind) wrote :

I checked with the Kicad versions available in OpenSuse Leap 42.1 and Fedora 23, and crashes in both of these.

JP - the problem is, it doesn't happen for me on stable either, and the
problem is reported with stable. So there may be something system-dependent
going on, can't really say it's fixed yet IMO.

On Jul 4, 2016 07:45, "jean-pierre charras" <email address hidden>
wrote:

> It does not happen in the current testing branch, so I tag it a fix
> committed.
>
> ** Changed in: kicad
> Status: New => Fix Committed
>
> --
> You received this bug notification because you are a member of KiCad Bug
> Squad, which is subscribed to KiCad.
> https://bugs.launchpad.net/bugs/1598809
>
> Title:
> PCBNEW crashes on loading a file exported from Gerbview
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1598809/+subscriptions
>

I just fixed the issue (I hope...) in my working trees.
I do not think it is system dependent (it was a missing initialization only noticeable with board files generated by Gerbview).
It happened on my computer in the stable version, and (for some reason, perhaps an other change) not in the current product branch.

Chris Pavlina (pavlina-chris) wrote :

Ah, that makes sense - uninitialized data /can/ be "system"-dependent as
the uninitialized data will default to different things for different
people.

On Jul 5, 2016 10:55, "jean-pierre charras" <email address hidden>
wrote:

> I just fixed the issue (I hope...) in my working trees.
> I do not think it is system dependent (it was a missing initialization
> only noticeable with board files generated by Gerbview).
> It happened on my computer in the stable version, and (for some reason,
> perhaps an other change) not in the current product branch.
>
> --
> You received this bug notification because you are a member of KiCad Bug
> Squad, which is subscribed to KiCad.
> https://bugs.launchpad.net/bugs/1598809
>
> Title:
> PCBNEW crashes on loading a file exported from Gerbview
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1598809/+subscriptions
>

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers