PCBnew: Re-assigning shortcuts for switching canvas mode does not work

Bug #1588032 reported by kaspar on 2016-06-01
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KiCad
Low
Unassigned

Bug Description

Changing the shortcuts for switching the canvas mode to legacy, Cairo or Opengl doesn't work. The new shortcuts do appear in the menus but nothing happens when you press the keys.

EDIT: Actually, re-assigning to one of the F1-F12 keys does seem to work but not to single letter keys.

kaspar (kaspar-emanuel) on 2016-06-01
description: updated
summary: - Re-assigning shortcuts for switching canvas mode does not work
+ PCBnew: Re-assigning shortcuts for switching canvas mode does not work
description: updated

It works for me.

Please, gives a not working example.

xzcvczx (xzcvczx) wrote :

is it possible that you double assigned a key? as in pcbnew most if not all of the regular keys are already assigned

kaspar (kaspar-emanuel) wrote :

No, if you double assign keys PCBnew warns you and get's rid of the old assignment. I have been testing some more and it seems to be specifically assigning "Switch to Legacy Canvas" to any single-letter short cuts. I tried A and Q. Assigning "Switch to OpenGL Canvas" does seem to work actually.

xzcvczx (xzcvczx) wrote :

Can't reproduce here on OSX. Please paste your version info from Help->Copy Version Info or Help->About->Copy Version info

Changed in kicad:
status: New → Incomplete
kaspar (kaspar-emanuel) wrote :

Ah, forgot, sorry.

Application: pcbnew
Version: 4.1.0-alpha+201605292346+6852~44~ubuntu14.04.1-product, release build
Libraries: wxWidgets 3.0.2
           libcurl/7.35.0 OpenSSL/1.0.1f zlib/1.2.8 libidn/1.28 librtmp/2.3
Platform: Linux 3.16.0-70-generic x86_64, 64 bit, Little endian, wxGTK
- Build Info -
wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.54.0
Curl: 7.35.0
KiCad - Compiler: GCC 4.8.4 with C++ ABI 1002
        Settings: USE_WX_GRAPHICS_CONTEXT=OFF
                  USE_WX_OVERLAY=OFF
                  KICAD_SCRIPTING=ON
                  KICAD_SCRIPTING_MODULES=ON
                  KICAD_SCRIPTING_WXPYTHON=ON
                  USE_FP_LIB_TABLE=HARD_CODED_ON
                  BUILD_GITHUB_PLUGIN=ON

kaspar (kaspar-emanuel) on 2016-06-02
Changed in kicad:
status: Incomplete → New

Does not happen on Windows, but happens on Linux 5kubuntu 14.04

kaspar (kaspar-emanuel) wrote :

I just noticed the Ctrl-Z shortcut is also not working in OpenGL or Cairo modes. Using the menu to undo does work.

xzcvczx (xzcvczx) wrote :

i wonder whether kde is interferring with the hotkeys or something.....

xzcvczx (xzcvczx) wrote :

woops my bad, saw jp's reponse and got distracted. I wonder if its an issue with some component in 14.04

Chris Pavlina (pavlina-chris) wrote :

I can reproduce this.

Application: pcbnew
Version: (2016-06-07 BZR 6892, Git c094ba0)-product, debug build
Libraries: wxWidgets 3.0.2
           libcurl/7.49.1 OpenSSL/1.0.2h zlib/1.2.8 libidn/1.32 libssh2/1.7.0
Platform: Linux 4.5.4-1-ARCH x86_64, 64 bit, Little endian, wxGTK
- Build Info -
wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.61.0
Curl: 7.49.1
KiCad - Compiler: Clang 3.8.0 with C++ ABI 1002
        Settings: USE_WX_GRAPHICS_CONTEXT=OFF
                  USE_WX_OVERLAY=OFF
                  KICAD_SCRIPTING=OFF
                  KICAD_SCRIPTING_MODULES=OFF
                  KICAD_SCRIPTING_WXPYTHON=OFF
                  USE_FP_LIB_TABLE=HARD_CODED_ON
                  BUILD_GITHUB_PLUGIN=ON

Changed in kicad:
status: New → Confirmed
importance: Undecided → Medium
Chris Pavlina (pavlina-chris) wrote :

To be specific, I changed the shortcut for switch-to-legacy to 'j'. It ignores the shortcut.

Chris Pavlina (pavlina-chris) wrote :

Interesting, it depends on focus. If I click on the layer widget first, it works. When the GAL canvas is in focus, it doesn't.

tags: added: gal
tags: added: hotkey
Jeff Young (jeyjey) on 2018-04-08
Changed in kicad:
importance: Medium → Low
Seth Hillbrand (sethh) wrote :

Seems to be fixed in master Please reset if you see it again.

Changed in kicad:
milestone: none → 5.1.0
status: Confirmed → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers