Keepout area of text in copper layers too small

Bug #1555358 reported by Christoph Nieß on 2016-03-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
High
jean-pierre charras

Bug Description

The keepout area of text put into a copper fill area is sometimes calculated too small, making characters like 'y' breach it. This doesn't only look bad, but might also affect DRC and lead to shorts.

Steps to reproduce:
- Generate a copper pour
- Write text containing a 'y' into it, sized to: Height = 5mm, Width = 3mm, Thickness = 0.4mm
- Redraw copper pour

See attached screenshot for example.

Version Information:
Application: kicad
Version: (2016-03-04 BZR 6608)-product release build
wxWidgets: Version 3.0.2 (debug,UTF-8,compiler with C++ ABI 1002,GCC 4.2.1,STL containers,compatible with 2.8)
Platform: Mac OS X (Darwin 15.3.0 x86_64), 64 bit, Little endian, wxMac
Boost version: 1.57.0
         USE_WX_GRAPHICS_CONTEXT=ON
         USE_WX_OVERLAY=ON
         KICAD_SCRIPTING=ON
         KICAD_SCRIPTING_MODULES=ON
         KICAD_SCRIPTING_WXPYTHON=ON
         USE_FP_LIB_TABLE=HARD_CODED_ON
         BUILD_GITHUB_PLUGIN=ON

Related branches

Chris Pavlina (pavlina-chris) wrote :

Confirmed. For anybody who cannot confirm this, try playing with text size, text thickness, and zone clearance. I had no problem at default clearance but can confirm at clearance=0.3mm.

Marking this High priority. I agree, this could lead to unintentional shorts and whatnot very easily, for instance by aligning a text item on the PCB according to the bottom edge of the empty region, then editing the text and assuming that it will stay within that region. *Particularly* since text is still not DRC'd, as I recall.

tags: added: pcbnew
Changed in kicad:
status: New → Confirmed
importance: Undecided → High
Changed in kicad:
assignee: nobody → jean-pierre charras (jp-charras)
Changed in kicad:
status: Confirmed → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers