Segfault in library editor when creating alternate symbol

Bug #1547299 reported by pipe on 2016-02-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Wayne Stambaugh

Bug Description

I made a component in the schematic library editor. I decided that I want a variation of it, so I opened up the component properties and checked the "Has alternate symbol (DeMorgan)" option.

When I did that it asks if it should "Add new pins for alternate body style". I would very much like that so I answered "Yes". This causes the schematic library editor to crash with a segfault.

Application: kicad
Version: (2016-02-18 BZR 6566, Git c2fd462)-product debug build
wxWidgets: Version 3.0.2 (debug,wchar_t,compiler with C++ ABI 1009,GCC 5.3.1,wx containers,compatible with 2.8)
Platform: Linux 4.3.0-1-amd64 x86_64, 64 bit, Little endian, wxGTK
Boost version: 1.58.0
         USE_WX_GRAPHICS_CONTEXT=OFF
         USE_WX_OVERLAY=OFF
         KICAD_SCRIPTING=ON
         KICAD_SCRIPTING_MODULES=ON
         KICAD_SCRIPTING_WXPYTHON=ON
         USE_FP_LIB_TABLE=HARD_CODED_ON
         BUILD_GITHUB_PLUGIN=ON

Related branches

pipe (pipatron) wrote :

Here is the backtrace of the segmentation fault.

tags: added: segfault
pipe (pipatron) wrote :

I can not readily reproduce it with a simple component with only one pin, so here's the component library I'm trying to perform this operation on.

Is this bug repeatable every time? We have been chasing a segfault bug
in the component library editor for a long time but no one seems to be
able to repeat it. I'm hoping this time we can finally figure out whats
going on.

On 2/18/2016 9:41 PM, pipe wrote:
> I can not readily reproduce it with a simple component with only one
> pin, so here's the component library I'm trying to perform this
> operation on.
>
> ** Attachment added: "s29gl064n-04.lib"
> https://bugs.launchpad.net/kicad/+bug/1547299/+attachment/4575147/+files/s29gl064n-04.lib
>

pipe (pipatron) wrote :

Yes, this happens every time. I've included a screen capture to illustrate exactly what I'm doing.

Wayne Stambaugh (stambaughw) wrote :

I confirmed the segfaul but this only happens when Eeschema is run in the stand alone mode. The segfault doesn't occur when Eeschema is launched from KiCad. Thanks for the great bug report.

Changed in kicad:
status: New → Confirmed
pipe (pipatron) wrote :

For me, this happens regardless of the way I start it, but if you can reproduce it in one place that's great. If a fix for that becomes available, I can test it again and see if it still breaks for me.

Wayne Stambaugh (stambaughw) wrote :

I committed a fix for this in the product branch r6571. Please test this when you get a chance and let me know if it resolves your issue.

Changed in kicad:
assignee: nobody → Wayne Stambaugh (stambaughw)
status: Confirmed → Fix Released
pipe (pipatron) wrote :

Yep, that fixed it! Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers