Zero size images in eeschema cause invisible wires in OS X

Bug #1529159 reported by Nick Winters on 2015-12-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Unassigned

Bug Description

Working with this project at this revision:
https://github.com/vedderb/bldc-hardware/tree/18b38f12b422a2ad4d2d673a452c127bccc4ad20
this file:
design/BLDC_4.sch

Here's what I see and expect to see: http://imgur.com/a/LKTcZ First image is in OS X showing first page of schematic with missing border, and many missing wires. Second image is in Linux Mint 17 with another version (whatever mint's package manager installed)

Application: eeschema
Version: (2015-12-22 BZR 6403)-product debug build
wxWidgets: Version 3.0.2 (debug,UTF-8,compiler with C++ ABI 1002,GCC 4.2.1,STL containers,compatible with 2.8)
Platform: Mac OS X (Darwin 15.2.0 x86_64), 64 bit, Little endian, wxMac
Boost version: 1.54.0
libcurl version: 7.46.0 (with SSL - OpenSSL/1.0.2e)
         USE_WX_GRAPHICS_CONTEXT=OFF
         USE_WX_OVERLAY=ON
         KICAD_SCRIPTING=ON
         KICAD_SCRIPTING_MODULES=ON
         KICAD_SCRIPTING_WXPYTHON=ON
         USE_FP_LIB_TABLE=HARD_CODED_ON
         BUILD_GITHUB_PLUGIN=ON

I've built this from source today with wxPython 3.0.2 (with webkit something edited to include WebKitLegacy.h so it compiles on OS X 10.11 (this shouldn't be needed for 3.0.3, see http://trac.wxwidgets.org/ticket/16329 ) )

On the console when running these are printed after loading this schematic:
kiRound_: in file /Users/nick/src/kicad/kicad/common/class_bitmap_base.cpp on line 233, val: inf too ' > 0 ' for int
kiRound_: in file /Users/nick/src/kicad/kicad/common/class_bitmap_base.cpp on line 234, val: inf too ' > 0 ' for int
Dec 24 12:59:12 eeschema[72466] <Error>: CGAffineTransformInvert: singular matrix.

There's more but I lost it because I kept searching. The schematic does in fact have a 0 scale image (lines 1312-4826 or so in the .sch file), and editing the eeschema source as follows seems to cause the printed errors to go away and missing wires and lines return.
in kicad/common/class_bitmap_base.cpp
void BITMAP_BASE::DrawBitmap( EDA_DRAW_PANEL* aPanel, wxDC* aDC, const wxPoint& aPos )
{
    if( m_bitmap == NULL )
        return;

    wxPoint pos = aPos;
    wxSize size = GetSize();

    // HACK: skip drawing 0x0 images
    if (size.x == 0 && size.y == 0)
    {
        return;
    }

Tags: osx Edit Tag help

Related branches

Changed in kicad:
status: New → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers