Comments in Page Settings inverted order.

Bug #1523564 reported by firewalker on 2015-12-07
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
KiCad
Wishlist
Unassigned

Bug Description

The enumeration of the comments in the Page Settings dialog for both Eeschema and Pcbnew are inverted in relation they show up in the actual sheet.

Someone would expect Comment 1 to be placed on the top of the list.

Eeschema:
http://i.imgur.com/IbU5TFA.png

Pcbnew:
http://i.imgur.com/U8HZGGx.png

Application: kicad
Version: no-vcs-found-product release build
wxWidgets: Version 3.0.2 (debug,wchar_t,compiler with C++ ABI 1009,GCC 5.2.0,wx containers,compatible with 2.8)
Platform: Linux 4.2.5-1-ARCH i686, 32 bit, Little endian, wxGTK
Boost version: 1.59.0
         USE_WX_GRAPHICS_CONTEXT=OFF
         USE_WX_OVERLAY=OFF
         KICAD_SCRIPTING=ON
         KICAD_SCRIPTING_MODULES=ON
         KICAD_SCRIPTING_WXPYTHON=ON
         USE_FP_LIB_TABLE=HARD_CODED_ON
         BUILD_GITHUB_PLUGIN=ON

firewalker (firew4lker) wrote :

Version 4.0.0

Wayne Stambaugh (stambaughw) wrote :

This has been the comment order for as long as I've been with the project. Rather then use the default border and title block, you create your own custom title block and set the ordering any way you prefer.

Changed in kicad:
status: New → Triaged
importance: Undecided → Wishlist
Chris Pavlina (pavlina-chris) wrote :

Yeah, but why should the default be backwards? I agree, it's weird. I think the original thought was something along the lines of building the comment block up from the bottom, rather than starting in the middle of the page - but yeah...weird.

It is strange. The problem now is if you reverse the order, everyone
who took this into account and entered the comments so they would come
out in the proper order in the title block will not be happy. Is that a
big number of users? I don't know. There is an easy way to find out.
Change it and see who screams.

On 12/8/2015 9:37 AM, Chris Pavlina wrote:
> Yeah, but why should the default be backwards? I agree, it's weird. I
> think the original thought was something along the lines of building the
> comment block up from the bottom, rather than starting in the middle of
> the page - but yeah...weird.
>

Jeff Young (jeyjey) wrote :

I agree that this is sub-optimal, but I think there's too much water under the bridge now to get any ROI from changing it.

Changed in kicad:
status: Triaged → Won't Fix
Seth Hillbrand (sethh) wrote :

@Jeff- Why not just make a new file with the correct ordering but call it a different name (default_v51.page_layout)? Then make that the default project's new default page layout. Old files with no default layout specified get the old layout but upon saving, get their layout specified.

We probably shouldn't be keeping the "no filename means *this*" bits around anyway.

Jeff Young (jeyjey) wrote :

We could, but then we'd get a bunch of bugs "I upgraded to 5.1 and now I don't get my default page layout anymore".

We could of course answer all those questions (telling them to reset it in their project or copy it to the new name or whatever).

But is it worth it for something everyone's lived with for a very long time now?

(Note: not a rhetorical question. The answer may be "yes, it's worth it".)

Jeff Young (jeyjey) wrote :

(Just to be clear, I don't feel strongly. If someone else thinks it's worth it, feel free to set it back to "Confirmed".)

Seth Hillbrand (sethh) wrote :

I think so, yes. The more we can file down the unexpected corners, the better.

Changed in kicad:
status: Won't Fix → Triaged
milestone: none → 5.1.0
Leandro Heck (leoheck) wrote :

User comment here. I never bother to adjust or fix something on my projects
if the objective is to improve the software. I know I am using free and
open source tool and I am aware of the risks. Also, if this is a feature
for version 5.1, old projects will still look the same on version 5.0,
right?

On Sep 29, 2018 11:29, "Jeff Young" <email address hidden> wrote:

We could, but then we'd get a bunch of bugs "I upgraded to 5.1 and now I
don't get my default page layout anymore".

We could of course answer all those questions (telling them to reset it
in their project or copy it to the new name or whatever).

But is it worth it for something everyone's lived with for a very long
time now?

(Note: not a rhetorical question. The answer may be "yes, it's worth
it".)

--
You received this bug notification because you are subscribed to a
duplicate bug report (1789064).
https://bugs.launchpad.net/bugs/1523564

Title:
  Comments in Page Settings inverted order.

Status in KiCad:
  Won't Fix

Bug description:
  The enumeration of the comments in the Page Settings dialog for both
  Eeschema and Pcbnew are inverted in relation they show up in the
  actual sheet.

  Someone would expect Comment 1 to be placed on the top of the list.

  Eeschema:
  http://i.imgur.com/IbU5TFA.png

  Pcbnew:
  http://i.imgur.com/U8HZGGx.png

  Application: kicad
  Version: no-vcs-found-product release build
  wxWidgets: Version 3.0.2 (debug,wchar_t,compiler with C++ ABI 1009,GCC
5.2.0,wx containers,compatible with 2.8)
  Platform: Linux 4.2.5-1-ARCH i686, 32 bit, Little endian, wxGTK
  Boost version: 1.59.0
           USE_WX_GRAPHICS_CONTEXT=OFF
           USE_WX_OVERLAY=OFF
           KICAD_SCRIPTING=ON
           KICAD_SCRIPTING_MODULES=ON
           KICAD_SCRIPTING_WXPYTHON=ON
           USE_FP_LIB_TABLE=HARD_CODED_ON
           BUILD_GITHUB_PLUGIN=ON

To manage notifications about this bug go to:
https://bugs.launchpad.net/kicad/+bug/1523564/+subscriptions

Seth Hillbrand (sethh) wrote :

Yes, this would only be 5.1. It would only affect new projects not existing projects created before 5.1 and opened in 5.1. And it would only be noticeable if you add comments to the title block on your new schematic.

Wayne Stambaugh (stambaughw) wrote :

Version 5.1 is in feature freeze. Moving to 6.0.0 milestone.

Changed in kicad:
milestone: 5.1.0 → 6.0.0-rc1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers