page limits visible

Bug #1499285 reported by Novak Tamas on 2015-09-24
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
KiCad
Low
Jeff Young

Bug Description

I don't know if this is a bug. In pcbnew 2015-09-15 BZR6201 there is a Preferences - Display - Show page limits checkbox. If this refers to showing/hiding the double red frame with position numbers, then it doesn't work (OpenGL mode, Win7).
That frame is very annoying, as (for abs coordinates apply to my board) I place the top left corner of my pcb to (0;0), so frame covers my board.
I attached a printscreen, where two horizontal red lines at pin 56 and 60 are not tracks but the frame lines, and short segments at pin 57 and 59 are part of position number "1".
Please make it be able to hide.

Novak Tamas (novak-7) wrote :
Maciej Suminski (orsonmmz) wrote :

Indeed, GAL canvases do not respect the setting, but it toggles only the outer frame. The page template you are referring to, is always enabled as there is no option to disable it at the moment.

tags: added: cern gal pcbnew

Page limit does not refer to the border and title block. When enabled
in the legacy canvas, there is a light grey (assuming default color)
rectangle that defines the currently configured paper size. That being
said, I just noticed that the configuration setting for the page limit
is not being saved and/or loaded correctly on Pcbnew.

On 9/24/2015 6:22 AM, Novak Tamas wrote:
> Public bug reported:
>
> I don't know if this is a bug. In pcbnew 2015-09-15 BZR6201 there is a Preferences - Display - Show page limits checkbox. If this refers to showing/hiding the double red frame with position numbers, then it doesn't work (OpenGL mode, Win7).
> That frame is very annoying, as (for abs coordinates apply to my board) I place the top left corner of my pcb to (0;0), so frame covers my board.
> I attached a printscreen, where two horizontal red lines at pin 56 and 60 are not tracks but the frame lines, and short segments at pin 57 and 59 are part of position number "1".
> Please make it be able to hide.
>
> ** Affects: kicad
> Importance: Undecided
> Status: New
>
>
> ** Tags: frame hide page
>
> ** Attachment added: "Annoying_drawing_frame.jpg"
> https://bugs.launchpad.net/bugs/1499285/+attachment/4473180/+files/Annoying_drawing_frame.jpg
>

pipe (pipatron) wrote :

I'm not sure how to handle this bug report since the problem described by the title is different from the problem described in the body, but I went here to report the problem in the title: Show page limits.

This option does indeed work in legacy, but does not work for me in GAL. Enabling the option turns the page limit bright white, while disabling it turns the limit yellow.

Application: kicad
Version: (2016-01-04 BZR 6422, Git ed2a1d5)-product debug build
wxWidgets: Version 3.0.2 (debug,wchar_t,compiler with C++ ABI 1009,GCC 5.3.1,wx containers,compatible with 2.8)
Platform: Linux 4.3.0-1-amd64 x86_64, 64 bit, Little endian, wxGTK
Boost version: 1.58.0
libcurl version: 7.45.0 (with SSL - OpenSSL/1.0.2e)
         USE_WX_GRAPHICS_CONTEXT=OFF
         USE_WX_OVERLAY=OFF
         KICAD_SCRIPTING=ON
         KICAD_SCRIPTING_MODULES=ON
         KICAD_SCRIPTING_WXPYTHON=ON
         USE_FP_LIB_TABLE=HARD_CODED_ON
         BUILD_GITHUB_PLUGIN=ON

Novak Tamas (novak-7) wrote :

The annoying "double red frame with position numbers" I originally mentioned is not the "page limits", but the "layout".
That can be edited/disabled, pls read https://forum.kicad.info/t/setting-origin-of-coordinates/520.
In GAL mode (which will probably be the final and only working mode) you can't see page limits regardless of option ticked/unticked.
As I can't see any importance of this frame, "repairing this bug" should be removing "show page limits" checkbox; making the gray/yellow frame able to be seen in GAL mode is unneccessary.

xzcvczx (xzcvczx) on 2016-05-30
Changed in kicad:
importance: Undecided → Low
status: New → Confirmed
tags: removed: frame hide page
Nick Østergaard (nickoe) wrote :

The page limits option is still not honoured for GAL.
Version: (5.0-dev-4060-g28f1209ce), release build

Jeff Young (jeyjey) on 2018-07-01
Changed in kicad:
status: Confirmed → In Progress
assignee: nobody → Jeff Young (jeyjey)
milestone: none → 5.1.0
Jeff Young (jeyjey) on 2018-07-17
Changed in kicad:
status: In Progress → Fix Committed
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision df863e44e20c2eaf96fc4f9129a93b0aa19ca963
https://git.launchpad.net/kicad/patch/?id=df863e44e20c2eaf96fc4f9129a93b0aa19ca963

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers