gerbview not handling drill definitions correctly

Bug #1485420 reported by Mark Roszko on 2015-08-17
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KiCad
Low
Unassigned

Bug Description

Gerbview currently expects tool "information" to be defined in the header which includes drill size, etc.

Excellon drill format allows this to occur in the body as the C# and S# commands are defined in the program body section of the spec and must be coupled with the T#. In fact the "header" is considered optional in the excellon spec and the CNC will run any commands normally in the header in the body just fine.

PADS PCB generates Excellon files which do not include any tool info in the header.

I was going to fix this as I have loads of PADS PCB generated nc drill files to test with but just throwing this on here for documentation.

Related branches

Mark Roszko (mark-roszko) wrote :

Let me just throw up a drill file for reference.

tags: added: gerbview
Changed in kicad:
importance: Undecided → Low
Simon Wells (xzcvczx) wrote :

still an issue in 6813

Changed in kicad:
status: New → Confirmed
Simon Wells (xzcvczx) wrote :

commited in 6827

Changed in kicad:
status: Confirmed → Fix Committed
PCB Wiz (1-pcb-wiz) wrote :

Is there a schedule for this fix ?
I also tested GerbV, and it can import PADS Excellon info directly, without issues.

Besides the embedded tool info in PADS
%
T1C.02F197S550
X016000Y015500

I have found GerbView also coughs around G85 Slot G-Codes.
Not sure if this needs to be a separate bug ? (as it is all PADS-Excellon related)

PADS gives this (This loads OK in GerbV)
T3C.037F197S550
X044583Y026417G85X044710Y026290
X045290Y025710G85X045417Y025583
X045417Y016417G85X045290Y016290
X044710Y015710G85X044583Y015583

However, GerbView needs this small manual fix

T3
X044583Y026417G85X044710Y026290
X045290Y025710G85X045417Y025583
X045417Y016417G85X045290Y016290
X044710Y015710G85X044583Y015583
G05
T4

ie add the G05. I think GerbView is treating a G85 as sticky, and any holes after the above lines, are treated as slot-polylines, (oops) unless the G05 patch is added.

Fix is probably to make any new Tool code, also reset the G85 mode ?

PCB Wiz (1-pcb-wiz) wrote :

I also see there is a commercial product called GerbView, that has been around a while
http://www.softwarecompanions.com/gbupdate600.html

Shouldn't the KiCad Gerber Viewer be called something else, so as not to confuse Google Searches ?

GerbExView & GerbExViewer seem to be 'google open' (since it can read excellon files too..)
GerberViewer has one source forge hit.

Simon Wells (xzcvczx) wrote :

are you running stable or nightlies? this has been commited to the product branch but i am not sure if it is due to be in 4.0.3

PCB Wiz (1-pcb-wiz) wrote :

hmm, I was running 4.0.2, so I downloaded a KiCad nightly build from June 17, but looking carefully I see KiCAD is new but GerbView is still showing as 4.0.2 - looks like GerbView is not in the one I downloaded.

Is there a different place to download GerbView nightlies ?

PCB Wiz (1-pcb-wiz) wrote :

Also, Should I raise the G85 sticky bug (above) as a separate issue ?
I manually edited a DRL file until it imported, and that then reveals the G85 issue.

Nick Østergaard (nickoe) wrote :

@1-pcb-wiz, maybe you have gerbview.exe in multiple locaitons on your system? Try searching for it in program files and %appdata% for your user.

PCB Wiz (1-pcb-wiz) wrote :

Good question.
Search finds just the one, dated 29 Feb in the same dir as 18 june build installs.
Should Gerbview.exe have updated too, or it is not included in some nightly builds ?

Nick Østergaard (nickoe) wrote :

It should be updated too. There is no option in the installer to only install some of the "apps".

And is that in program files? Are you sure there is not a gerbview.exe in appdata roaming somewhere?

PCB Wiz (1-pcb-wiz) wrote :

OK, I'll try again..... maybe I slipped up...

All looks ok, on 20 June Build (r6943) AND the G85 issue also looks ok too :) Great!.

 I posted a screen shot of an OK import here (just point at files and load) :

https://forum.kicad.info/t/gerbview-reading-drill-file/2841/5

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers