missing buttons on eeschema erc dialog box

Bug #1483411 reported by Andrzej Michalec on 2015-08-10
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Unassigned

Bug Description

Three buttons on ERC dialog box are invisible, dialog has place for it but does not render it. Resizing window or moving around does not help. Sometimes when quickly moved some drawing garbage is frozen on buttons canvas. Other dialogs in eeschema/pcbnew render dialogs with buttons without any issues.

My platform is Windows 7 64-bit. When eeschema runs in compatibility mode with "disable visual themes" turned on, then buttons' blanks are visible on gray canvas (see screenshots attached). On vmware with Windows Server 2008 (OSX as host) it works fine so my best guess is its wxWidgets issue on 64-bit platform.

Kicad installer downloaded from mirror (http://www2.futureware.at/~nickoe/) linked on kicad-pcb.org website.

Application: kicad
Version: (2015-08-05 BZR 6055, Git fa29c62)-product release build
wxWidgets: Version 3.0.2 (debug,wchar_t,compiler with C++ ABI 1009,GCC 5.2.0,wx containers,compatible with 2.8)
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Boost version: 1.57.0
         USE_WX_GRAPHICS_CONTEXT=OFF
         USE_WX_OVERLAY=OFF
         KICAD_SCRIPTING=ON
         KICAD_SCRIPTING_MODULES=ON
         KICAD_SCRIPTING_WXPYTHON=ON
         USE_FP_LIB_TABLE=HARD_CODED_ON
         BUILD_GITHUB_PLUGIN=ON

Andrzej Michalec (jedreg) wrote :
Pol Welter (polwelter) wrote :

I can confirm this. It also occurs in the 6167 build downloaded from http://downloads.kicad-pcb.org/windows/

Application: kicad
Version: (2015-09-07 BZR 6167, Git 1689401)-product release build
wxWidgets: Version 3.0.2 (debug,wchar_t,compiler with C++ ABI 1009,GCC 5.2.0,wx containers,compatible with 2.8)
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Boost version: 1.57.0
         USE_WX_GRAPHICS_CONTEXT=OFF
         USE_WX_OVERLAY=OFF
         KICAD_SCRIPTING=ON
         KICAD_SCRIPTING_MODULES=ON
         KICAD_SCRIPTING_WXPYTHON=ON
         USE_FP_LIB_TABLE=HARD_CODED_ON
         BUILD_GITHUB_PLUGIN=ON

Can you test a rev >= BZR 6177 and see if still happens ?

Andrzej Michalec (jedreg) wrote :

I can confirm that 6177 fixes this issue on my machine. Thank you.

Changed in kicad:
status: New → Fix Committed
Pol Welter (polwelter) wrote :

Works for me as well. You guys are quick!
Thanks a lot!

Jon Neal (reportingsjr) on 2015-09-25
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments