Not all elements updated when language is changed

Bug #1392582 reported by Blair Bonnett on 2014-11-14
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
KiCad
Low
Jeff Young

Bug Description

When the language is changed, not all the GUI elements are updated. For example:

1. Start the main KiCad launcher (system language is English, so thats what it starts in).
2. Change the language to Polish. The menu entries change, but the tooltips of the toolbar buttons are still in English.
3. Start Pcbnew. Everything (including the tooltips) is in Polish.
4. Change the language back to English. The menus (both in the main launcher and Pcbnew) change to English, but the tooltips in Pcbnew are still Polish.

Is this an oversight in the internationalisation code, or is updating the tooltips not possible? If the latter, then maybe there should be a warning box (e.g., "Note that some text will not be translated until you restart KiCad") should be displayed?

Application: kicad
Version: (2014-11-13 BZR 5275)-BZR + patches Debug build
wxWidgets: Version 3.0.2 (debug,wchar_t,compiler with C++ ABI 1002,GCC 4.9.2,wx containers,compatible with 2.8)
Platform: Linux 3.17.2-1-ARCH x86_64, 64 bit, Little endian, wxGTK
Boost version: 1.57.0
         USE_WX_GRAPHICS_CONTEXT=OFF
         USE_WX_OVERLAY=OFF
         KICAD_SCRIPTING=ON
         KICAD_SCRIPTING_MODULES=ON
         KICAD_SCRIPTING_WXPYTHON=ON
         USE_FP_LIB_TABLE=HARD_CODED_ON
         BUILD_GITHUB_PLUGIN=ON

Blair Bonnett (bcb) wrote :

Tooltips aren't the only place this occurs, for example the rendering options in Pcbnew don't updated until after a complete restart. Bug 594098 mentions the 'text of the buttons' (possibly referring to the tooltips), and bug 594105 says some of the layers don't update (this may refer to the rendering options).

Changed in kicad:
importance: Undecided → Low
D. Stimits (stimits) wrote :

Actual language is not the only tooltip problem. Colors of mouse hover-over for tool tips do not accept desktop settings. Once any KDE/plasma/desktop theme is changed it seems nearly impossible to get a readable color...mostly it is white on white. I once found a working combination which wasn't white on white, which then went away after logging out and back in. Tooltip font color and background color should honor the desktop settings, but do not. This is a more serious bug than it sounds like, as it makes learning and using KiCad an extreme effort...one has to memorize the hover-over tooltip text by other means for any tooltip to be useful.

Blair Bonnett (bcb) wrote :

Unless I'm missing something, that appears to be a separate bug to this one. Could you please file a new report for it so we don't get mixed up trying to fix them both from the same report?

xzcvczx (xzcvczx) on 2016-05-29
Changed in kicad:
status: New → Confirmed
Andrey M (andrey.mrt.) wrote :

Including partial fix, more to follow.

Bug largely due to inconsistency in how language updates are handled.

Jeff Young (jeyjey) wrote :

Fixed the toolbar tooltips, the layers palette (including render stuff), and the status bar.

I'm attaching a patch in case anyone wants to take a look, but I think it should wait till after 5.0-stable is branched.

Jeff Young (jeyjey) on 2018-02-13
Changed in kicad:
milestone: none → 6.0.0-rc1
Jeff Young (jeyjey) on 2018-03-06
Changed in kicad:
status: Confirmed → In Progress
assignee: nobody → Jeff Young (jeyjey)
Jeff Young (jeyjey) wrote :

Fix committed to private 6.0 branch.

KiCad Janitor (kicad-janitor) wrote :

Fixed in revision aa0ae48dda4a61b7b072166f5b46cb5733bd55b1
https://git.launchpad.net/kicad/patch/?id=aa0ae48dda4a61b7b072166f5b46cb5733bd55b1

Changed in kicad:
status: In Progress → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers