Mirror printing gives misaligned print

Bug #1317715 reported by Amir on 2014-05-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Medium
Unassigned

Bug Description

Application: KiCad
Version: (2013-07-07 BZR 4022)-stable
Build: wxWidgets 2.9.4 (wchar_t,compiler with C++ ABI 1002,GCC 4.7.2,wx containers,compatible with 2.8)
Platform: Windows 7 (build 7600), 64-bit edition, 64 bit, Little endian, wxMSW
Boost version: 1.53.0
Options: USE_PCBNEW_NANOMETRES=ON
         KICAD_GOST=OFF
         USE_WX_GRAPHICS_CONTEXT=OFF
         USE_WX_OVERLAY=OFF
         KICAD_SCRIPTING=OFF
         KICAD_SCRIPTING_MODULES=OFF
         KICAD_SCRIPTING_WXPYTHON=OFF
------
Printer HP Pro 400.
Win 7

- when printing multiple normal prints of the attached file it gives a perfect copies.
- when trying to print 1 print normally, other print mirrored just to register them face to face, the mirrored print has big shift and misalignment.

Amir (alamir-ismail) wrote :
Martin Errenst (imp-d) on 2014-05-10
tags: added: printing

I don't understand your problem.

Amir (alamir-ismail) wrote :

When I print mirrored layers, the print out has shifts on pads location and margins. Below is example. Of the differences between normal and mirrored prints I got.

   | o. o. | normal print
    | o. o. | mirrored print , after flipping the trace paper.

Amir (alamir-ismail) wrote :

|o. o.|
 |o. o. |

Amir (alamir-ismail) wrote :

0. 0. Normal
0. 0. Mirrored

xzcvczx (xzcvczx) wrote :

Can you confirm if this is still an issue

Changed in kicad:
status: New → Incomplete

Should I install the new version first ?

Sent from Yahoo Mail on Android

  On Wed, 25 May, 2016 at 11:36, Simon Wells<email address hidden> wrote: Can you confirm if this is still an issue

** Changed in: kicad
      Status: New => Incomplete

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1317715

Title:
  Mirror printing gives misaligned print

Status in KiCad:
  Incomplete

Bug description:
  Application: KiCad
  Version: (2013-07-07 BZR 4022)-stable
  Build: wxWidgets 2.9.4 (wchar_t,compiler with C++ ABI 1002,GCC 4.7.2,wx containers,compatible with 2.8)
  Platform: Windows 7 (build 7600), 64-bit edition, 64 bit, Little endian, wxMSW
  Boost version: 1.53.0
  Options: USE_PCBNEW_NANOMETRES=ON
          KICAD_GOST=OFF
          USE_WX_GRAPHICS_CONTEXT=OFF
          USE_WX_OVERLAY=OFF
          KICAD_SCRIPTING=OFF
          KICAD_SCRIPTING_MODULES=OFF
          KICAD_SCRIPTING_WXPYTHON=OFF
  ------
  Printer HP Pro 400.
  Win 7

  - when printing multiple normal prints of the attached file it gives a perfect copies.
  - when trying to print 1 print normally, other print mirrored just to register them face to face, the mirrored print has big shift and misalignment.

To manage notifications about this bug go to:
https://bugs.launchpad.net/kicad/+bug/1317715/+subscriptions

xzcvczx (xzcvczx) wrote :

yes please try 4.0.2 stable version

Novak Tamas (novak-7) wrote :

I've printed the attached pattern to my Samsung b/w laser with normal and mirror options (the only difference between prints is the "mirror" checkbox).

I made a photo of the two sheets. The line thicknesses are very different (as you can see on my little blunt picture "normal-and-mirrored-print.jpg").

Then I flipped the mirrored print and layed over the normal one. Aligned the frames (back lighted through both paper), and patterns *are* really misaligned (thin line print in foreground, thicker in background).

There are large dots around the frame. They are also misaligned if frames are aligned. On the other hand if I align big dots, PCB patterns *are* aligned, but frame gets misaligned.

Changed in kicad:
status: Incomplete → Confirmed
importance: Undecided → Low
Jeff Young (jeyjey) on 2019-03-05
Changed in kicad:
importance: Low → Medium
Wayne Stambaugh (stambaughw) wrote :

@Jeff, I think this was addressed with Orson's Cairo print changes. I have not seeing the mirrored print issue since these changes were made. This bug report is against the stable version before 4.0 so it is really old.

Jeff Young (jeyjey) wrote :

Excellent. I'll set it to Fix Committed.

Changed in kicad:
status: Confirmed → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers