kicad smd_transistors library has incorrect sot23 pin numbers

Bug #1315591 reported by David Zanetti on 2014-05-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Unassigned

Bug Description

The standard kicad library (at least in 2013-mar-13 -testing) smd_transistors.mod has an sot23 footprint with pin numbering that is not the commonly used sot23 layout.

The most common layout is:

   3
BODY
 1 2

With the pins numbered anti clockwise as is normally the case with most ICs. This makes pin 3 the pin on the single-pin side of an sot23.

The package in smd_transistors has them numbered this way:

   2
BODY
 1 3

With the single pin side being given pin 2. Very few sot23 devices use this layout.

This caught me out on a PCB I had manufactured. I should still have checked every pin-out provided, but I missed this one :(

Kerusey Karyu (keruseykaryu) wrote :

Smd_transistors.mod can not be fixed because *.mod files became obsolete and were removed from library repository in rev. 301.

However, this error moved to the new files in the S-expression format available in Git repository. So, I'll pay attention to it there.

Changed in kicad:
status: New → Confirmed
xzcvczx (xzcvczx) on 2016-05-25
Changed in kicad:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers