Comment 9 for bug 1171160

On Apr 26, 2013 12:46 AM, "Bernd Wiebus" <email address hidden> wrote:
>
> Hello Dick.
>
> > This is almost certainly a bug in wx, and one that we cannot work around
> > other than avoiding use of that character in such a context.
> >
>
> Yes, normaly i am very carefully and using only the numbers, the letters
> without special signs, a "-" and a "_" for file names. A point only to
> discriminate suffixes......I do not now anymore, which devil rode me at
> 2010 to use an ampersand at a file name. Perhaps it was derived from a
> firm name with an ampersand in....
>
> > The true fix would be to report it to the wxWidgets team, and get it
> > fixed there. It is not a critical bug. I am marking as won't fix and
> > not critical.
> >
>
> Ok, i made some remarks about this bug at a german kicad FAQ
>
http://www.mikrocontroller.net/articles/KiCAD#Tipps.26Tricks_.2F_Eigenheiten_.2F_Bugs
> So somebody would find clues about whats going on, if he notice this
> strange behavior.
>
> > Thanks for reporting it, and if you are ambitious, you could file it
> > with wxWidgets team and refer to this bug report in your report over
> > there.
>
> The wx librarys are C/C++ librarys i think. I do not know any C/C++. So
> my reporting to the wx team would be an unintelligible stammering.

Just asking that you post the url to this discussion over there. Nothing
more required of you than your time. Which is what you are asking of us.
Once they read this thread, it will get fixed and many months later it will
go away from kicad.

I am taking no further action, it is up to you.

 I can
> nothing tell about whats going on. I can only tell what happens if i use
> programs at a certain way....
>
> But you see what Mr. Charras wrote about this bug. So this has to be
> proofed first. It would not be fair to blame the wx team for nothing.
>
> Yet another topic: What is with Bug 1171171 ?
> https://bugs.launchpad.net/kicad/+bug/1171171
>
> With best regards: Bernd Wiebus alias dl1eic
>
>
>
> Adresse:
> Dipl.-Ing. Bernd Wiebus, CID+
> Weezer Str. 5
> 47589 Uedem
> Tel. 02825-9399977 (fest)
> 0162-6157950 (mob.)
>
> E-Mail: <email address hidden>
>
> --
> You received this bug notification because you are a member of KiCad Bug
> Squad, which is subscribed to KiCad.
> https://bugs.launchpad.net/bugs/1171160
>
> Title:
> SVG-Plot fails with ampersand in schematic or board filename
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1171160/+subscriptions