Applications started from KiCad.app are in the background on OSX 10.8

Bug #1154859 reported by Moritz Heuser on 2013-03-13
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
KiCad
Medium
Jeff Young

Bug Description

Build: (2013-mar-09)-testing
wxWidgets 2.9.5 Unicode and boost C++ libraries
OSX 10.8

If you start one of the KiCad applications (eeschema, cvpcb, ...) from the KiCad application the application will be started in the background. It makes no difference if started from on of the buttons or by double clicking on a project file.

As far as my investigations went it is a problem with the implementation of wxExecute which is using an NSTask internally.

I attached a (buggy) workaround , the buggy part is that eeschema is not seeing the KiCad libraries if started via "open".

Tags: osx Edit Tag help
Moritz Heuser (moritz-heuser) wrote :
Martin Errenst (imp-d) on 2014-02-22
tags: added: osx
Changed in kicad:
assignee: nobody → Marco Serantoni (marco-serantoni)

Moritz,
Soon Kicad will be one executable only with dynamic loading objects so that code will be obsoleted soon.

Sincerelly i prefer that users clicks on the application already launched than eeschema doesn't find libraries.
One is a cosmetic bug, the other is a functional one.

I'll set that as Opinion because i wish to discuss with you about this issue once you know also the background.
And i wish keep open the dialog before bashing it.

Thank you for your report, sincerely.
Marco

Changed in kicad:
status: New → Opinion
Moritz Heuser (moritz-heuser) wrote :

Hi Marco,

this patch was more intended to show where this issue originates. Also, in my opinion, this should be fixed in wxWidgets. So do with it what you like to. I will still report or even try to fix bugs if I find one.

Have a nice weekend,
Moritz

Jeff Young (jeyjey) wrote :

I'm going to give another look at this for 6.0 as it's rather annoying.

Changed in kicad:
assignee: Marco Serantoni (marco-serantoni) → nobody
status: Opinion → New
status: New → Confirmed
Jeff Young (jeyjey) on 2018-07-27
Changed in kicad:
importance: Undecided → Medium

Jeff, before you get started on this, let's talk!

On Fri, Jul 27, 2018, 6:35 AM Jeff Young <email address hidden> wrote:

> ** Changed in: kicad
> Importance: Undecided => Medium
>
> --
> You received this bug notification because you are subscribed to KiCad.
> Matching subscriptions: OS X KiCad bugs
> https://bugs.launchpad.net/bugs/1154859
>
> Title:
> Applications started from KiCad.app are in the background on OSX 10.8
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1154859/+subscriptions
>

Jeff Young (jeyjey) wrote :

He he… you’ll note I didn’t assign it to myself. ;)

> On 27 Jul 2018, at 12:50, Adam Wolf <email address hidden> wrote:
>
> Jeff, before you get started on this, let's talk!
>
> On Fri, Jul 27, 2018, 6:35 AM Jeff Young <email address hidden>
> wrote:
>
>> ** Changed in: kicad
>> Importance: Undecided => Medium
>>
>> --
>> You received this bug notification because you are subscribed to KiCad.
>> Matching subscriptions: OS X KiCad bugs
>> https://bugs.launchpad.net/bugs/1154859
>>
>> Title:
>> Applications started from KiCad.app are in the background on OSX 10.8
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/kicad/+bug/1154859/+subscriptions
>>
>
> --
> You received this bug notification because you are a member of KiCad Bug
> Squad, which is subscribed to KiCad.
> https://bugs.launchpad.net/bugs/1154859
>
> Title:
> Applications started from KiCad.app are in the background on OSX 10.8
>
> Status in KiCad:
> Confirmed
>
> Bug description:
> Build: (2013-mar-09)-testing
> wxWidgets 2.9.5 Unicode and boost C++ libraries
> OSX 10.8
>
> If you start one of the KiCad applications (eeschema, cvpcb, ...) from
> the KiCad application the application will be started in the
> background. It makes no difference if started from on of the buttons
> or by double clicking on a project file.
>
> As far as my investigations went it is a problem with the
> implementation of wxExecute which is using an NSTask internally.
>
> I attached a (buggy) workaround , the buggy part is that eeschema is
> not seeing the KiCad libraries if started via "open".
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1154859/+subscriptions

Jeff Young (jeyjey) wrote :

@Adam, I was thinking about taking a look at this. Any words of wisdom for me?

Adam Wolf (adamwolf) wrote :

Having subbundles inside of bundles (like we do now) is not something that
we can have a valid signature on. I would love to provide a real signed
set of bundles for KiCad.

I have thought about how to get around this. A few options:

1) Just copy, instead of symlink. This may be fine, actually. I would
like to talk to Bernhard about this.

2) Make kicad.app look at the type of file it's opening, and do different
things depending on it. For instance, if you give it a .pro file, or no
file, it opens up as a project manager. If you give it a .kicad_pcb file,
it opens as pcbnew.

3) Other cool things I don't even know about.

If your work here ends up being large, maybe let's get a plan of attack for
this whole thing first. If it looks like it might be a little tweak, go
for it.

Thoughts?

On Fri, Sep 21, 2018 at 9:10 AM Jeff Young <email address hidden>
wrote:

> @Adam, I was thinking about taking a look at this. Any words of wisdom
> for me?
>
> --
> You received this bug notification because you are subscribed to KiCad.
> Matching subscriptions: OS X KiCad bugs
> https://bugs.launchpad.net/bugs/1154859
>
> Title:
> Applications started from KiCad.app are in the background on OSX 10.8
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1154859/+subscriptions
>

Jeff Young (jeyjey) on 2018-11-13
Changed in kicad:
assignee: nobody → Jeff Young (jeyjey)
milestone: none → 5.1.0
status: Confirmed → In Progress
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 8725511c3cc0e418d671ffcb05c72f7f50302e7d
https://git.launchpad.net/kicad/patch/?id=8725511c3cc0e418d671ffcb05c72f7f50302e7d

Changed in kicad:
status: In Progress → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers