kicawinbuilder 3.4-2 do not update kicad version after a building

Bug #1333243 reported by m on 2014-06-23
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
kicad-winbuilder
Medium
Brian Sidebotham

Bug Description

hi,
I've downloaded the new kicadwinbuilder version
https://launchpad.net/kicad-winbuilder/trunk/kicad-winbuilder-3.4/+download/kicad-winbuilder-3.4-2.7z

everything is fine for building the apps, but when there is a new the product release, the builder builds up all the applications, but the version of kicad is not updated...

following the log messages after a build of version 4952 (first build run) and a new build following the version 4953 ...

Microsoft Windows [Version 6.2.9200]
(c) 2012 Microsoft Corporation. All rights reserved.

C:\kw34p>make
-- KiCad-Winbuilder V3.4
-- Parallel build using 3 Processors
-- Build type: Release
-- Checking for environment problems
-- Checking for installed Bazaar
-- Checking for wxPython
-- Found wxPython
-- Downloading Latest Library Archive...
-- Checking for KiCad Documentation latest source
-- KiCad Documentation is up-to-date.
-- Checking for BZIP2
-- Checking for GLEW
-- Found GLEW
-- Checking for Cairo
-- Found Cairo
-- Checking for KiCad latest source code
-- Updating KiCad source code from bazaar head
-- Cleaning PCBNEW Python files to ensure good build...
-- Using KiCad Options:
-- -DKICAD_SCRIPTING=ON
-- -DKICAD_SCRIPTING_MODULES=ON
-- -DKICAD_SCRIPTING_WXPYTHON=ON
-- -DPYTHON_ROOT_DIR=C:/kw34p/env/python
-- -DBUILD_GITHUB_PLUGIN=ON
-- Building Release version of KiCad revision: 4953

[ 0%] [ 0%] Built target boost
Built target lib-dependencies
[ 1%] Built target openssl
[ 1%] Built target lib_dxf
[ 2%] Built target potrace
[ 2%] Built target idfcyl
[ 2%] Built target idfrect
[ 32%] Built target bitmaps
[ 33%] Built target idf3
[ 33%] Generating headers containing GLSL source code
[ 33%] Built target shader_headers
[ 33%] Built target 3d-viewer
[ 33%] Built target avhttp
[ 34%] Built target pcad2kicadpcb
[ 34%] Built target polygon
[ 34%] Built target dxf2idf
[ 34%] Built target idf2vrml
[ 38%] Built target pcbcommon
[ 39%] Built target gal
[ 39%] Built target github_plugin
[ 47%] Built target common
[ 49%] Built target pnsrouter
[ 50%] Built target cvpcb_kiface
[ 50%] Swig source
[ 53%] Built target gerbview_kiface
[ 53%] Generating pcbnew_wrap.cxx, pcbnew.py
[ 63%] Built target eeschema_kiface
swig_import_helper fixed for C:/kw34p/build/Release/pcbnew/pcbnew.py
[ 64%] Built target pl_editor_kiface
[ 65%] Built target bitmap2component
[ 67%] Built target pcb_calculator_kiface
[ 68%] Built target kicad
[ 68%] Built target cvpcb
[ 69%] Built target eeschema
[ 69%] Built target gerbview
[ 70%] Built target pl_editor
[ 70%] Built target pcb_calculator
Scanning dependencies of target pcbnew_kiface
[ 70%] Building CXX object pcbnew/CMakeFiles/pcbnew_kiface.dir/pcbnew_wrap.cxx.o
bj
Scanning dependencies of target _pcbnew
[ 70%] Building CXX object pcbnew/CMakeFiles/_pcbnew.dir/scripting/pcbnewPYTHON_
wrap.cxx.obj
Linking CXX shared module _pcbnew.kiface
Linking CXX shared module _pcbnew.pyd
[ 84%] Built target pcbnew_kiface
[ 84%] Built target pcbnew
[ 84%] Fixing swig_import_helper in Kicad scripting
swig_import_helper fixed for C:/kw34p/build/Release/pcbnew/pcbnew.py
[ 84%] Built target FixSwigImportsScripting
[ 98%] Built target _pcbnew
[100%] Fixing swig_import_helper in Kicad scripting modules
swig_import_helper fixed for C:/kw34p/build/Release/pcbnew/pcbnew.py
[100%] Built target FixSwigImportsModuleScripting
-- Installing KiCad locally. Use RunKiCad.bat to run this version
-- Downloading runtime libraries..
Press any key to continue . . .

Related branches

m (easyw) wrote :
Maciej Suminski (orsonmmz) wrote :

Hi m,

It seems to work the same way with Linux builds. Once version.h file is created, the version stored inside is used until it is removed.

Regards,
Orson

Download full text (4.8 KiB)

Actually, this is a bug in the kicad source. It didn't used to be broken.
There is a call to " make rebuild_cache" in kicad- winbuilder and as is
noted on version.h it was designed to re-generate the version information.
The kicad cmakelists.txt would have to be fixed to fix this bug.
 On 23 Jun 2014 14:15, "Maciej Sumiński" <email address hidden> wrote:

> Hi m,
>
> It seems to work the same way with Linux builds. Once version.h file is
> created, the version stored inside is used until it is removed.
>
> Regards,
> Orson
>
> --
> You received this bug notification because you are a member of Valvers
> GCode Committers, which is subscribed to kicad-winbuilder.
> Matching subscriptions: winbuilder-bugs
> https://bugs.launchpad.net/bugs/1333243
>
> Title:
> kicawinbuilder 3.4-2 do not update kicad version after a building
>
> Status in KiCad Windows Builder:
> New
>
> Bug description:
> hi,
> I've downloaded the new kicadwinbuilder version
>
> https://launchpad.net/kicad-winbuilder/trunk/kicad-winbuilder-3.4/+download/kicad-winbuilder-3.4-2.7z
>
> everything is fine for building the apps, but when there is a new the
> product release, the builder builds up all the applications, but the
> version of kicad is not updated...
>
> following the log messages after a build of version 4952 (first build
> run) and a new build following the version 4953 ...
>
> Microsoft Windows [Version 6.2.9200]
> (c) 2012 Microsoft Corporation. All rights reserved.
>
> C:\kw34p>make
> -- KiCad-Winbuilder V3.4
> -- Parallel build using 3 Processors
> -- Build type: Release
> -- Checking for environment problems
> -- Checking for installed Bazaar
> -- Checking for wxPython
> -- Found wxPython
> -- Downloading Latest Library Archive...
> -- Checking for KiCad Documentation latest source
> -- KiCad Documentation is up-to-date.
> -- Checking for BZIP2
> -- Checking for GLEW
> -- Found GLEW
> -- Checking for Cairo
> -- Found Cairo
> -- Checking for KiCad latest source code
> -- Updating KiCad source code from bazaar head
> -- Cleaning PCBNEW Python files to ensure good build...
> -- Using KiCad Options:
> -- -DKICAD_SCRIPTING=ON
> -- -DKICAD_SCRIPTING_MODULES=ON
> -- -DKICAD_SCRIPTING_WXPYTHON=ON
> -- -DPYTHON_ROOT_DIR=C:/kw34p/env/python
> -- -DBUILD_GITHUB_PLUGIN=ON
> -- Building Release version of KiCad revision: 4953
>
> [ 0%] [ 0%] Built target boost
> Built target lib-dependencies
> [ 1%] Built target openssl
> [ 1%] Built target lib_dxf
> [ 2%] Built target potrace
> [ 2%] Built target idfcyl
> [ 2%] Built target idfrect
> [ 32%] Built target bitmaps
> [ 33%] Built target idf3
> [ 33%] Generating headers containing GLSL source code
> [ 33%] Built target shader_headers
> [ 33%] Built target 3d-viewer
> [ 33%] Built target avhttp
> [ 34%] Built target pcad2kicadpcb
> [ 34%] Built target polygon
> [ 34%] Built target dxf2idf
> [ 34%] Built target idf2vrml
> [ 38%] Built target pcbcommon
> [ 39%] Built target gal
> [ 39%] Built target github_plugin
> [ 47%] Built target common
> [ 49%] Built target pnsrouter
> [ 50%] Built target cvpcb_kifac...

Read more...

m (easyw) wrote :

this is a workaround to align version nbr in kicad winbuilder...
thanks for the tool
Maurice

Download full text (4.7 KiB)

Thanks.

I will look at the KiCad source and commit a fix when I get time.
Thanks for the bug report!

Best Regards,

Brian.

On 24 June 2014 09:07, m <email address hidden> wrote:
> this is a workaround to align version nbr in kicad winbuilder...
> thanks for the tool
> Maurice
>
> ** Patch added: "workaround to align version nbr"
> https://bugs.launchpad.net/kicad-winbuilder/+bug/1333243/+attachment/4137973/+files/KiCadWinbuilder.diff
>
> --
> You received this bug notification because you are a member of Valvers
> GCode Committers, which is subscribed to kicad-winbuilder.
> Matching subscriptions: winbuilder-bugs
> https://bugs.launchpad.net/bugs/1333243
>
> Title:
> kicawinbuilder 3.4-2 do not update kicad version after a building
>
> Status in KiCad Windows Builder:
> New
>
> Bug description:
> hi,
> I've downloaded the new kicadwinbuilder version
> https://launchpad.net/kicad-winbuilder/trunk/kicad-winbuilder-3.4/+download/kicad-winbuilder-3.4-2.7z
>
> everything is fine for building the apps, but when there is a new the
> product release, the builder builds up all the applications, but the
> version of kicad is not updated...
>
> following the log messages after a build of version 4952 (first build
> run) and a new build following the version 4953 ...
>
> Microsoft Windows [Version 6.2.9200]
> (c) 2012 Microsoft Corporation. All rights reserved.
>
> C:\kw34p>make
> -- KiCad-Winbuilder V3.4
> -- Parallel build using 3 Processors
> -- Build type: Release
> -- Checking for environment problems
> -- Checking for installed Bazaar
> -- Checking for wxPython
> -- Found wxPython
> -- Downloading Latest Library Archive...
> -- Checking for KiCad Documentation latest source
> -- KiCad Documentation is up-to-date.
> -- Checking for BZIP2
> -- Checking for GLEW
> -- Found GLEW
> -- Checking for Cairo
> -- Found Cairo
> -- Checking for KiCad latest source code
> -- Updating KiCad source code from bazaar head
> -- Cleaning PCBNEW Python files to ensure good build...
> -- Using KiCad Options:
> -- -DKICAD_SCRIPTING=ON
> -- -DKICAD_SCRIPTING_MODULES=ON
> -- -DKICAD_SCRIPTING_WXPYTHON=ON
> -- -DPYTHON_ROOT_DIR=C:/kw34p/env/python
> -- -DBUILD_GITHUB_PLUGIN=ON
> -- Building Release version of KiCad revision: 4953
>
> [ 0%] [ 0%] Built target boost
> Built target lib-dependencies
> [ 1%] Built target openssl
> [ 1%] Built target lib_dxf
> [ 2%] Built target potrace
> [ 2%] Built target idfcyl
> [ 2%] Built target idfrect
> [ 32%] Built target bitmaps
> [ 33%] Built target idf3
> [ 33%] Generating headers containing GLSL source code
> [ 33%] Built target shader_headers
> [ 33%] Built target 3d-viewer
> [ 33%] Built target avhttp
> [ 34%] Built target pcad2kicadpcb
> [ 34%] Built target polygon
> [ 34%] Built target dxf2idf
> [ 34%] Built target idf2vrml
> [ 38%] Built target pcbcommon
> [ 39%] Built target gal
> [ 39%] Built target github_plugin
> [ 47%] Built target common
> [ 49%] Built target pnsrouter
> [ 50%] Built target cvpcb_kiface
> [ 50%] Swig source
> [ 53%] Built target gerbview_kiface
> [ 53%] Genera...

Read more...

Ian Woloschin (iwoloschin) wrote :

I noticed this problem, but figured it was due to some of my own tinkering. I noticed that the rebuild-cache log file was always empty, so I tee'd the rebuild-cache command to make sure it was running. Once I did that the version.h file was correctly regenerated.

Download full text (4.7 KiB)

Thanks for the information Ian,

Perhaps then Winbuilder is still the source of the problem.

Best Regards, Brian.

On 25 June 2014 15:42, Ian Woloschin <email address hidden> wrote:
> I noticed this problem, but figured it was due to some of my own
> tinkering. I noticed that the rebuild-cache log file was always empty,
> so I tee'd the rebuild-cache command to make sure it was running. Once
> I did that the version.h file was correctly regenerated.
>
> --
> You received this bug notification because you are a member of Valvers
> GCode Committers, which is subscribed to kicad-winbuilder.
> Matching subscriptions: winbuilder-bugs
> https://bugs.launchpad.net/bugs/1333243
>
> Title:
> kicawinbuilder 3.4-2 do not update kicad version after a building
>
> Status in KiCad Windows Builder:
> New
>
> Bug description:
> hi,
> I've downloaded the new kicadwinbuilder version
> https://launchpad.net/kicad-winbuilder/trunk/kicad-winbuilder-3.4/+download/kicad-winbuilder-3.4-2.7z
>
> everything is fine for building the apps, but when there is a new the
> product release, the builder builds up all the applications, but the
> version of kicad is not updated...
>
> following the log messages after a build of version 4952 (first build
> run) and a new build following the version 4953 ...
>
> Microsoft Windows [Version 6.2.9200]
> (c) 2012 Microsoft Corporation. All rights reserved.
>
> C:\kw34p>make
> -- KiCad-Winbuilder V3.4
> -- Parallel build using 3 Processors
> -- Build type: Release
> -- Checking for environment problems
> -- Checking for installed Bazaar
> -- Checking for wxPython
> -- Found wxPython
> -- Downloading Latest Library Archive...
> -- Checking for KiCad Documentation latest source
> -- KiCad Documentation is up-to-date.
> -- Checking for BZIP2
> -- Checking for GLEW
> -- Found GLEW
> -- Checking for Cairo
> -- Found Cairo
> -- Checking for KiCad latest source code
> -- Updating KiCad source code from bazaar head
> -- Cleaning PCBNEW Python files to ensure good build...
> -- Using KiCad Options:
> -- -DKICAD_SCRIPTING=ON
> -- -DKICAD_SCRIPTING_MODULES=ON
> -- -DKICAD_SCRIPTING_WXPYTHON=ON
> -- -DPYTHON_ROOT_DIR=C:/kw34p/env/python
> -- -DBUILD_GITHUB_PLUGIN=ON
> -- Building Release version of KiCad revision: 4953
>
> [ 0%] [ 0%] Built target boost
> Built target lib-dependencies
> [ 1%] Built target openssl
> [ 1%] Built target lib_dxf
> [ 2%] Built target potrace
> [ 2%] Built target idfcyl
> [ 2%] Built target idfrect
> [ 32%] Built target bitmaps
> [ 33%] Built target idf3
> [ 33%] Generating headers containing GLSL source code
> [ 33%] Built target shader_headers
> [ 33%] Built target 3d-viewer
> [ 33%] Built target avhttp
> [ 34%] Built target pcad2kicadpcb
> [ 34%] Built target polygon
> [ 34%] Built target dxf2idf
> [ 34%] Built target idf2vrml
> [ 38%] Built target pcbcommon
> [ 39%] Built target gal
> [ 39%] Built target github_plugin
> [ 47%] Built target common
> [ 49%] Built target pnsrouter
> [ 50%] Built target cvpcb_kiface
> [ 50%] Swig source
> [ 53%] Built target gerbview_kiface
> ...

Read more...

m (easyw) wrote :

hi Ian,
could you please post the code?

thank you
Maurice

Ian Woloschin (iwoloschin) wrote :

Here's the code block for the rebuild_cache command. You can see I just commented out the OUTPUT_FILE line and used the existing tee command, just like done one block below for the full build.

execute_process(
    COMMAND ${MINGW_MAKE} ${MAKE_KI_OPTS} rebuild_cache
    COMMAND ${TEE_COMMAND} "${LOGDIR}/make_${BUILD}_cache.log"
 WORKING_DIRECTORY "${BUILDDIR}/${BUILD}"
# OUTPUT_FILE "${LOGDIR}/make_${BUILD}_cache.log"
    ERROR_FILE "${LOGDIR}/make_${BUILD}_cache.log"
    RESULT_VARIABLE kicad_NOT_BUILT )

I've got no idea why this worked, but I noticed the problem, made the above change, and then ran it while I took care of a few other things. When I saw it worked I forgot to follow up on why exactly it was broken in the first place.

m (easyw) wrote :

thanks :)

Changed in kicad-winbuilder:
importance: Undecided → Medium
assignee: nobody → Brian Sidebotham (brian-sidebotham)
Changed in kicad-winbuilder:
status: New → Fix Committed
Changed in kicad-winbuilder:
status: Fix Committed → Fix Released
Benjamin (bvernoux) wrote :

This bug is always present in kicad-winbuilder-3.4-3

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers