Identity API v3 (CURRENT) in Identity API Reference: PUT method for "Add user to group" returns 204 on success, not 200 as written

Bug #1784375 reported by Bruno Canning
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Identity (keystone)
Low
Bi wei

Bug Description

- [x] This doc is inaccurate in this way: PUT method for "Add user to group" returns 204 on success, not 200 as written
- [ ] This is a doc addition request.
- [ ] I have a fix to the document that I can paste below including example: input and output.

Hi Folks,

The PUT method for adding users to a group returns http code 204 (No Content) on success, not 200 (OK) as written in the document. I am using the "Queens" release and made the call to API "v3" with the URL "http://host.com:35357/v3/groups/{group_id}/users/{user_id}" via the http "PUT" method.

I have reproduced this five times with the same result each time.

Best wishes,
Bruno

If you have a troubleshooting or support issue, use the following resources:

 - Ask OpenStack: http://ask.openstack.org
 - The mailing list: http://lists.openstack.org
 - IRC: 'openstack' channel on Freenode

-----------------------------------
Release: v3.10 on 'Fri Jul 27 04:40:31 2018, commit 31e1a4d'
SHA:
Source: Can't derive source file URL
URL: https://developer.openstack.org/api-ref/identity/v3/index.html

wangxiyuan (wangxiyuan)
Changed in keystone:
status: New → Confirmed
Gage Hugo (gagehugo)
Changed in keystone:
importance: Undecided → Low
tags: added: documentation low-hanging-fruit
Bi wei (biwei)
Changed in keystone:
assignee: nobody → Bi wei (biwei)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to keystone (master)

Fix proposed to branch: master
Review: https://review.openstack.org/587262

Changed in keystone:
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to keystone (master)

Reviewed: https://review.openstack.org/587262
Committed: https://git.openstack.org/cgit/openstack/keystone/commit/?id=68dfd78c359098bf6a77d0668f09ec3d6efa0ad1
Submitter: Zuul
Branch: master

commit 68dfd78c359098bf6a77d0668f09ec3d6efa0ad1
Author: biwei <kkttaa678@163.com>
Date: Mon Jul 30 21:51:47 2018 -0400

    Api-ref: Correct response code

    The response code for PUT /groups/{group_id}/users/{user_id} should be 204, not 200.

    Closes-bug: #1784375
    Change-Id: I73705131f15dc7df764de21ad116f28e77230b6e

Changed in keystone:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/keystone 14.0.0.0rc1

This issue was fixed in the openstack/keystone 14.0.0.0rc1 release candidate.

Changed in keystone:
milestone: none → rocky-rc1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers