stable/ocata requirements mismatch (pika and iso8601)

Bug #1721402 reported by Stuart Rench on 2017-10-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Identity (keystone)
Undecided
Unassigned
oslo.utils
Undecided
Unassigned

Bug Description

When installing keystone from the GitHub (https://github.com/openstack/keystone/tree/stable/ocata),
there are 2 packages that cause issues with proper functionality.

The first is pika. When starting the service it says that pika must be >0.9.0 but <0.11.0, however, the requirements.txt file allows for 0.11.0 to be installed.

The second is iso8601. The service will stand up just fine, but when attempting to log in, the service will fail to authenticate due to the inability for oslo_utils timeparser to be able to parse a time in the following format:
2010-01-01T12:00:00UTC+01:00

Further investigation shows that version 0.1.12 broke this change (https://bitbucket.org/micktwomey/pyiso8601/). Downgrading iso8601 to 0.1.11 resolves the issue.

Lance Bragstad (lbragstad) wrote :

The first requirement doesn't seem to be used in keystone at all. It must be getting pulled in due to a transitive dependency somewhere?

The second seems specific to oslo_utils and not keystone. Add oslo to this bug report so that we can get some more eyes on this.

I'm unsure how to fix this from a keystone perspective, unless the fix lands in oslo and we bump stable requirements (which there is a process around).

Changed in keystone:
status: New → Incomplete
Matthew Thode (prometheanfire) wrote :

Ocata upper-constraints.txt (what's tested in openstack gates) is pinned to 0.1.11 already. For co-installability please use upper-constraints.txt.

https://github.com/openstack/requirements/blob/stable/ocata/upper-constraints.txt#L165

ChangBo Guo(gcb) (glongwave) wrote :

yes, we need honor the upper-constraints.txt

BTW, 0.1.12 iso8601 is reported in https://bugs.launchpad.net/oslo.utils/+bug/1744160

Changed in oslo.utils:
status: New → Won't Fix
Colleen Murphy (krinkle) wrote :

Setting to won't fix for keystone as well. You can install with -c requirements/upper-constraints.txt to ensure dependencies are constrained to known working versions.

Changed in keystone:
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers