Minimum requirements too low on oslo.log for keystone

Bug #1628883 reported by Dr. Jens Harbott on 2016-09-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Identity (keystone)
Undecided
Unassigned
keystone (Ubuntu)
Undecided
Corey Bryant

Bug Description

After upgrading keystone from mitaka to newton-rc1 on Xenial I am getting this error:

$ keystone-manage db_sync
Traceback (most recent call last):
  File "/usr/bin/keystone-manage", line 6, in <module>
    from keystone.cmd.manage import main
  File "/usr/lib/python2.7/dist-packages/keystone/cmd/manage.py", line 32, in <module>
    from keystone.cmd import cli
  File "/usr/lib/python2.7/dist-packages/keystone/cmd/cli.py", line 28, in <module>
    from keystone.cmd import doctor
  File "/usr/lib/python2.7/dist-packages/keystone/cmd/doctor/__init__.py", line 13, in <module>
    from keystone.cmd.doctor import caching
  File "/usr/lib/python2.7/dist-packages/keystone/cmd/doctor/caching.py", line 13, in <module>
    import keystone.conf
  File "/usr/lib/python2.7/dist-packages/keystone/conf/__init__.py", line 26, in <module>
    from keystone.conf import default
  File "/usr/lib/python2.7/dist-packages/keystone/conf/default.py", line 180, in <module>
    deprecated_since=versionutils.deprecated.NEWTON,
AttributeError: type object 'deprecated' has no attribute 'NEWTON'

It seems due to the fact that the installed version of oslo.log is not updated properly:

python-oslo.log:
  Installed: 3.2.0-2
  Candidate: 3.16.0-0ubuntu1~cloud0
  Version table:
     3.16.0-0ubuntu1~cloud0 500
        500 http://ubuntu-cloud.archive.canonical.com/ubuntu xenial-updates/newton/main amd64 Packages
        500 http://ubuntu-cloud.archive.canonical.com/ubuntu xenial-updates/newton/main i386 Packages
 *** 3.2.0-2 500
        500 http://mirror/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status

But looking at the requirements.txt in stable/newton, even oslo.log>=1.14.0 is claimed to work.

Changed in keystone (Ubuntu):
status: New → Triaged
Dr. Jens Harbott (j-harbott) wrote :

So looking at the tags in the oslo.log repo, it seems that keystone=stable/newton needs to depend on oslo.log>=3.4.0 in order to work.

Corey Bryant (corey.bryant) wrote :

frickler, thanks again for the bug report. I just uploaded keystone 2:10.0.0~rc2-0ubuntu2 which depends on oslo.log >= 3.16.0 to align with upper-constraints and the version we have in the archive for newton.

Changed in keystone (Ubuntu):
assignee: nobody → Corey Bryant (corey.bryant)
Boris Bobrov (bbobrov) on 2016-09-29
Changed in keystone:
status: New → Confirmed
Steve Martinelli (stevemar) wrote :

This is a dupe of https://bugs.launchpad.net/keystone/+bug/1623168 -- it was assessed during the requirements FFE period, since there are many other versions of oslo.log that can be used.

I doubt we will do anything to our stable/newton code for this bug, we will certainly fix it in master.

Changed in keystone:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package keystone - 2:10.0.0~rc2-0ubuntu2

---------------
keystone (2:10.0.0~rc2-0ubuntu2) yakkety; urgency=medium

  * d/control: oslo.log min version level in global-requirements is too low,
    so set min version to upper-constraints level (LP: #1628883).

 -- Corey Bryant <email address hidden> Thu, 29 Sep 2016 07:54:36 -0400

Changed in keystone (Ubuntu):
status: Triaged → Fix Released

Change abandoned by Boris Bobrov (<email address hidden>) on branch: stable/newton
Review: https://review.openstack.org/379451
Reason: not needed probably

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers