[api] domain configuration API docs missing domain config creation

Bug #1607567 reported by Eric Brown
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Identity (keystone)
Wishlist
Eric Brown

Bug Description

The domain configuration API documentation is missing information on how to create a domain config. The help for domain config mentions a PUT request, but the API for the PUT is missing.

http://developer.openstack.org/api-ref/identity/v3/index.html?expanded=update-domain-configuration-detail#domain-configuration

I also checked the code and there is support for creating a domain config via a PUT request.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to keystone (master)

Fix proposed to branch: master
Review: https://review.openstack.org/348591

Changed in keystone:
assignee: nobody → Eric Brown (ericwb)
status: New → In Progress
Changed in keystone:
importance: Undecided → Medium
milestone: none → newton-3
tags: added: api
Changed in keystone:
milestone: newton-3 → none
Changed in keystone:
milestone: none → newton-3
tags: added: api-ref
removed: api
summary: - domain configuration API docs missing domain config creation
+ [api] domain configuration API docs missing domain config creation
Changed in keystone:
importance: Medium → Wishlist
Changed in keystone:
assignee: Eric Brown (ericwb) → Steve Martinelli (stevemar)
Changed in keystone:
assignee: Steve Martinelli (stevemar) → Eric Brown (ericwb)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to keystone (master)

Reviewed: https://review.openstack.org/348591
Committed: https://git.openstack.org/cgit/openstack/keystone/commit/?id=ebe1e835cb4ac2fe3d763950616fbd48f2961ff4
Submitter: Jenkins
Branch: master

commit ebe1e835cb4ac2fe3d763950616fbd48f2961ff4
Author: Eric Brown <email address hidden>
Date: Thu Jul 28 17:00:19 2016 -0700

    Improve domain configuration API docs

    * Beautified the response codes (removed trailing commas and added
      spaces)
    * Creating a domain configuration was missing from the docs

    Change-Id: Ifaabc38c27669588b1abcb1d121a9e4410d62ebb
    Closes-Bug: #1607567

Changed in keystone:
status: In Progress → Fix Released
Revision history for this message
Thierry Carrez (ttx) wrote : Fix included in openstack/keystone 10.0.0.0b3

This issue was fixed in the openstack/keystone 10.0.0.0b3 development milestone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers