Misleading variable naming is used in ldap driver

Bug #1571342 reported by Kahou Lei on 2016-04-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Identity (keystone)
Low
Kahou Lei

Bug Description

In keystone/common/ldap/core.py, the EnabledEmuMixIn get_all() method is using "tenant" as the return object. This is misleading as this method is not using as project only but also other identity resources (such as user and group). We should rename the variables to be more generic to avoid confusion.

https://github.com/openstack/keystone/blob/master/keystone/common/ldap/core.py#L1921-L1932

Fix proposed to branch: master
Review: https://review.openstack.org/306838

Changed in keystone:
assignee: nobody → Kahou Lei (kahou82)
status: New → In Progress
Kahou Lei (kahou82) on 2016-04-17
description: updated

Reviewed: https://review.openstack.org/306838
Committed: https://git.openstack.org/cgit/openstack/keystone/commit/?id=e23ef5bd23bd800420d145a11ceb903ec4c52400
Submitter: Jenkins
Branch: master

commit e23ef5bd23bd800420d145a11ceb903ec4c52400
Author: Kahou Lei <email address hidden>
Date: Sun Apr 17 08:00:20 2016 -0700

    Fix confusing naming in ldap EnableEmuMixin.

    In keystone/common/ldap/core.py, the get_all() method of EnabledEmuMixIn is
    using "tenant" as the return object. This is misleading as the core method
    is not using as project only but also other identity or resources (such as
    user and group). We should change to name to be more generic to avoid
    confusion.

    Change-Id: I53a7eb22539697e16ac9893daf59506483345f9e
    closes-bug: 1571342

Changed in keystone:
status: In Progress → Fix Released

This issue was fixed in the openstack/keystone 10.0.0.0b1 development milestone.

Changed in keystone:
importance: Undecided → Low
milestone: none → newton-1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers