[api-ref] Add "update user of OS-KSCRUD extension" on identity v2 API

Bug #1524153 reported by Ken'ichi Ohmichi on 2015-12-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Identity (keystone)
Low
Steve Martinelli

Bug Description

Now keystone supports "update user of OS-KSCRUD extension" on identity v2 API, and tempest also is testing the API.
However, the api-site doesn't contain the API description.
So we need to write the API for API users.

The URL is "OS-KSCRUD/users/<user-id>" and the method is PATCH on identity v2 API.

Atsushi SAKAI (sakaia) on 2015-12-09
Changed in openstack-api-site:
status: New → Confirmed
tags: added: keystone
Sharat Sharma (sharat-sharma) wrote :

Hey,
Should we document it under a separate heading "OS-KSCRUD admin extension" or simply include it under OS-KSCATALOG admin extension since it supports CRUD operations?

Changed in openstack-api-site:
assignee: nobody → Sharat Sharma (sharat-sharma)
Atsushi SAKAI (sakaia) on 2016-05-15
affects: openstack-api-site → keystone
summary: - Need to write "update user of OS-KSCRUD extension" on identity v2 API
+ [api-ref]Need to write "update user of OS-KSCRUD extension" on identity
+ v2 API
tags: added: api-ref
removed: keystone
summary: - [api-ref]Need to write "update user of OS-KSCRUD extension" on identity
- v2 API
+ [api-ref] Add "update user of OS-KSCRUD extension" on identity v2 API
Changed in keystone:
assignee: Sharat Sharma (sharat-sharma) → nobody
importance: Undecided → Low

Fix proposed to branch: master
Review: https://review.openstack.org/341708

Changed in keystone:
assignee: nobody → Boris Bobrov (bbobrov)
status: Confirmed → In Progress
Changed in keystone:
assignee: Boris Bobrov (bbobrov) → Steve Martinelli (stevemar)

Reviewed: https://review.openstack.org/341708
Committed: https://git.openstack.org/cgit/openstack/keystone/commit/?id=8a56b19734ba0ffb1dba9db200feac2c48c12b9e
Submitter: Jenkins
Branch: master

commit 8a56b19734ba0ffb1dba9db200feac2c48c12b9e
Author: Boris Bobrov <email address hidden>
Date: Wed Jul 13 20:28:50 2016 +0300

    Add OS-KSCRUD api-ref

    Change-Id: Ibf837eb880ee1811bfc85464b213451ddaf94a0b
    Closes-Bug: 1524153

Changed in keystone:
status: In Progress → Fix Released
Changed in keystone:
milestone: none → newton-2

This issue was fixed in the openstack/keystone 10.0.0.0b2 development milestone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers