API Version info incorrect for Liberty

Bug #1522433 reported by Henry Nash on 2015-12-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Identity (keystone)
Medium
Amy Marrich

Bug Description

Our API allows you to query keystone for the version that is supports (e.g. V2 and v3), as well as the minor version we support (e.g. 3.4) as well as other status of the API. Looks like this was not updated for the Liberty release:

            versions['v3'] = {
                'id': 'v3.4',
                'status': 'stable',
                'updated': '2015-03-30T00:00:00Z',
                'links': [
                    {
                        'rel': 'self',
                        'href': self._get_identity_url(context, 'v3'),
                    }
                ],
                'media-types': [
                    {
                        'base': 'application/json',
                        'type': MEDIA_TYPE_JSON % 'v3'
                    }
                ]
            }

The above is from version/controller.py.

Liberty supports version 3.5 of the API, and the date needs to be updated.

Lance Bragstad (lbragstad) wrote :

Looks like a patch to versions will be necessary [0] [1]. Henry, what should the 'updated' date be? Should it be the day the patch was submitted or should it be the day Liberty was released?

[0] https://github.com/openstack/keystone/blob/8dd27d3368ce0aa396386010f6aec5ed6304d687/keystone/version/controllers.py#L147-L164
[1] https://github.com/openstack/keystone/commit/1ef41d2abdfe143ca3bc3b00a88b809a3314cae2

tags: added: low-hanging-fruit
Changed in keystone:
status: New → Confirmed
importance: Undecided → Medium
Henry Nash (henry-nash) wrote :

So it looks like we typically set the date to shortly after the m3 release is made (at which point we consider the API frozen)...but before and RC are released - which for Liberty is maybe around September 15th ?

Changed in keystone:
assignee: nobody → Amy Marrich (amy-marrich)

Fix proposed to branch: master
Review: https://review.openstack.org/253034

Changed in keystone:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/253034
Committed: https://git.openstack.org/cgit/openstack/keystone/commit/?id=087af823403c7f5eccb29b974ce12e5379521c0f
Submitter: Jenkins
Branch: master

commit 087af823403c7f5eccb29b974ce12e5379521c0f
Author: Amy Marrich <email address hidden>
Date: Thu Dec 3 09:52:49 2015 -0600

    Update API version info for Liberty

    Updated version/controller.py and tests/unit/test_version.py

    Change-Id: I20c861e7750cf6717a3c49c9cb4aed3725342ae1
    Closes-Bug: #1522433

Changed in keystone:
status: In Progress → Fix Committed
Changed in keystone:
milestone: none → mitaka-2
status: Fix Committed → Fix Released

This issue was fixed in the openstack/keystone 9.0.0.0b2 development milestone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers