API-based Domain specific config does not check for type of option

Bug #1517037 reported by Henry Nash on 2015-11-17
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Identity (keystone)
Low
Unassigned

Bug Description

When using the API method for specifying domain specific options for config values, we don't check that the type of option specified via the API matches the underlying config option type. This could lead to strange results which would be hard for an operator to debug in the field.

Henry Nash (henry-nash) on 2015-11-17
Changed in keystone:
assignee: nobody → Henry Nash (henry-nash)
importance: Undecided → Medium
Changed in keystone:
milestone: none → mitaka-2
Steve Martinelli (stevemar) wrote :

no patch yet, so i'm bumping to mitaka-3 as mitaka-2 is due tomorrow

Changed in keystone:
milestone: mitaka-2 → mitaka-3
Changed in keystone:
assignee: Henry Nash (henry-nash) → nobody
Steve Martinelli (stevemar) wrote :

not sure how do-able this will be, ideally we should re-use the 'type' from oslo.config, and loop through the new proposed options.

Changed in keystone:
importance: Medium → Low

Fix proposed to branch: master
Review: https://review.openstack.org/281078

Changed in keystone:
assignee: nobody → Steve Martinelli (stevemar)
status: New → In Progress
Steve Martinelli (stevemar) wrote :

removing from mitaka-3 milestone, not a blocker

Changed in keystone:
milestone: mitaka-3 → none

Change abandoned by Steve Martinelli (<email address hidden>) on branch: master
Review: https://review.openstack.org/281078
Reason: if someone wants to pick this up i will happily restore it

Changed in keystone:
assignee: Steve Martinelli (stevemar) → nobody
status: In Progress → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers