Rally change breaks Keystone rally job

Bug #1507752 reported by Davanum Srinivas (DIMS)
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Identity (keystone)
Medium
Andrey Kurilin
Rally
High
Chris St. Pierre

Bug Description

This change:
http://git.openstack.org/cgit/openstack/rally/diff/rally/plugins/openstack/scenarios/keystone/basic.py?id=f871de842214f103b4841160e90c73cd98c4f5ad

Breaks this job:
http://logs.openstack.org/74/231574/6/check/gate-rally-dsvm-keystone/57d4dfc/rally-plot/results.html.gz#/KeystoneBasic.create_user/failures

Traceback:
Traceback (most recent call last):
  File "/opt/stack/new/rally/rally/task/runner.py", line 64, in _run_scenario_once
    method_name)(**kwargs) or scenario_output
  File "/opt/stack/new/rally/rally/plugins/openstack/scenarios/keystone/basic.py", line 33, in create_user
    self._user_create(**kwargs)
  File "/opt/stack/new/rally/rally/task/atomic.py", line 83, in func_atomic_actions
    f = func(self, *args, **kwargs)
  File "/opt/stack/new/rally/rally/plugins/openstack/scenarios/keystone/utils.py", line 45, in _user_create
    name, password=password, email=email, **kwargs)
TypeError: create() got an unexpected keyword argument 'name_length'

Changed in keystone:
importance: Undecided → Medium
Changed in rally:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Andrey Kurilin (andreykurilin)
assignee: Andrey Kurilin (andreykurilin) → Chris St. Pierre (stpierre)
status: Triaged → In Progress
Changed in keystone:
status: New → Confirmed
Revision history for this message
Andrey Kurilin (andreykurilin) wrote :

Fix was merged to Rally(https://review.openstack.org/#/c/237182/ ), so gates should work now(they use rally master, so we don't need to cut a release).

Changed in rally:
status: In Progress → Fix Committed
Changed in rally:
milestone: none → 0.1.2
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to keystone (master)

Fix proposed to branch: master
Review: https://review.openstack.org/240251

Changed in keystone:
assignee: nobody → Andrey Kurilin (andreykurilin)
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to keystone (master)

Reviewed: https://review.openstack.org/240251
Committed: https://git.openstack.org/cgit/openstack/keystone/commit/?id=e21f9d8cd158b45d21827e60ab7154456b860382
Submitter: Jenkins
Branch: master

commit e21f9d8cd158b45d21827e60ab7154456b860382
Author: Andrey Kurilin <email address hidden>
Date: Thu Oct 29 16:33:34 2015 +0200

    [rally] remove deprecated arg

    `name_length` is deprecated in latest rally due to changes related to
    improvement of cleanup mechanism.

    Change-Id: I636dcfe8d0a05f9b621e15d5ec302f74cc6d741a
    Closes-Bug: #1507752

Changed in keystone:
status: In Progress → Fix Committed
Changed in keystone:
milestone: none → mitaka-1
Revision history for this message
Thierry Carrez (ttx) wrote : Fix included in openstack/keystone 9.0.0.0b1

This issue was fixed in the openstack/keystone 9.0.0.0b1 development milestone.

Changed in keystone:
status: Fix Committed → Fix Released
Changed in rally:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers