Fix copyright headers to be compliant with Foundation policies

Bug #1214176 reported by Sean Winn on 2013-08-19
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ceilometer
Undecided
ZhiQiang Fan
Cinder
Undecided
Dinesh Bhor
Glance
Low
Dinesh Bhor
Glance Client
Undecided
ZhiQiang Fan
Murano
Low
Dinesh Bhor
OpenStack Compute (nova)
Undecided
ZhiQiang Fan
OpenStack DBaaS (Trove)
Undecided
ZhiQiang Fan
OpenStack Dashboard (Horizon)
Undecided
ZhiQiang Fan
OpenStack Heat
Fix Released
Undecided
ZhiQiang Fan
OpenStack Identity (keystone)
Low
Steve Martinelli
OpenStack Object Storage (swift)
Low
ZhiQiang Fan
PBR
Undecided
Dinesh Bhor
devstack
Undecided
ZhiQiang Fan
neutron
Low
ZhiQiang Fan
python-ceilometerclient
Undecided
ZhiQiang Fan
python-cinderclient
Low
ZhiQiang Fan
python-heatclient
Fix Released
Undecided
ZhiQiang Fan
python-keystoneclient
Low
ZhiQiang Fan
python-manilaclient
Undecided
Dinesh Bhor
python-neutronclient
Undecided
Akihiro Motoki
python-troveclient
Undecided
Dinesh Bhor
tempest
Undecided
ZhiQiang Fan

Bug Description

Correct the copyright headers to be consistent with the policies outlined by the OpenStack Foundation at http://www.openstack.org/brand/openstack-trademark-policy/

Remove references to OpenStack LLC, replace with OpenStack Foundation

Sean Winn (seanmwinn) on 2013-08-19
Changed in keystone:
assignee: nobody → Sean Winn (seanmwinn)
Changed in keystone:
status: New → Confirmed
Changed in keystone:
status: Confirmed → In Progress
Dolph Mathews (dolph) on 2013-08-27
Changed in keystone:
importance: Undecided → Low
Sean Winn (seanmwinn) on 2013-08-27
Changed in keystone:
status: In Progress → Fix Committed
status: Fix Committed → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/45293

Changed in keystone:
assignee: Sean Winn (seanmwinn) → David Stanek (dstanek)
Changed in keystone:
assignee: David Stanek (dstanek) → Steve Martinelli (stevemar)

Reviewed: https://review.openstack.org/45293
Committed: http://github.com/openstack/keystone/commit/8d2f53c403e51022947943815b34dd9e0deca835
Submitter: Jenkins
Branch: master

commit 8d2f53c403e51022947943815b34dd9e0deca835
Author: David Stanek <email address hidden>
Date: Thu Sep 5 13:35:25 2013 -0400

    Changes template header for translation catalogs

    New translation catalogs will be generated with the organization set to
    'OpenStack Foundation' in the header.

    Change-Id: I0da323113030c6a68b3c4bbdd94053639312c594
    Partial-Bug: #1214176

Reviewed: https://review.openstack.org/43708
Committed: http://github.com/openstack/keystone/commit/0331f8a58a0440ed1b875f21d976b6d782094e4b
Submitter: Jenkins
Branch: master

commit 0331f8a58a0440ed1b875f21d976b6d782094e4b
Author: Sean Winn <email address hidden>
Date: Mon Aug 26 06:32:10 2013 -0700

    Changed header from LLC to Foundation based on trademark policies

    Fixes: Bug 1214176

    Change-Id: Ie937081a53d377671b8b88f422642c8131002f88

Changed in keystone:
status: In Progress → Fix Committed
Sean Winn (seanmwinn) on 2013-09-16
Changed in swift:
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/47423

Changed in swift:
assignee: nobody → ZhiQiang Fan (aji-zqfan)
status: Confirmed → In Progress
ZhiQiang Fan (aji-zqfan) wrote :
Changed in neutron:
assignee: nobody → ZhiQiang Fan (aji-zqfan)
status: New → In Progress
ZhiQiang Fan (aji-zqfan) wrote :
Changed in ceilometer:
assignee: nobody → ZhiQiang Fan (aji-zqfan)
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/47437

Changed in nova:
assignee: nobody → ZhiQiang Fan (aji-zqfan)
status: New → In Progress
ZhiQiang Fan (aji-zqfan) wrote :
Changed in devstack:
assignee: nobody → ZhiQiang Fan (aji-zqfan)
status: New → In Progress
ZhiQiang Fan (aji-zqfan) wrote :
Changed in hacking:
assignee: nobody → ZhiQiang Fan (aji-zqfan)
status: New → In Progress
Changed in heat:
assignee: nobody → ZhiQiang Fan (aji-zqfan)

Fix proposed to branch: master
Review: https://review.openstack.org/47442

Changed in heat:
status: New → In Progress
ZhiQiang Fan (aji-zqfan) on 2013-09-19
Changed in horizon:
assignee: nobody → ZhiQiang Fan (aji-zqfan)

Fix proposed to branch: master
Review: https://review.openstack.org/47445

Changed in horizon:
status: New → In Progress

Reviewed: https://review.openstack.org/47430
Committed: http://github.com/openstack/neutron/commit/005879ee07c9c02de9d8c47215600f1d36afa41b
Submitter: Jenkins
Branch: master

commit 005879ee07c9c02de9d8c47215600f1d36afa41b
Author: ZhiQiang Fan <email address hidden>
Date: Fri Sep 20 01:29:20 2013 +0800

    Change header from LLC to Foundation

    Change-Id: I11d7e734ae56568f2387a208efe0d1487377cbf9
    Closes-Bug: #1214176

Changed in neutron:
status: In Progress → Fix Committed
ZhiQiang Fan (aji-zqfan) on 2013-09-19
Changed in python-ceilometerclient:
assignee: nobody → ZhiQiang Fan (aji-zqfan)

Fix proposed to branch: master
Review: https://review.openstack.org/47449

Changed in python-ceilometerclient:
status: New → In Progress
ZhiQiang Fan (aji-zqfan) on 2013-09-19
Changed in ironic:
assignee: nobody → ZhiQiang Fan (aji-zqfan)

Fix proposed to branch: master
Review: https://review.openstack.org/47451

Changed in ironic:
status: New → In Progress
ZhiQiang Fan (aji-zqfan) on 2013-09-19
Changed in python-cinderclient:
assignee: nobody → ZhiQiang Fan (aji-zqfan)

Fix proposed to branch: master
Review: https://review.openstack.org/47453

Changed in python-cinderclient:
status: New → In Progress
ZhiQiang Fan (aji-zqfan) on 2013-09-19
Changed in python-glanceclient:
assignee: nobody → ZhiQiang Fan (aji-zqfan)

Fix proposed to branch: master
Review: https://review.openstack.org/47458

Changed in python-glanceclient:
status: New → In Progress
ZhiQiang Fan (aji-zqfan) on 2013-09-19
Changed in python-heatclient:
assignee: nobody → ZhiQiang Fan (aji-zqfan)

Fix proposed to branch: master
Review: https://review.openstack.org/47462

Changed in python-heatclient:
status: New → In Progress
ZhiQiang Fan (aji-zqfan) on 2013-09-19
Changed in python-keystoneclient:
assignee: nobody → ZhiQiang Fan (aji-zqfan)
status: New → In Progress
ZhiQiang Fan (aji-zqfan) wrote :
Changed in tempest:
assignee: nobody → ZhiQiang Fan (aji-zqfan)
status: New → In Progress
ZhiQiang Fan (aji-zqfan) wrote :
Changed in trove:
assignee: nobody → ZhiQiang Fan (aji-zqfan)
status: New → In Progress
Changed in python-troveclient:
assignee: nobody → ZhiQiang Fan (aji-zqfan)
status: New → In Progress

Reviewed: https://review.openstack.org/47462
Committed: http://github.com/openstack/python-heatclient/commit/455b1cb4e88cff87787d69ecf196c64be0467ed4
Submitter: Jenkins
Branch: master

commit 455b1cb4e88cff87787d69ecf196c64be0467ed4
Author: ZhiQiang Fan <email address hidden>
Date: Fri Sep 20 04:21:21 2013 +0800

    Replace OpenStack LLC with OpenStack Foundation

    Change-Id: I8f2697ca99192078d5db2adb4db98287520d9895
    Fixes-Bug: #1214176

Changed in python-heatclient:
status: In Progress → Fix Committed
Changed in heat:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/47442
Committed: http://github.com/openstack/heat/commit/82b7aa6c6cec8e17780f81a414e7be42c5c6adb7
Submitter: Jenkins
Branch: master

commit 82b7aa6c6cec8e17780f81a414e7be42c5c6adb7
Author: ZhiQiang Fan <email address hidden>
Date: Fri Sep 20 02:34:29 2013 +0800

    Replace OpenStack LLC with OpenStack Foundation

    Change-Id: Ia3489a1cff5070b000098e278c772cb823ae688c
    Fixes-Bug: #1214176

ZhiQiang Fan (aji-zqfan) wrote :
John Griffith (john-griffith) wrote :

I'm not sure about this, typically going back and changing/modifying existing copyrights isn't something that's generally acceptable. I realize this is a specific case, but I still am not sure if this is the correct thing to do or if it's necessary at all.

I'd like to get some guidance here from folks that are more copyright savvy than I am, as copyright headers have been a touchy subject in the past.

My understanding int he past was you can append to/add but you can't remove or modify.

ZhiQiang Fan (aji-zqfan) wrote :

@John Griffith
as i commented in https://review.openstack.org/#/c/47437/

please check https://wiki.openstack.org/wiki/Documentation/Copyright

and please check nova repo
$ egrep -i '2010.*openstack.*foundation' nova/ -r | wc -l
66
$ egrep -i '2011.*openstack.*foundation' nova/ -r | wc -l
228

so in the past, contributors change the openstack llc to openstack foundation, even copyright is added in 2010, 2011 which trademark didn't change yet

as most of documents and code source files already use openstack foundation trademark (even old files created early), i think it is better to sync among the rest projects/files

What if that existing Copyright header referred to a non-existent entity?

There is no OpenStack LLC. There never was a limited liability corporation setup under that name, so the fact that the copyright header ever displayed OpenStack LLC was always a bug as well as a total fallacy. To me, this is a huge bug. It would be a different story if we were actually protecting the IP of a real company who created the code, but in this case we would be protecting the integrity of a header that credits a fictitious limited liability corporation which does not exist and never has.

Policy or not, I honestly believe the headers should be changed to reflect an actual real entity. OpenStack Foundation is real. OpenStack LLC is fictitious.

Regards,

Sean W.

On Sep 19, 2013, at 7:58 PM, John Griffith <email address hidden> wrote:

> I'm not sure about this, typically going back and changing/modifying
> existing copyrights isn't something that's generally acceptable. I
> realize this is a specific case, but I still am not sure if this is the
> correct thing to do or if it's necessary at all.
>
> I'd like to get some guidance here from folks that are more copyright
> savvy than I am, as copyright headers have been a touchy subject in the
> past.
>
> My understanding int he past was you can append to/add but you can't
> remove or modify.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1214176
>
> Title:
> Fix copyright headers to be compliant with Foundation policies
>
> Status in Ceilometer:
> In Progress
> Status in devstack - openstack dev environments:
> In Progress
> Status in OpenStack Hacking Guidelines:
> In Progress
> Status in Orchestration API (Heat):
> Fix Committed
> Status in OpenStack Dashboard (Horizon):
> In Progress
> Status in Ironic (Bare Metal Provisioning):
> In Progress
> Status in OpenStack Identity (Keystone):
> Fix Committed
> Status in OpenStack Neutron (virtual network service):
> Fix Committed
> Status in OpenStack Compute (Nova):
> In Progress
> Status in Python client library for Ceilometer:
> In Progress
> Status in Python client library for Cinder:
> In Progress
> Status in Python client library for Glance:
> In Progress
> Status in Python client library for heat:
> Fix Committed
> Status in Python client library for Keystone:
> In Progress
> Status in Trove client binding:
> In Progress
> Status in OpenStack Object Storage (Swift):
> In Progress
> Status in Tempest:
> In Progress
> Status in Trove - Database as a Service:
> In Progress
>
> Bug description:
> Correct the copyright headers to be consistent with the policies
> outlined by the OpenStack Foundation at http://www.openstack.org/brand
> /openstack-trademark-policy/
>
> Remove references to OpenStack LLC, replace with OpenStack Foundation
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ceilometer/+bug/1214176/+subscriptions

Reviewed: https://review.openstack.org/47445
Committed: http://github.com/openstack/horizon/commit/686cc88fd2e011a66712bae07a2b993ca754a630
Submitter: Jenkins
Branch: master

commit 686cc88fd2e011a66712bae07a2b993ca754a630
Author: ZhiQiang Fan <email address hidden>
Date: Fri Sep 20 02:49:55 2013 +0800

    Replace OpenStack LLC with OpenStack Foundation

    Change-Id: I6c638f04fb7c97ac986ef31c1190011ed90a43d2
    Fixes-Bug: #1214176

Changed in horizon:
status: In Progress → Fix Committed
Changed in neutron:
importance: Undecided → Low
milestone: none → havana-rc1
Changed in swift:
importance: Undecided → Low
Changed in ironic:
importance: Undecided → Low

Reviewed: https://review.openstack.org/47478
Committed: http://github.com/openstack/python-troveclient/commit/e3a301ff2805fcfdaf69422b109fc43934f8cbff
Submitter: Jenkins
Branch: master

commit e3a301ff2805fcfdaf69422b109fc43934f8cbff
Author: ZhiQiang Fan <email address hidden>
Date: Fri Sep 20 05:09:03 2013 +0800

    Replace OpenStack LLC with OpenStack Foundation

    Some files still use trademark OpenStack LLC in header, which
    should be changed to OpenStack Foundation.

    Change-Id: Ib30cd06cdd13b9f949e028753716aa55736f4a40
    Fixes-Bug: #1214176

Changed in python-troveclient:
status: In Progress → Fix Committed
Changed in trove:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/47476
Committed: http://github.com/openstack/trove/commit/e52c0f568e514316003aed1f1afa9714bd500696
Submitter: Jenkins
Branch: master

commit e52c0f568e514316003aed1f1afa9714bd500696
Author: ZhiQiang Fan <email address hidden>
Date: Fri Sep 20 05:00:04 2013 +0800

    Replace OpenStack LLC with OpenStack Foundation

    Some files still use trademark OpenStack LLC in header, which
    should be changed to OpenStack Foundation.

    NOTE: tools/install_venv.py is not touched, should sync with oslo,
    so does trove/openstack/common/*

    Change-Id: I7218ae896eb7db681bb224a209df47f203952606
    Fixes-Bug: #1214176

Reviewed: https://review.openstack.org/47449
Committed: http://github.com/openstack/python-ceilometerclient/commit/fb1ff39d53826b94c3c04645d972a0a96dc8225a
Submitter: Jenkins
Branch: master

commit fb1ff39d53826b94c3c04645d972a0a96dc8225a
Author: ZhiQiang Fan <email address hidden>
Date: Fri Sep 20 03:14:11 2013 +0800

    Replace OpenStack LLC with OpenStack Foundation

    Change-Id: Ia007da282714d8ee7337fd3b51f6dcc3b64d7ec3
    Fixes-Bug: #1214176

Changed in python-ceilometerclient:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/47451
Committed: http://github.com/openstack/ironic/commit/2cb920614ab56c44d8dd1bc84cd982365982dbf0
Submitter: Jenkins
Branch: master

commit 2cb920614ab56c44d8dd1bc84cd982365982dbf0
Author: ZhiQiang Fan <email address hidden>
Date: Fri Sep 20 03:24:24 2013 +0800

    Replace OpenStack LLC with OpenStack Foundation

    Some files still use trademark OpenStack LLC in header, which
    should be changed to OpenStack Foundation.

    Change-Id: I6ab820e61514c6004247d9b931976e03baf84ae0
    Fixes-Bug: #1214176

Changed in ironic:
status: In Progress → Fix Committed
Changed in python-cinderclient:
importance: Undecided → Low

Reviewed: https://review.openstack.org/47433
Committed: http://github.com/openstack/ceilometer/commit/0758c7e2f0b55fffc4bd65c16e4d02cca3e918e1
Submitter: Jenkins
Branch: master

commit 0758c7e2f0b55fffc4bd65c16e4d02cca3e918e1
Author: ZhiQiang Fan <email address hidden>
Date: Fri Sep 20 01:45:22 2013 +0800

    Replace OpenStack LLC with OpenStack Foundation

    NOTE: openstack/common files are not touched, they should be updated
    via sync with oslo.

    Change-Id: I0106004a8f211d047db28f35fecd386a4e327569
    Closes-Bug: #1214176

Changed in ceilometer:
status: In Progress → Fix Committed
tags: added: headers
Changed in python-heatclient:
milestone: none → v0.2.5
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-02
Changed in keystone:
status: Fix Committed → Fix Released

Reviewed: https://review.openstack.org/47453
Committed: http://github.com/openstack/python-cinderclient/commit/5ad95e9fd236a1f27cbcf1105494d6680a7d8ffe
Submitter: Jenkins
Branch: master

commit 5ad95e9fd236a1f27cbcf1105494d6680a7d8ffe
Author: ZhiQiang Fan <email address hidden>
Date: Fri Sep 20 03:31:42 2013 +0800

    Replace OpenStack LLC with OpenStack Foundation

    NOTE:
    * openstack/common/* should be synced from oslo, so i leave them
    untouched.
    * add (c) symbol for related lines, leave others untouched.

    Change-Id: I46a87c7f248d3468b1fdf5661411962faf2fb875
    Fixes-Bug: #1214176

Changed in python-cinderclient:
status: In Progress → Fix Committed
Thierry Carrez (ttx) wrote : RC1

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

 affects ceilometer
 status fixreleased
 milestone havana-rc1
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCAAGBQJSTHC4AAoJEFB6+JAlsQQjdAkQAJEnraDMfHKJwTwaUpNMjGAj
qnCFxHyvyQpELEmvghChnBBrlqC459QbwVbFks98tmzOm44WHNBmu/tNMjCjohQB
HwoTC/4tiUcueGP4bfleOTs0ivDsw5VJyaWRhy92mt5X71Mw7bFf4dkbcxFVpUaG
DshQTupbNWncuL+Hoj1lrPX+BMZlpm0Vo5pAtcpgeEwU7dMGHx5tYYsG6gMUXGsh
BWPvKpxcX9u20F9+smDvGs0gT6BYN//EZkkImwG2Z71/CL39tuUcysu37G8n16Wl
7uPLa4dVtSqbM0puuDD+EumFwayQj4QXdJCl4hksJBQGe6WdfOSjZt0a3fa3xz0b
1YfN1d2kHfuTMjWIbNnM1as90qupqNOWKjw5zCrr1V22lADenux6KA1jsHMNKePi
FHKs+xja+U3F8iKx9Mr/UuMXzsFlrZmqpTHmejcgDmdIsbpluv3Epz/vVdlBbxTg
m3QlbBIQ1y3/RCyZ42PIsVLVm3UG4cwcOf5hbVdEgRhI7xwJd8DaqIKurknYnmz7
gVvNMaPfjCSTMsgWVTEK+26cxblE2YG0MZHhSm+7t8/pB8DXj5FKgCBLwgPu6zIK
4Upxz2qRP/0pk62nA6I/jZ2Q2+MOs0S39XgGG4tdVdSMGf5PjuUpvXiuh29w/Ah5
0wLlAotY/eOTTbmiRP8F
=0Twe
-----END PGP SIGNATURE-----

Changed in ceilometer:
milestone: none → havana-rc1
status: Fix Committed → Fix Released
Thierry Carrez (ttx) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

 affects horizon
 status fixreleased
 milestone havana-rc1
 affects neutron
 status fixreleased
 milestone havana-rc1
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCAAGBQJSTRzIAAoJEFB6+JAlsQQjYAcP/0mSUVUL2uBR6TaztcjDznQE
iR5/Qi3b2tSSZFGmByNGnnT8D4ZDweIXRqdOB5fuS+iinR00CURC3JRxcLT8hEYW
r5c0aB2HxCafOKhUfPt0/mIlCgwb7wrMBbo/p6z44aMNDbYRqVWlU5Zo1eyxc74H
9tznblgr/KBspg9mYWe2nyma1l++B8RnQ0ULab1U8eHgf6mb7xm+cJqxEFAPUulx
PeZbNkWHGgCdTn5TblRwIJpiSjMPhnD5sD7R9a59oTnhEpY/3SOFHj936/ZhojRn
Hoa+eJ6EdJ8J7Xp2jakkH4wAYwGvWVH/DAEbJcDQF9Ezlsgg6UNyrBG3Rv3IkCQ9
DSun/FRnlU6u6lVz7vqyLK9TkPEpryRClDDvyq+7e0QTAeEFhy+vhiYik94Gezq5
hLsgorAbXv/AfGrQ7gkLNi9CYMHA/HtSeIjW3zPCQdEHVOPJik8wFQq4d1ITJnPF
dNJZTJdRiE1Ha4lt1aurFc0mHAFEibLg2h/IszpH3dhEY9qrUjNzsUMEAkzVF9dU
WDiLu5AgqRX+5iIxP7Ja7AhESJnZq1Z0ILItBusC0CeFGTyHkSz6squSSstp5Tjd
JJbSiqsKGvnkk7cI32E8so4Uyfjh37doiIQihS0tB/PtC1QQaRJqeEanoS3USBnR
FEGxVFMvoKSw6ZTQUg6M
=BW++
-----END PGP SIGNATURE-----

Thierry Carrez (ttx) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

 affects heat
 status fixreleased
 milestone havana-rc1
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCAAGBQJSTR0LAAoJEFB6+JAlsQQjrq8P/Rp2oSHYSPqgWUUy3fd5kal2
k3knz1enqQJw1GphMwcySar3qXUK1NYZ0nPOwR25VuypVXJr+cDMBjDdYWtO942B
+M5dOUpm3pha1h2efxF6awQJ732WpEsS9/dobFzrgNr46fuyijCSRkf0AtYtt5ge
jW2r+lQHhDiKcUGYi0nY08qRI086u0zGXACjAqKCjHpNeyejoy4b4SVsj4e2lSd0
p7SkqiRUAkHwVymHbXQx8lHxNcWGZ8v9qnU+PGRAA5xc0yBid+lhEyKxxtTMUhIx
xC+9mmAx49MvHlanGqUWjqMitXNICg7ddHjcz+o/G3asaqFOfNdSczRufav2d2qk
Tt/w3jmqKvMcEfPldM5ZqujOEC9837SD8fbkL54+FedvTWrfb1/HDGdpH2Gyr475
LonqwnNQLIs3FuT1ZYmHhvdp4Csu82vcKbboEIKxlMplkHUQUvDjZMMkWjyzWdYx
x3F7MsyH5WzEEjRNeR2vbHgOzWujzS4CMmxYewABbXgrLzcMn9/83Zz9m9MpKhxc
Y5Sno2LjH1we3CdIYyej4w8ojO58U4jMVujZDWRJ7PyIS8b/NQcNeWMq+V5brG2Q
b3LyVuHowwfLvSPchXysQ3MmbjswdA3Qv6aDWbFRO9CLuG+pvtvEwxLdcLbgTTBo
AG26qL1k1yzX1nnVVIjj
=oj7P
-----END PGP SIGNATURE-----

Changed in horizon:
milestone: none → havana-rc1
status: Fix Committed → Fix Released
Changed in neutron:
status: Fix Committed → Fix Released
Changed in heat:
milestone: none → havana-rc1
status: Fix Committed → Fix Released

Reviewed: https://review.openstack.org/47437
Committed: http://github.com/openstack/nova/commit/1477f615bb94cc36ade11ca4e8e848cdfc4c2916
Submitter: Jenkins
Branch: master

commit 1477f615bb94cc36ade11ca4e8e848cdfc4c2916
Author: ZhiQiang Fan <email address hidden>
Date: Fri Sep 20 02:14:41 2013 +0800

    Replace OpenStack LLC with OpenStack Foundation

    Change-Id: I5203554989bc7244cff2899d52c5764360bba60c
    Fixes-Bug: #1214176

Changed in nova:
status: In Progress → Fix Committed
Akihiro Motoki (amotoki) wrote :

Fix proposed to branch: master
Review: https://review.openstack.org/#/c/42279/

Changed in python-neutronclient:
assignee: nobody → Akihiro Motoki (amotoki)
status: New → In Progress
Dolph Mathews (dolph) on 2013-10-16
Changed in python-keystoneclient:
milestone: none → 0.4.1
importance: Undecided → Low
Changed in swift:
status: In Progress → Fix Committed
Dolph Mathews (dolph) on 2013-10-16
Changed in python-keystoneclient:
milestone: 0.4.1 → none
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
milestone: none → 0.4.1

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

 affects ceilometer
 milestone 2013.2
 affects keystone
 milestone 2013.2
 affects nova
 milestone 2013.2
 affects horizon
 milestone 2013.2
 affects trove
 milestone 2013.2
 affects heat
 milestone 2013.2
 affects neutron
 milestone 2013.2
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCAAGBQJSX6rrAAoJEFB6+JAlsQQjsHMP/jG8xBEsqBMK0CRZXznvPduF
gGapG1wzNKuk1WNMClwMDPm+qEI1+yK57ytMI8K9a3G1roPS6zybbKsRe1Esbsle
MbfUXstR4k+YhiAovfcCXpzrFXRCBWkxhcuHw+mLmQR/krk7O8beCQtpkKkyA+Kp
jBhnH+hhKH2dlkwID/kWXmL2S5GoetLsVA8FdPp5MFNLV0BRZT6aPf43A0NyNuA/
Frimuyj5vXKjXvMqmGEhQWzQbViGzmh8s1m62H/w6+Hyf5I9CcdQbfDcriaKo+0I
XmNTa24CmbZq9maPnB07QIIHFIBMiwENKfnf1oLf5VHPVGeur1wWWUcHVNMLiA+R
IKpnSyx03ME/VVdmJy/3a3zt1kl3YreSACVxW86hf1XLmWpfqfasd0VCuHM8r6y0
0CH7kNmlzmyimYFtPnttKA4dnAju2Fa7aC0QSBl8WIswGHwSVZOStWyOhwgQl260
uO2Z7UXjrXewNOqRfRuwb/ayc7tGgAq8SzbtcmmJLzzsaDsD0Z4eSlDokY0uuIZM
QXJTwAg1ITBvHNCeep7dbdmtf0XKscICZADHO5ny7zmGGbvdD0mWXd8KP9zFT7uA
ufx9GuKhlDnK+mB4Md8II1dnyV9Soww5qdAF3kXy3tG9vGGKWIObeRHLCon/HB2R
7zaiESGGdoX7kdFyF6k9
=UpDu
-----END PGP SIGNATURE-----

Changed in ceilometer:
milestone: havana-rc1 → 2013.2
Changed in heat:
milestone: havana-rc1 → 2013.2
Changed in horizon:
milestone: havana-rc1 → 2013.2
Changed in keystone:
milestone: none → 2013.2
Changed in neutron:
milestone: havana-rc1 → 2013.2
Changed in nova:
milestone: none → 2013.2
Changed in trove:
milestone: none → 2013.2
Thierry Carrez (ttx) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

 affects swift
 status fixreleased
 milestone 1.10.0
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCAAGBQJSX7axAAoJEFB6+JAlsQQj0WMP/iu0jVDO1PX88gu8M6oBAQ2g
iq97+fUviPMrlSNQPA8K8GVVxc/M05hVR1PDuAxG5eMjH0ZD3bgnJJ/P+UNkvCxW
4q2wOV/QpQaIo4huB1KlDz3sRmjZMZrV8ph07Y9YGqY/7V8a49966Xt1td9ZeAIt
y5sP0baaYqToLgUqNF3tbjvKLa+EFcwMYDQxAd0+X6yAk6rkHdgH6Fbavh5mx87z
0CeCRoztE0MTpeuQUW1qKUKpce+1nbrgvspMyr3ifebmP+WG4YEfFFAEtZPeHzew
BkCQhRA0//XUcVZhaEX++IWh+kCLtYjeKMvAsr0iPmOn7iZMGcWbQgg9mMhpSqu3
PjZ5AvbE+l1R/if0E2aeHOQC9Z9ub5mSh2/GXpHddhB5rmnLTjwcho/M6BQCbHUI
2gBGwVI3wr6OTDsSID5ZcIfwbtE780drVRJBR91MlOBX1f+/PNX8szRkjaspqdF2
BKnFY21tow4Q71qDfERONRTYs+VdS7HgvyguYn1tRkAnpqVYNvv9+mg2HOcTdqPb
hccY5PyqCq1+KagnvJnKX7VKL1KyFleSlKhU+PgNITg8T2YSB8HzmtyG0o0CollF
btJOV76toWIITS4Cnr6F+AY3uIQwPXDLG3eD9sY2HbTW8WhnDFlv7HhN98fLg/M8
z26n3xFfZrRPvchOhjVy
=3vO7
-----END PGP SIGNATURE-----

Changed in swift:
milestone: none → 1.10.0
status: Fix Committed → Fix Released
Thierry Carrez (ttx) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

 affects nova
 status fixreleased
 affects trove
 status fixreleased
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCAAGBQJSX9XlAAoJEFB6+JAlsQQjIaYP/1eEdmuwvqmCC5LSb2FIUv28
lVE9XDbfaxiLYH/o0LKKsnLLdsLUNc3Ksty++1O7py9FXEPlyxg1OY8guQsCO3yt
NN6KgT3rqLKqudWHLazODYlK/YYUgKddPGNyqPtGvajkr/mFU+fHK6uRFhNra1UT
fOAZPLEHa/nTtbo9pABCOFoZQWLoObuhilvQJPu4trvHYLglz8nljJnuWvgbJ1Hm
K62LtRY1Ynz8j5hQV5mDPw0HitWTKNAIt6B4KJBOH5wuV1phZjjab8BaYP0G+18u
s3iL4NAbHJap3f7dr+imgOlZ6WqlFmzCebKrWu67/Gl4zI1ITiCOxUS5KKzzIcDX
i2ytFLQC1qXQuaS4T7yFW71UvGF+7yC8J+bTK0xPvFapFcp7Hn1HDmmOkcuSL0Hq
l6+NgxGlCr4AB/ZYnJw2XZk0a91LmyR7t8CbBp2tZz/KpmfWBPKnz5wKCFiDTA8T
vwgR3LT6r+SXPr1ZrnxWHQRC8i4/Qbqip0aqR5Q+CTWB503H60bU6t2LsdPgHllQ
H4n5BB07L65n7rXmEHGtp4iut87Dxb6bkfjQscEhqVzg/iLhGktk9DXmiCAYnVN0
PIJ2+PTwZ4TPwYlL2SAbRZBa2nwbxV7sIDaS3CYkUhuPgdzimi7XuSCBsftL2HxG
aK2Z9cxMJ1xOWWhAP14K
=WDrH
-----END PGP SIGNATURE-----

Changed in nova:
status: Fix Committed → Fix Released
Changed in trove:
status: Fix Committed → Fix Released
Akihiro Motoki (amotoki) on 2013-10-24
Changed in python-neutronclient:
status: In Progress → Fix Committed
Download full text (24.9 KiB)

Reviewed: https://review.openstack.org/54029
Committed: http://github.com/openstack/swift/commit/94d3671b0bbf87fdbff845643963f3f9a97c58b5
Submitter: Jenkins
Branch: feature/ec

commit abcecd26a7b5871f75f0fbddf0d08bbac95bb089
Author: Kun Huang <email address hidden>
Date: Wed Oct 23 21:19:01 2013 +0800

    utf8 encode tempurl key

    In tempurl middleware, hmac uses the value of account metadata to
    generate HMAC-SHA1 signature and hmac must accept a str-type string, not
    a unicode string. The meta dict returned from get_info stroges special
    chars as unicode however. So just encode it for tempurl using.

    Closes-Bug: #1242644
    Change-Id: I4be62eea014a573efc4748470de57dccf00e431d

commit cd2e7df0b69bbd269cd3c4170e0fee8186a07c95
Author: Pete Zaitcev <email address hidden>
Date: Tue Oct 22 17:18:04 2013 -0600

    Add an __str__ method to brokers

    A few uses of broker.db_file are in printouts where we do need
    them, so the administrator may know what's up. Seems like an easy
    way to get rid of those is to make brokers identify themselves
    with common __str__. Alternative back-end implementations may
    supply something other than a filename here, for example a cluster
    name and a volume name.

    Note that I'm not sure if correct coercion would occur when
    brokers are bounced through dictionaries, hence explicit str().

    Change-Id: I329788ebd1fbe39ffadcf9f9d5194a74a88dde58

commit 9807a358c6d1314d25e3a41da75be5851fa0ac27
Author: Donagh McCabe <email address hidden>
Date: Fri Aug 23 15:03:08 2013 +0100

    Add WWW-Authenticate to 401 responses

    Per http://www.ietf.org/rfc/rfc2616.txt, when a 401 error is returned, the
    Www-Authenticate response header MUST also be returned. The format is
    described in http://www.ietf.org/rfc/rfc2617.txt.

    Swift supports and/or implements a number of authentication schemes
    including tempauth, Keystone, tempurl, formpost and container sync. In
    this fix, we use a catch-all, "Swift". The realm is the account (where
    known) or "unknown" (bad path or where the 401 is returned from code
    that does not have the request). Examples:

         Www-Authenticate: Swift realm="AUTH_1234567889"
         Www-Authenticate: Swift realm="unknown"

    Fixes bug #1215491

    Change-Id: I03362789318dfa156d3733ef9348795062a9cfc4

commit ed5101b2002b877518466ae5f9a6d652581238f2
Author: Yuan Zhou <email address hidden>
Date: Sat Oct 19 11:40:35 2013 +0800

    Adding more unit tests for audit_location_generator

    Change-Id: I40410fbbb79cea8647074f703e4675364c69d930

commit 5202b0e58613738cc81ec63e7c6da14ce5429526
Author: Peter Portante <email address hidden>
Date: Thu Sep 12 19:51:18 2013 -0400

    DiskFile API, with reference implementation

    Refactor on-disk knowledge out of the object server by pushing the
    async update pickle creation to the new DiskFileManager class (name is
    not the best, so suggestions welcome), along with the REPLICATOR
    method logic. We also move the mount checking and thread pool storage
    to the new ondisk.Devices object, which then also becomes th...

ZhiQiang Fan (aji-zqfan) on 2013-12-30
Changed in tempest:
status: In Progress → Fix Committed
Changed in python-glanceclient:
status: In Progress → Fix Committed
Changed in hacking:
status: In Progress → Fix Committed
Changed in devstack:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2014-01-22
no longer affects: ironic
no longer affects: python-troveclient
Matthew Treinish (treinish) wrote :

affects tempest
status fixreleased

Akihiro Motoki (amotoki) on 2014-10-17
Changed in python-neutronclient:
milestone: none → 2.3.0-2.3.4
Akihiro Motoki (amotoki) on 2015-03-03
tags: added: released-neutronclient
Joe Gordon (jogo) on 2015-04-09
no longer affects: hacking
Changed in python-ceilometerclient:
status: Fix Committed → Fix Released
Changed in python-cinderclient:
status: Fix Committed → Fix Released
Changed in python-glanceclient:
milestone: none → 1.0.0
status: Fix Committed → Fix Released
Akihiro Motoki (amotoki) wrote :

We cannot update the status to Fix Released in neutronclient. Instead i will remove neutronclient from the affected projects to make the bug list simple.

no longer affects: python-neutronclient
Akihiro Motoki (amotoki) on 2015-12-10
tags: removed: released-neutronclient
Changed in python-neutronclient:
assignee: nobody → Akihiro Motoki (amotoki)
status: New → Fix Released
ZhiQiang Fan (aji-zqfan) on 2016-04-15
Changed in devstack:
status: Fix Committed → Fix Released
Changed in tempest:
status: Fix Committed → Fix Released
Changed in murano:
assignee: nobody → Dinesh Bhor (dinesh-bhor)

Fix proposed to branch: master
Review: https://review.openstack.org/346669

Changed in murano:
status: New → In Progress

Reviewed: https://review.openstack.org/346675
Committed: https://git.openstack.org/cgit/openstack/keystone/commit/?id=d0328e3293d411c8d5ff9e17175511498cab78f4
Submitter: Jenkins
Branch: master

commit d0328e3293d411c8d5ff9e17175511498cab78f4
Author: dineshbhor <email address hidden>
Date: Fri Jul 22 13:05:43 2016 +0530

    Replace OpenStack LLC with OpenStack Foundation

    Change-Id: I08ad2fad6122734cbcc5842c0b6f76c5f680b69c
    Closes-Bug: #1214176

Changed in python-manilaclient:
assignee: nobody → Dinesh Bhor (dinesh-bhor)

Fix proposed to branch: master
Review: https://review.openstack.org/347285

Changed in python-manilaclient:
status: New → In Progress
Changed in cinder:
assignee: nobody → Dinesh Bhor (dinesh-bhor)

Fix proposed to branch: master
Review: https://review.openstack.org/347288

Changed in cinder:
status: New → In Progress
Changed in python-troveclient:
assignee: nobody → Dinesh Bhor (dinesh-bhor)

Fix proposed to branch: master
Review: https://review.openstack.org/347294

Changed in python-troveclient:
status: New → In Progress
Changed in pbr:
assignee: nobody → Dinesh Bhor (dinesh-bhor)

Fix proposed to branch: master
Review: https://review.openstack.org/347299

Changed in pbr:
status: New → In Progress
Changed in glance:
importance: Undecided → Low
status: New → Triaged
assignee: nobody → Dinesh Bhor (dinesh-bhor)

Reviewed: https://review.openstack.org/347288
Committed: https://git.openstack.org/cgit/openstack/python-glanceclient/commit/?id=98bbbb88e74cd0a631c74cac425db9864ad3d93d
Submitter: Jenkins
Branch: master

commit 98bbbb88e74cd0a631c74cac425db9864ad3d93d
Author: dineshbhor <email address hidden>
Date: Tue Jul 26 15:17:14 2016 +0530

    Replace OpenStack LLC with OpenStack Foundation

    Change-Id: I5877db07031b12d8fa7ed774ac09d24f8906ea86
    Closes-Bug: #1214176

Change abandoned by Anthony Washington (<email address hidden>) on branch: master
Review: https://review.openstack.org/347497

Reviewed: https://review.openstack.org/346673
Committed: https://git.openstack.org/cgit/openstack/trove/commit/?id=43546ce905d0f2517ac447334257dd50c2a2e39f
Submitter: Jenkins
Branch: master

commit 43546ce905d0f2517ac447334257dd50c2a2e39f
Author: dineshbhor <email address hidden>
Date: Fri Jul 22 14:11:20 2016 +0530

    Replace OpenStack LLC with OpenStack Foundation

    Change-Id: I7b738715873eff90a49357dec5be4e179c04713c
    Closes-Bug: #1214176

Reviewed: https://review.openstack.org/347277
Committed: https://git.openstack.org/cgit/openstack/tempest/commit/?id=1c5dc627e9c6caa748a541841ca93c4181bf014e
Submitter: Jenkins
Branch: master

commit 1c5dc627e9c6caa748a541841ca93c4181bf014e
Author: dineshbhor <email address hidden>
Date: Tue Jul 26 15:37:40 2016 +0530

    Replace OpenStack LLC with OpenStack Foundation

    Some files still use trademark OpenStack LLC in header, which
    should be changed to OpenStack Foundation according to
    openstack trademark policy:
    http://www.openstack.org/brand/openstack-trademark-policy/

    Change-Id: I4c71a93931e6a39c33885b64b27fe80229057ff4
    Closes-Bug: #1214176

Reviewed: https://review.openstack.org/347408
Committed: https://git.openstack.org/cgit/openstack/glance/commit/?id=b2e3ed90737b7c9ef8119758db690e2822b7af9b
Submitter: Jenkins
Branch: master

commit b2e3ed90737b7c9ef8119758db690e2822b7af9b
Author: dineshbhor <email address hidden>
Date: Tue Jul 26 19:29:23 2016 +0530

    Replace OpenStack LLC with OpenStack Foundation

    Change-Id: Ifee4e6eef37fe00019dd3adfaef8bb99a7970944
    Closes-Bug: #1214176

Changed in glance:
status: Triaged → Fix Released

Reviewed: https://review.openstack.org/347285
Committed: https://git.openstack.org/cgit/openstack/python-manilaclient/commit/?id=093a2e69f60bef9db025b1b2a2bec76f66c1c9bd
Submitter: Jenkins
Branch: master

commit 093a2e69f60bef9db025b1b2a2bec76f66c1c9bd
Author: dineshbhor <email address hidden>
Date: Tue Jul 26 16:22:37 2016 +0530

    Replace OpenStack LLC with OpenStack Foundation

    TrivialFix
    Change-Id: I336952baacf55e36ad0a56ac98b95977fc0d593a
    Closes-Bug: #1214176

Changed in python-manilaclient:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/347290
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=1761d87fafb5e2d3cbb60896fa302b23f4252dc0
Submitter: Jenkins
Branch: master

commit 1761d87fafb5e2d3cbb60896fa302b23f4252dc0
Author: dineshbhor <email address hidden>
Date: Tue Jul 26 15:23:59 2016 +0530

    Replace OpenStack LLC with OpenStack Foundation

    Change-Id: I199fffd139a4d077985373231354343228d9d8b8
    Closes-Bug: #1214176

Changed in cinder:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/347296
Committed: https://git.openstack.org/cgit/openstack/python-cinderclient/commit/?id=1f372ebcc76b3e4e2e94dc43b14d3d214de3157f
Submitter: Jenkins
Branch: master

commit 1f372ebcc76b3e4e2e94dc43b14d3d214de3157f
Author: dineshbhor <email address hidden>
Date: Tue Jul 26 12:05:14 2016 +0530

    Replace OpenStack LLC with OpenStack Foundation

    Change-Id: Icf7d5b9f8887e75532ebf5b17835a2b1b22be3c3
    Closes-Bug: #1214176

This issue was fixed in the openstack/python-glanceclient 2.3.0 release.

Reviewed: https://review.openstack.org/347294
Committed: https://git.openstack.org/cgit/openstack/python-troveclient/commit/?id=ecdae90c776859533b59dc4eba217d0d804a8a15
Submitter: Jenkins
Branch: master

commit ecdae90c776859533b59dc4eba217d0d804a8a15
Author: dineshbhor <email address hidden>
Date: Tue Jul 26 11:55:09 2016 +0530

    Replace OpenStack LLC with OpenStack Foundation

    Change-Id: I108bd63dce28be059ce1bbbcc7b1a5c4488f028e
    Closes-Bug: #1214176

Changed in python-troveclient:
status: In Progress → Fix Released
Changed in murano:
importance: Undecided → Low
milestone: none → newton-3

Reviewed: https://review.openstack.org/346669
Committed: https://git.openstack.org/cgit/openstack/murano/commit/?id=0854616891b54cb90db9ab92fc8b0174720efb04
Submitter: Jenkins
Branch: master

commit 0854616891b54cb90db9ab92fc8b0174720efb04
Author: dineshbhor <email address hidden>
Date: Fri Jul 22 12:50:33 2016 +0530

    Replace OpenStack LLC with OpenStack Foundation

    Change-Id: I0c2f97bbd8bb61b9b35ccf0f21f2c52ddaf0f72b
    Closes-Bug: #1214176

Changed in murano:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/347299
Committed: https://git.openstack.org/cgit/openstack-dev/pbr/commit/?id=a95982f9a061fa29fd98a87ffd6f9fe7043d5e1f
Submitter: Jenkins
Branch: master

commit a95982f9a061fa29fd98a87ffd6f9fe7043d5e1f
Author: dineshbhor <email address hidden>
Date: Tue Jul 26 16:30:10 2016 +0530

    Replace OpenStack LLC with OpenStack Foundation

    Change-Id: I03fac862d7346bdac83503afb5f26119d0ea300d
    Closes-Bug: #1214176

Changed in pbr:
status: In Progress → Fix Released

This issue was fixed in the openstack/python-troveclient 2.4.0 release.

This issue was fixed in the openstack/python-manilaclient 1.11.0 release.

This issue was fixed in the openstack/trove 6.0.0.0b3 development milestone.

This issue was fixed in the openstack/trove 6.0.0.0b3 development milestone.

This issue was fixed in the openstack/murano 3.0.0.0b3 development milestone.

This issue was fixed in the openstack/glance 13.0.0.0b3 development milestone.

This issue was fixed in the openstack/python-cinderclient 1.9.0 release.

This issue was fixed in the openstack/glance 13.0.0.0b3 development milestone.

This issue was fixed in the openstack/cinder 9.0.0.0b3 development milestone.

This issue was fixed in the openstack/keystone 10.0.0.0b3 development milestone.

This issue was fixed in the openstack/python-cinderclient 1.9.0 release.

This issue was fixed in the openstack/python-manilaclient 1.11.0 release.

This issue was fixed in the openstack/python-cinderclient 1.9.0 release.

This issue was fixed in the openstack/python-manilaclient 1.11.0 release.

This issue was fixed in the openstack/python-cinderclient 1.9.0 release.

This issue was fixed in the openstack/python-manilaclient 1.11.0 release.

This issue was fixed in the openstack/python-cinderclient 1.9.0 release.

This issue was fixed in the openstack/python-manilaclient 1.11.0 release.

This issue was fixed in the openstack-dev/pbr 2.0.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers