missing dependency - babel

Bug #1211270 reported by Jan Provaznik on 2013-08-12
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Identity (keystone)
Low
Clint Byrum

Bug Description

Commit 2c2ebe88a18f3096035812e96ffcf4b23a0395be adds dependency on babel. Babel should be listed in requirements.txt too.

Changed in keystone:
assignee: nobody → Jan Provaznik (jan-provaznik)

Fix proposed to branch: master
Review: https://review.openstack.org/41378

Changed in keystone:
status: New → In Progress
Dolph Mathews (dolph) wrote :

Babel is already required:

  $ ack Babel
  test-requirements.txt
  44:Babel

Are you suggesting it be moved to requirements.txt?

Changed in keystone:
importance: Undecided → Low
Clint Byrum (clint-fewbar) wrote :

Yes, it needs to be in requirements because of keystone.openstack.common.gettextutils:

Traceback (most recent call last):
  File "/opt/stack/venvs/keystone/bin/keystone-manage", line 16, in <module>
    from keystone import cli
  File "/opt/stack/venvs/keystone/local/lib/python2.7/site-packages/keystone/cli.py", line 28, in <module>
    from keystone.common import openssl
  File "/opt/stack/venvs/keystone/local/lib/python2.7/site-packages/keystone/common/openssl.py", line 23, in <module>
    from keystone import config
  File "/opt/stack/venvs/keystone/local/lib/python2.7/site-packages/keystone/config.py", line 21, in <module>
    from keystone import exception
  File "/opt/stack/venvs/keystone/local/lib/python2.7/site-packages/keystone/exception.py", line 19, in <module>
    from keystone.openstack.common.gettextutils import _ # noqa
  File "/opt/stack/venvs/keystone/local/lib/python2.7/site-packages/keystone/openstack/common/gettextutils.py", line 34, in <module>
    from babel import localedata
ImportError: No module named babel

Clint Byrum (clint-fewbar) wrote :

BTW this should be at least Medium importance if not High. It is a regression introduced by this change:

commit 2c2ebe88a18f3096035812e96ffcf4b23a0395be
Author: Lance Bragstad <email address hidden>
Date: Fri Aug 2 14:26:30 2013 +0000

    Sync unified logging solution from Oslo

    This commit introduces a unified logging strategy from oslo-incubator in
    an attempt to standardize logging in Keystone similar to other OpenStack
    projects (Nova, Quantum, etc.). This commit only introduces
    oslo-incubator/openstack/common/log.py and it's dependencies.
    Implementation of this logging solution will be purposed later.

    blueprint unified-logging-in-keystone

    Change-Id: I860c0f0e935fcd7b4c4886ffd54bf22f2cf4cbb3

The reason it isn't detected is that the gate runs devstack and so other components of openstack end up bringing in babel.

Changed in keystone:
assignee: Jan Provaznik (jan-provaznik) → Clint Byrum (clint-fewbar)

Reviewed: https://review.openstack.org/41378
Committed: http://github.com/openstack/keystone/commit/62b4e1f40886913a5e87cc37ca3b165d87913a52
Submitter: Jenkins
Branch: master

commit 62b4e1f40886913a5e87cc37ca3b165d87913a52
Author: Jan Provaznik <email address hidden>
Date: Mon Aug 12 13:07:42 2013 +0200

    Move Babel dependency from test-req to req

    Recent changes added an undeclared dependency on babel in
    keystone.openstack.common.gettextutils.

    Change-Id: I045195e056c555a293371b50cfc3d7ec0c110ba7
    Fixes: bug #1211270

Changed in keystone:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-09-05
Changed in keystone:
milestone: none → havana-3
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in keystone:
milestone: havana-3 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers