token provider/format defaults and uuid unexpected behavior

Bug #1204314 reported by Brant Knudson on 2013-07-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Identity (keystone)
High
Brant Knudson

Bug Description

A couple of configs where it doesn't look like the Keystone server is acting correctly.

Config 1: Defaults for both token_format and provider.

[signing]
# Deprecated in favor of provider in the [token] section
#token_format = PKI

[token]
driver = keystone.token.backends.sql.Token
# Provides token persistence.
# driver = keystone.token.backends.sql.Token

- says
keystone.conf [signing] token_format is deprecated in favor of keystone.conf [token] provider

I don't have token_format set, so Keystone shouldn't be complaining.

Config 2: don't set token_format because it deprecated, use uuid provider.

[signing]
# Deprecated in favor of provider in the [token] section
#token_format = PKI

[token]
driver = keystone.token.backends.sql.Token
# Provides token persistence.
# driver = keystone.token.backends.sql.Token

# Controls the token construction, validation, and revocation operations.
provider = keystone.token.providers.uuid.Provider

- server fails to start, saying
 keystone.conf [signing] token_format (deprecated) conflicts with keystone.conf [token] provider

I'm not using token_format because it's deprecated, so the server shouldn't fail to start when I don't use it with uuid provider.

Brant Knudson (blk-u) on 2013-07-24
summary: - Configuring token provider and format not working
+ token provider/format defaults and uuid unexpected behavior
Dolph Mathews (dolph) on 2013-07-24
Changed in keystone:
status: New → Triaged
importance: Undecided → High

Fix proposed to branch: master
Review: https://review.openstack.org/38404

Changed in keystone:
assignee: nobody → Brant Knudson (blk-u)
status: Triaged → In Progress

Reviewed: https://review.openstack.org/38404
Committed: http://github.com/openstack/keystone/commit/7b4fedeed3517a17d32dad820bae2a49dd6c3e1b
Submitter: Jenkins
Branch: master

commit 7b4fedeed3517a17d32dad820bae2a49dd6c3e1b
Author: Brant Knudson <email address hidden>
Date: Tue Jul 23 21:16:01 2013 -0500

    default token format/provider handling

    The Keystone server would print a warning when both the token
    format and provider were set to the default.

    Also, the Keystone server would not start if the format was
    commented out and the provider was set to the uuid.Provider.

    Fixes: bug 1204314

    Change-Id: Id7db33a1f27c4986af153efc73b22db8c6a8942e

Changed in keystone:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-09-05
Changed in keystone:
milestone: none → havana-3
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in keystone:
milestone: havana-3 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers