Relax OpenStack upper capping of client versions

Bug #1200214 reported by Dirk Mueller on 2013-07-11
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ceilometer
Undecided
gordon chung
Cinder
High
John Griffith
Glance Client
Undecided
Sean Dague
Ironic
Fix Released
High
Kun Huang
OpenStack Compute (nova)
High
Sean Dague
OpenStack Dashboard (Horizon)
High
David Lyle
OpenStack Heat
Fix Released
High
Steve Baker
OpenStack Identity (keystone)
High
Kun Huang
python-ceilometerclient
Undecided
Unassigned
python-cinderclient
Undecided
John Griffith
python-heatclient
Fix Released
High
Dirk Mueller
tempest
High
Matthew Treinish

Bug Description

Because of the way the gate process pip requirements (one project at a time), on a current gate run
we actually install and uninstall python-keystoneclient 4 times in a
normal run, flipping back and forth from HEAD to 0.2.5.

http://paste.openstack.org/show/39880/ - shows what's going on

The net of this means that if any of the projects specify a capped
client, it has the potential for preventing that client from being
tested in the gate.

As part of the discussion here:

http://lists.openstack.org/pipermail/openstack-dev/2013-July/011660.html

it was suggested to only cap client versions at the major version, since all minor version bumps must be strictly backward compatible by policy.

Dolph Mathews (dolph) on 2013-07-11
Changed in keystone:
status: New → Confirmed
importance: Undecided → High
Changed in tempest:
importance: Undecided → High
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/36671

Changed in tempest:
assignee: nobody → Matthew Treinish (treinish)
status: Confirmed → In Progress
John Griffith (john-griffith) wrote :

cinder is already in flight here: https://review.openstack.org/#/c/36344/
and was approved prior to my seeing the bug report here.

Changed in cinder:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Adam Gandelman (gandelman-a)
John Griffith (john-griffith) wrote :

derp! New update to requirements. Got it

Changed in cinder:
assignee: Adam Gandelman (gandelman-a) → John Griffith (john-griffith)
status: Triaged → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/36681

Changed in keystone:
assignee: nobody → Kun Huang (academicgareth)
status: Confirmed → In Progress
Changed in nova:
assignee: nobody → Kun Huang (academicgareth)
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/36683

Changed in ironic:
assignee: nobody → Kun Huang (academicgareth)
status: New → In Progress
Changed in heat:
assignee: nobody → Steve Baker (steve-stevebaker)
status: New → Triaged
Changed in python-heatclient:
assignee: nobody → Steve Baker (steve-stevebaker)
status: New → Triaged
Changed in heat:
importance: Undecided → High
Changed in python-heatclient:
importance: Undecided → High
Changed in heat:
milestone: none → havana-2

Fix proposed to branch: master
Review: https://review.openstack.org/36753

Changed in cinder:
status: Confirmed → In Progress
David Lyle (david-lyle) on 2013-07-12
Changed in horizon:
importance: Undecided → High
status: New → Confirmed
assignee: nobody → David Lyle (david-lyle)

Reviewed: https://review.openstack.org/36753
Committed: http://github.com/openstack/cinder/commit/942ff9c57a3ccf2859d2a7feea026417c38f8864
Submitter: Jenkins
Branch: master

commit 942ff9c57a3ccf2859d2a7feea026417c38f8864
Author: John Griffith <email address hidden>
Date: Thu Jul 11 18:02:45 2013 -0600

    Update requirements from openstack/requirements.

    Fixes bug: 1200214

    Change-Id: I31edd5283b72ac46e99a11aca196f5b9915c4465

Changed in cinder:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/36671
Committed: http://github.com/openstack/tempest/commit/b3635c99a8332400b2c7a05c8f63bf5ac8618663
Submitter: Jenkins
Branch: master

commit b3635c99a8332400b2c7a05c8f63bf5ac8618663
Author: Matthew Treinish <email address hidden>
Date: Thu Jul 11 10:44:18 2013 -0400

    Remove version caps from python-fooclient.

    This removes the version caps from python-neutronclient and
    python-cinderclient in Tempest. Per mailing list thread, allowing
    any project to cap one of our own clients actually prevents us
    from testing that client's git version in devstack gate (because
    there are 2 ways to install a python client, one from git, one from
    pip). This can allow bugs to creep into the clients because they are
    no longer tested in the gate.

    An exception is currently being made for neutron client because of
    the need for an incompatible change in their next release.

    Fixes bug #1200214 for Tempest

    Change-Id: I00a451448ec380068905b28f3b74656c083dc261

Changed in tempest:
status: In Progress → Fix Released

Fix proposed to branch: master
Review: https://review.openstack.org/36897

Changed in horizon:
status: Confirmed → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/36903

Changed in python-glanceclient:
assignee: nobody → Sean Dague (sdague)
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/36907

Changed in nova:
assignee: Kun Huang (academicgareth) → Sean Dague (sdague)
Changed in ceilometer:
assignee: nobody → Sean Dague (sdague)
status: New → In Progress
Sean Dague (sdague) on 2013-07-13
Changed in nova:
importance: Undecided → High
milestone: none → havana-2

Reviewed: https://review.openstack.org/36875
Committed: http://github.com/openstack/python-ceilometerclient/commit/3498d5146dbc5b6021c72b0a802af266b213f646
Submitter: Jenkins
Branch: master

commit 3498d5146dbc5b6021c72b0a802af266b213f646
Author: Gordon Chung <email address hidden>
Date: Fri Jul 12 14:14:03 2013 -0400

    Relax OpenStack upper capping of client versions

    uncap upper keystoneclient version

    Change-Id: Id1017f6073be8b7b95ca7ff0c68e09f61b26bb82
    Fixes: bug#1200214

Changed in python-ceilometerclient:
status: New → Fix Committed
Changed in python-heatclient:
assignee: Steve Baker (steve-stevebaker) → Dirk Mueller (dmllr)
status: Triaged → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/36992

Changed in ironic:
assignee: Kun Huang (academicgareth) → Dirk Mueller (dmllr)

Reviewed: https://review.openstack.org/36983
Committed: http://github.com/openstack/python-heatclient/commit/011fff3416eaeff7e573668e80cf48ce2224b080
Submitter: Jenkins
Branch: master

commit 011fff3416eaeff7e573668e80cf48ce2224b080
Author: Dirk Mueller <email address hidden>
Date: Sun Jul 14 18:13:33 2013 +0200

    Raise requirements to be in sync with OpenStack/Requirements

    Mainly due to the testing deps being outdated. Also
    fixes client capping.

    Fixes LP Bug #1200214

    Change-Id: I39c18144bc19189513fc4c1f9712b8938bd719cf

Changed in python-heatclient:
status: In Progress → Fix Committed

Fix proposed to branch: master
Review: https://review.openstack.org/37006

Changed in python-cinderclient:
assignee: nobody → John Griffith (john-griffith)
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/37013

Changed in heat:
status: Triaged → In Progress

Reviewed: https://review.openstack.org/37013
Committed: http://github.com/openstack/heat/commit/be17d129a3cf3820032a42a84dbc636752030920
Submitter: Jenkins
Branch: master

commit be17d129a3cf3820032a42a84dbc636752030920
Author: Steve Baker <email address hidden>
Date: Mon Jul 15 16:15:57 2013 +1200

    Align OpenStack client versions with project requirements.

    This brings heat into line with the consensus on how to specify
    version range caps.

    Fixes bug: #1200214

    Change-Id: I14affc96c44f865fdd0516c1eb4eb59f1a808b82

Changed in heat:
status: In Progress → Fix Committed
Changed in ironic:
assignee: Dirk Mueller (dmllr) → Kun Huang (academicgareth)

Reviewed: https://review.openstack.org/37006
Committed: http://github.com/openstack/python-cinderclient/commit/d7208847efb5bb0df1d1f3340681915d867847b9
Submitter: Jenkins
Branch: master

commit d7208847efb5bb0df1d1f3340681915d867847b9
Author: John Griffith <email address hidden>
Date: Sun Jul 14 19:47:58 2013 -0600

    Update to latest openstack/requirements.

    Fixes bug: 1200214

    Change-Id: I0ff8a76eb5d5a99892a270909c68207858e1bc8b

Changed in python-cinderclient:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/36907
Committed: http://github.com/openstack/nova/commit/b31be6e16ff48823630f1ef94b03f9857044edcd
Submitter: Jenkins
Branch: master

commit b31be6e16ff48823630f1ef94b03f9857044edcd
Author: Sean Dague <email address hidden>
Date: Fri Jul 12 17:23:13 2013 -0400

    remove python-glanceclient cap

    if any of the projects specify a capped client, it has the
    potential for preventing that client from being tested in the
    gate. To fix this we have to uncap maximum versions of all
    openstack client code in all openstack projects.

    (Note Neutronclient needs special dispensation for now, so
    it is left capped.)

    (Rebased after a neutron rename landed)

    Fixes bug #1200214

    Change-Id: I0168cb645279a819942a442c800afb1d0336203c

Changed in nova:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/36903
Committed: http://github.com/openstack/python-glanceclient/commit/29270bb853d1fa5e05139197c77fb13f3898ead4
Submitter: Jenkins
Branch: master

commit 29270bb853d1fa5e05139197c77fb13f3898ead4
Author: Sean Dague <email address hidden>
Date: Fri Jul 12 17:13:15 2013 -0400

    uncap python-keystoneclient version requirement

    if any of the projects specify a capped client, it has the
    potential for preventing that client from being tested in the
    gate. To fix this we have to uncap maximum versions of all
    openstack client code in all openstack projects.

    Fixes bug #1200214

    Change-Id: I664d2f030972a3bbb08ae1c4b1710816b54b44b2

Changed in python-glanceclient:
status: In Progress → Fix Committed
Changed in ironic:
importance: Undecided → High

Reviewed: https://review.openstack.org/36683
Committed: http://github.com/openstack/ironic/commit/3a3ce4399a03024517e16fd6c9d61b887b9eba02
Submitter: Jenkins
Branch: master

commit 3a3ce4399a03024517e16fd6c9d61b887b9eba02
Author: Kun Huang <email address hidden>
Date: Thu Jul 11 23:45:28 2013 +0800

    update requires to prevent version cap

    OpenStack clients. None of these should have an upper bound
    as that has implications for testing in the gate. An exception
    is currently being made for neutron client because of the need
    for an incompatible change in their next release.
    https://github.com/openstack/requirements

    fixes bug #1200214

    Change-Id: I6cc851554e2dcc620bfeb45dc63c9d80d09e9586

Changed in ironic:
status: In Progress → Fix Committed
Changed in ceilometer:
assignee: Sean Dague (sdague) → Kun Huang (academicgareth)
Changed in python-heatclient:
milestone: none → v0.2.3
Changed in ceilometer:
assignee: Kun Huang (academicgareth) → Sean Dague (sdague)
Thierry Carrez (ttx) on 2013-07-17
Changed in cinder:
milestone: none → havana-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-07-17
Changed in nova:
status: Fix Committed → Fix Released
Changed in heat:
status: Fix Committed → Fix Released

Reviewed: https://review.openstack.org/36680
Committed: http://github.com/openstack/keystone/commit/bd23cf25e2eeb139c6f3b35abf1e644a4270c0f2
Submitter: Jenkins
Branch: master

commit bd23cf25e2eeb139c6f3b35abf1e644a4270c0f2
Author: Kun Huang <email address hidden>
Date: Thu Jul 11 23:29:51 2013 +0800

    update requires to prevent version cap

    OpenStack clients requirements should not have an upper bound
    as that has implications for testing in the gate.

    ref: https://github.com/openstack/requirements

    fixes bug #1200214
    Change-Id: I45c8e94ede892a4d5412ac43aae9c4e131907c89

Changed in keystone:
status: In Progress → Fix Committed
David Lyle (david-lyle) on 2013-07-23
Changed in horizon:
milestone: none → havana-3

Reviewed: https://review.openstack.org/36897
Committed: http://github.com/openstack/horizon/commit/129a3d912998abef768492af125bea29bd6f0aa7
Submitter: Jenkins
Branch: master

commit 129a3d912998abef768492af125bea29bd6f0aa7
Author: David Lyle <email address hidden>
Date: Fri Jul 12 14:23:13 2013 -0600

    Unpinning upper bound on python-*clients

    If any of the projects specify a capped client, it has the
    potential for preventing that client from being tested in the
    gate. To fix this, maximum versions are uncapped for all
    openstack client code in all openstack projects.

    python-neutronclient is treated as an exception for now.

    Fixes: bug #1200214

    Change-Id: I64c68db0632b6547a6340c952bdb9cafe11ea1d9

Changed in horizon:
status: In Progress → Fix Committed

Fix proposed to branch: master
Review: https://review.openstack.org/38750

Changed in ceilometer:
assignee: Sean Dague (sdague) → gordon chung (chungg)

Reviewed: https://review.openstack.org/38750
Committed: http://github.com/openstack/ceilometer/commit/688c725ec15b7a38a5386a71144edce8cc1236cc
Submitter: Jenkins
Branch: master

commit 688c725ec15b7a38a5386a71144edce8cc1236cc
Author: Gordon Chung <email address hidden>
Date: Fri Jul 26 01:49:09 2013 -0400

    Relax OpenStack upper capping of client versions

    - uncap keystoneclient and bump to >=0.3.0 to match requirements
    - fix test case to handle change in keystoneclient where cached
    values are stored as string now. Previous test passed in tuple and
    new auth_token would fail when it tried to json.loads the
    tuple. (see _cache_get() in keystone auth_token)

    Change-Id: I568d8e0ae6586b91d5e38cb8750731f3fe6e22e7
    Fixes:Bug#1200214

Changed in ceilometer:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-09-05
Changed in keystone:
milestone: none → havana-3
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-09-05
Changed in ceilometer:
milestone: none → havana-3
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-09-05
Changed in horizon:
status: Fix Committed → Fix Released
Sean Dague (sdague) on 2013-09-23
Changed in tempest:
milestone: none → havana-3
Changed in python-heatclient:
milestone: v0.2.3 → none
status: Fix Committed → Fix Released
milestone: none → v0.2.5
Thierry Carrez (ttx) on 2013-10-17
Changed in ceilometer:
milestone: havana-3 → 2013.2
Thierry Carrez (ttx) on 2013-10-17
Changed in heat:
milestone: havana-2 → 2013.2
Thierry Carrez (ttx) on 2013-10-17
Changed in cinder:
milestone: havana-2 → 2013.2
Thierry Carrez (ttx) on 2013-10-17
Changed in nova:
milestone: havana-2 → 2013.2
Thierry Carrez (ttx) on 2013-10-17
Changed in keystone:
milestone: havana-3 → 2013.2
Thierry Carrez (ttx) on 2013-10-17
Changed in horizon:
milestone: havana-3 → 2013.2
Thierry Carrez (ttx) on 2014-01-22
Changed in ironic:
milestone: none → icehouse-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2014-04-17
Changed in ironic:
milestone: icehouse-2 → 2014.1
Louis Taylor (kragniz) on 2014-09-21
Changed in python-glanceclient:
status: Fix Committed → Fix Released
Changed in python-ceilometerclient:
milestone: none → 1.3.0
status: Fix Committed → Fix Released
Changed in python-cinderclient:
milestone: none → 1.3.1
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers