tox cover testing is failing due to a missing entry in tox.ini

Bug #1195371 reported by Anthony Dodd on 2013-06-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Identity (keystone)
Low
Anthony Dodd

Bug Description

`tox -e cover` is failing due to a missing entry in keystone's tox.ini file.
In tox.ini the following code appears:
'''
[testenv:cover]
setenv = NOSE_WITH_COVERAGE=1
         NOSE_COVER_HTML=1
         NOSE_COVER_HTML_DIR={toxinidir}/cover
'''

Adding 'VIRTUAL_ENV={envdir}' to the setenv mapping, as shown below, has resolved the issue on my machine.
'''
[testenv:cover]
setenv = VIRTUAL_ENV={envdir}
         NOSE_WITH_COVERAGE=1
         NOSE_COVER_HTML=1
         NOSE_COVER_HTML_DIR={toxinidir}/cover
'''

Anthony Dodd (thedodd) on 2013-06-27
Changed in keystone:
assignee: nobody → Anthony Dodd (thedodd)
Clark Boylan (cboylan) wrote :

This happened when I patched tox.ini to make tox -ecover work for jenkins and ended up just breaking it for everyone :(

Changed in keystone:
status: New → Confirmed
Anthony Dodd (thedodd) wrote :

Thanks for the confirmation Clark! I will fix the issue right now. The changes should be ready for review shortly.

Changed in keystone:
status: Confirmed → In Progress
Dolph Mathews (dolph) on 2013-06-28
Changed in keystone:
importance: Undecided → Low

Reviewed: https://review.openstack.org/34766
Committed: http://github.com/openstack/keystone/commit/a8f2512f2511a3bce314e90bfb46d7083cb998da
Submitter: Jenkins
Branch: master

commit a8f2512f2511a3bce314e90bfb46d7083cb998da
Author: Anthony Dodd <email address hidden>
Date: Thu Jun 27 11:24:45 2013 -0500

    `tox -ecover` failure. Missing entry in tox.ini

    `tox -ecover` is failing due to a missing entry in keystone's tox.ini file.
    In tox.ini the following code appears:
    '''
    [testenv:cover]
    setenv = NOSE_WITH_COVERAGE=1
             NOSE_COVER_HTML=1
             NOSE_COVER_HTML_DIR={toxinidir}/cover
    '''

    Adding 'VIRTUAL_ENV={envdir}' to the setenv mapping, as shown below,
    has resolved the issue on my machine.
    '''
    [testenv:cover]
    setenv = VIRTUAL_ENV={envdir}
             NOSE_WITH_COVERAGE=1
             NOSE_COVER_HTML=1
             NOSE_COVER_HTML_DIR={toxinidir}/cover
    '''

    Change-Id: I3550ac61cdc6389dd239c5ad319d881519b3543d
    Fixes: bug #1195371

Changed in keystone:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-07-17
Changed in keystone:
milestone: none → havana-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in keystone:
milestone: havana-2 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers