Logging use logging.conf doesn't workwhen keystone is fronted by apache via mod-wsgi

Bug #1190324 reported by Haneef Ali on 2013-06-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Identity (keystone)
Medium
Jamie Lennox

Bug Description

Logging use logging.conf doesn't workwhen keystone is fronted by apache via mod-wsgi

Haneef Ali (haneef) on 2013-06-12
Changed in keystone:
assignee: nobody → HANEEF Ali (haneef)
Dolph Mathews (dolph) wrote :

Can you be more specific regarding how it "doesn't work"?

Changed in keystone:
status: New → Incomplete

Fix proposed to branch: master
Review: https://review.openstack.org/32778

Changed in keystone:
status: Incomplete → In Progress
Haneef Ali (haneef) wrote :

Logging is not setup in keystone.py whereas it is setup in keystone-bin ( which is standalone server)

(i.e) config.setup_logging(CONF) is missing

https://review.openstack.org/#/c/32778/

Changed in keystone:
assignee: HANEEF Ali (haneef) → Dolph Mathews (dolph)
Dolph Mathews (dolph) on 2013-06-12
Changed in keystone:
importance: Undecided → Medium
assignee: Dolph Mathews (dolph) → Jamie Lennox (jamielennox)

Reviewed: https://review.openstack.org/32658
Committed: http://github.com/openstack/keystone/commit/86eab682fcf1b43113a1fc66eb571ace00014473
Submitter: Jenkins
Branch: master

commit 86eab682fcf1b43113a1fc66eb571ace00014473
Author: Jamie Lennox <email address hidden>
Date: Wed Jun 12 10:11:12 2013 +1000

    Initialize logging from HTTPD.

    Fixes bug 1190324

    Change-Id: I6031c26c4917bd526c5918d815bff3bd060301c8

Changed in keystone:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-07-17
Changed in keystone:
milestone: none → havana-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in keystone:
milestone: havana-2 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers