Too many stat warning logs

Bug #1189118 reported by Wu Wenxiang on 2013-06-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Identity (keystone)
Low
Wu Wenxiang

Bug Description

In deploying environment.
I run multi keystone processes in multi ports, and use a haproxy to proxy all of them, like below:

_____Haproxy(5000)
                           |______Keystone-1(5000)
                           |______Keystone-2(5001)
                           |______Keystone-3(5002)
                           |______Keystone-4(5003)

I use this topo because of performance.

details: https://answers.launchpad.net/keystone/+question/230455

And I found too many warning logs in syslog:
Unable to resolve API as either public or admin: Haproxy:5000
Unable to resolve API as either public or admin: Haproxy:5000
Unable to resolve API as either public or admin: Haproxy:5000
....

Reason:
The root cause is Keystone-2~Keystone-4 not listened in 5000 as same as haproxy, so stat logic could handle.

I think this warning should be removed.
Or we should find another way to stat port.

Fix proposed to branch: master
Review: https://review.openstack.org/32312

Changed in keystone:
assignee: nobody → Wu Wenxiang (wu-wenxiang)
status: New → In Progress
Dolph Mathews (dolph) on 2013-06-10
Changed in keystone:
importance: Undecided → Low
Wu Wenxiang (wu-wenxiang) wrote :

In fact, I really prefer using "multi-worker children processes" which was the same as nova-api and cinder-api. With multi-worker solution, we could launch more than 1 process listened at the same port, which fix this issue more graceful.
How about your opinions?

Reviewed: https://review.openstack.org/32312
Committed: http://github.com/openstack/keystone/commit/6ca63a77e228a32b6e4763ec3d6b198a14769bb8
Submitter: Jenkins
Branch: master

commit 6ca63a77e228a32b6e4763ec3d6b198a14769bb8
Author: Wu Wenxiang <wu.wenxiang@99cloud.net>
Date: Sun Jun 9 17:24:27 2013 +0800

    Remove a stat warning log

    If using load balancer before keystone and the port numbers was
    different between load balancer and keystone, too many stat warning logs
    could be found in logs. The root cause is the keystone servers' stat
    logic getting the request host information which point to load balancer
    ip address and port rather than the ips and ports of themselves.

    Fixes bug #1189118
    Change-Id: Ic837af77bc2509086c0e37194ba70b683f693ae5

Changed in keystone:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-07-17
Changed in keystone:
milestone: none → havana-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in keystone:
milestone: havana-2 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions