python-webob dependency should bot be ==, instead it should be >=

Bug #1180033 reported by Haneef Ali on 2013-05-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Identity (keystone)
Low
sai krishna

Bug Description

keystone declares python-webob dependency as ==, which is not a good way of defining dependency. Please use >= and <= . Otherwise the document should explictly say why it requires particular version

# keystone dependencies
pam>=0.1.4
WebOb==1.2.3
eventlet
greenlet
PasteDeploy
paste
routes
sqlalchemy>=0.7.8,<=0.7.9
sqlalchemy-migrate>=0.7.2
passlib
lxml
iso8601>=0.1.4
python-keystoneclient>=0.2.1,<0.3
oslo.config>=1.1.0

Changed in keystone:
assignee: nobody → sai krishna (krishna1256)
Dolph Mathews (dolph) wrote :

Unassigning as it doesn't look like there's a review in progress

Changed in keystone:
status: New → Confirmed
importance: Undecided → Low
assignee: sai krishna (krishna1256) → nobody
sai krishna (krishna1256) wrote :

Hi,

Sorry for the delay.

Dependencies are defined with == in all other components(Horizon) also.
 and the latest version of python WebOb is 1.2.3 . sine defining webOb>=1.2.3,<=1.2.4 would be meaning less.
So I guess either fix should be given as >= or it should be updated in document. am commiting the requirements.txt with WebOb>=1.2.3 .

I could see modifying WebOb>=1.2.3 in requirements.txt is a better option.

Please comment so that I can proceed with review process.

Changed in keystone:
assignee: nobody → sai krishna (krishna1256)

Hi,

Sorry for the delay.

Dependencies are defined with == in all other components(Horizon) also.
 and the latest version of python WebOb is 1.2.3 . sine defining
webOb>=1.2.3,<=1.2.4 would be meaning less.
So I guess either fix should be given as >= or it should be updated in
document. am commiting the requirements.txt with WebOb>=1.2.3 .

I could see modifying WebOb>=1.2.3 in requirements.txt is a better option.

Please comment so that I can proceed with review process.

I have also re-assigned the bug to me. I will work on this bug immediately.

Thanks& Regards,

Sai krishna.

On Fri, Jun 7, 2013 at 8:43 PM, Dolph Mathews <email address hidden>wrote:

> Unassigning as it doesn't look like there's a review in progress
>
> ** Changed in: keystone
> Status: New => Confirmed
>
> ** Changed in: keystone
> Importance: Undecided => Low
>
> ** Changed in: keystone
> Assignee: sai krishna (krishna1256) => (unassigned)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1180033
>
> Title:
> python-webob dependency should bot be ==, instead it should be >=
>
> Status in OpenStack Identity (Keystone):
> Confirmed
>
> Bug description:
> keystone declares python-webob dependency as ==, which is not a good
> way of defining dependency. Please use >= and <= . Otherwise the
> document should explictly say why it requires particular version
>
> # keystone dependencies
> pam>=0.1.4
> WebOb==1.2.3
> eventlet
> greenlet
> PasteDeploy
> paste
> routes
> sqlalchemy>=0.7.8,<=0.7.9
> sqlalchemy-migrate>=0.7.2
> passlib
> lxml
> iso8601>=0.1.4
> python-keystoneclient>=0.2.1,<0.3
> oslo.config>=1.1.0
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/keystone/+bug/1180033/+subscriptions
>

Dolph Mathews (dolph) wrote :

As long as we're compatible with openstack-wide requirements [1], we should support the latest dependencies we can. Requirements are generally pinned when upgrading causes issues for the project, however I'm not clear on the history of why these particular requirements are pinned as such. I'm happy to see them unpinned, if possible.

[1]: https://github.com/openstack/requirements/blob/master/tools/pip-requires

Fix proposed to branch: master
Review: https://review.openstack.org/32254

Changed in keystone:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/32254
Committed: http://github.com/openstack/keystone/commit/3a58207e6ab9d7c6c22e3dd75afb8f2cc76830b2
Submitter: Jenkins
Branch: master

commit 3a58207e6ab9d7c6c22e3dd75afb8f2cc76830b2
Author: saikrishna <email address hidden>
Date: Wed Jun 12 08:59:54 2013 +0530

    python WebOb dependency made unpinned.

    keystone declares python-webob dependency as ==,
    which is not a good way of defining dependency.
    So to support latest dependencies, WebOb is unpinned in
    requirements.txt

    Fixes: bug #1180033
    Change-Id: I73042cf88baf378c8564abb2394963866082977e

Changed in keystone:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-07-17
Changed in keystone:
milestone: none → havana-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in keystone:
milestone: havana-2 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers