update group if member user is deleted in LDAP

Bug #1175205 reported by Sahdev Zala on 2013-05-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Identity (keystone)
Medium
Sahdev Zala

Bug Description

Currently if a user is member of a specific LDAP group and later that user is deleted from the ldap server via keystone api, it doesn't remove the member reference from the group. It should.

If user is deleted outside keystone, i.e. directly from LDAP server, the group may still contain a dead member entry but in that case we are handling it by ignoring the entry and providing a warning about it.

Sahdev Zala (spzala) on 2013-05-01
Changed in keystone:
assignee: nobody → Sahdev Zala (spzala)
Dolph Mathews (dolph) on 2013-06-10
Changed in keystone:
importance: Undecided → Medium
status: New → Triaged
Sahdev Zala (spzala) wrote :

The problem is fixed under https://review.openstack.org/#/c/31974/.

I have tested it and it's working good, so closing the bug.

Thanks, Adam!

Changed in keystone:
status: Triaged → Fix Released
Sahdev Zala (spzala) on 2013-06-25
Changed in keystone:
status: Fix Released → Fix Committed
Thierry Carrez (ttx) on 2013-07-17
Changed in keystone:
milestone: none → havana-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in keystone:
milestone: havana-2 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers