man pages installed with keystone are outdated

Bug #1082050 reported by Anne Gentle on 2012-11-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Identity (keystone)
Medium
Unassigned
keystone (Ubuntu)
Low
Unassigned

Bug Description

keystone: spelling-error-in-manpage usr/share/man/man8/keystone-auth.8.gz arguement argument (also in usr/share/man/man8/keystone-control.8.gz and usr/share/man/man8/keystone.8.gz)
[08:40am] zigo: Also, many hyphen-used-as-minus-sign

Related branches

Joseph Heck (heckj) wrote :

Adam -

Couldn't figure out how to link this to the packaging of Keystone for ubuntu, so assigning to you in hopes you can help that out. Wasn't sure of the relevant project to link this to...

Changed in keystone:
assignee: nobody → Adam Gandelman (gandelman-a)
status: New → Triaged
importance: Undecided → Medium
Joseph Heck (heckj) wrote :

man page is generated in packaging - not part of the upstream keystone repo

Changed in keystone:
status: Triaged → Invalid
assignee: Adam Gandelman (gandelman-a) → nobody
Adam Gandelman (gandelman-a) wrote :

Thanks, Joseph. Looks like there are a bunch of stale and unneeded man pages leftover from the pre-redux days.

summary: - Spelling errors reported on IRC
+ man pages installed with keystone are outdated
Changed in keystone (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package keystone - 2013.1~g2-0ubuntu1

---------------
keystone (2013.1~g2-0ubuntu1) raring; urgency=low

  [ James Page ]
  * Re-enable gating of package build based on successful unit testing:
    - d/tests/test_overrides.conf: Fixup test configuration to use
      correct certificate locations.
    - d/p/fix-ubuntu-tests.patch: Skip tests for older versions of
      keystoneclient based on checkouts of upstream git repo.
    - d/rules: Re-enable package build failure on test failure.
  * d/control: Bump dependencies on python-keystoneclient to >= 1:0.2.
  * d/control: Update Vcs-Bzr location to point to correct branch.
  * d/control,d/po/*: Setup package templates for translation.
  * d/man/*: Corrected spellings in man pages.
  * d/keystone.upstart: Tweak 'stop on' to be triggered on all
    appropriate runlevel transitions, use start-stop-daemon to startup
    keystone daemon.

  [ Adam Gandelman ]
  * debian/keystone.manpages: Install sphinx-generated manpages instead
    of our own outdated and unneeded versions. (LP: #1082050)

  [ Chuck Short ]
  * New upstream release.
  * Remove incomplete/broken dbconfig-common scripts.
 -- Chuck Short <email address hidden> Fri, 11 Jan 2013 08:47:26 -0600

Changed in keystone (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers