Using lubuntu 18.04.1 LTS when I try to run keryx using python 3 I get the error: SyntaxError: Non-UTF-8 code starting with '\xb0'in file ./keryx on line 2 but no encoding declared.

Bug #1785073 reported by Syd on 2018-08-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Keryx
Undecided
Unassigned

Bug Description

ran from the terminal using "python 3 ./keryx" and the terminal window just displays the above error. Works perfect on the (online) windows pc I will be using to get the updates, but on the latest LTS Lubuntu just won't play ball. Would really like to be able to use the program.
Thank you

Syd (crowleybluegrass) wrote :

Apologies, forgot to attach picture the first time

Syd (crowleybluegrass) wrote :
Syd (crowleybluegrass) wrote :

Apologies again for the repeat posts, just wanted to be more specific:
I was using version "keryx_0.92.3.2.zip" when I received this error; I'll try using "Keryx_Ubuntu_x86.zip" when I get get home tonight and see if that works.

Chris Oliver (excid3) wrote :

Try using Python 2. I don't believe anyone ever ported this up to Python 3 yet.

Syd (crowleybluegrass) wrote :

I installed python 2 last night and, sadly, still not working :(
Python 2 is set up fine, but I get the same error. I tried the version listed as ubuntu also and got the same/similar error, just with a different \xb number, 6 or 7 IIRC (like a fool I forgot to uplaod the screenshot to my flashdrive...)

Hope someone can shed some light on what I'm doing wrong, or if this is a genuine (but it seems very under reported) error. Would really help me out if I could get this software to work, updating offline machines can be a difficult and time consuming process.

Thank you.

mac9416 (mac9416) wrote :

Thanks for giving that a try, Syd. I'll do some debugging tonight and let you know what I come up with. Haven't been able to work on it much lately (just got married), but you seem pretty darn motivated, so I'll dig in and see if we can fix the bug. :-)

Syd (crowleybluegrass) wrote :

Congratulations! :)

Thank you for getting back to me so quickly Mac and Chris, it is very much appreciated. Again, I hope it's not somehow an error on my part, but it seems everything else (dependencies etc.) is working okay.

Good luck with the debugging, look forward to hearing what you come up with.

Regards

Syd (crowleybluegrass) wrote :

Just uploading the pictures I forgot the other day in the hope it might shed some light/make your job easier in some way. Thanks again.

mac9416 (mac9416) wrote :

Thanks!

So I can't believe I missed this before... you can run './keryx' without the 'python[3]'. It's a compiled binary which should be able to run completely independently of Python. The error is just Python saying "This is not the kind of file I know how to execute."

I just started up Keryx in 18.04.1 and to my shock it runs. Let me know if anything goes wrong.

mac9416 (mac9416) wrote :

Oh, running ./keryx will only work if you're using the 0.92.5 tar.gz or zip. I'm not sure about the Ubuntu zip.

Syd (crowleybluegrass) wrote :

Now that you've had it working just fine on the same version of Lubuntu it makes me feel like I'm being a pain at this point. Apologies for taking up any more of your time, but although keryx now runs.. I can't read anything.

I've attached screenshots of everything that seems to be mentioned/could be related: the bitmap configuration files, the fonts folder... not sure what to do. I tried creating the pango folder using the command it mentions, but it doesn't seem to make any difference.

I tried booting keryx up on my windows partition and taking note of what the buttons related to and just working through that way for now, but I get a (sadly unreadable) error message when I try to make a new project in Lubuntu.

Thank you for your time, it is much appreciated.

Syd (crowleybluegrass) wrote :
Syd (crowleybluegrass) wrote :
Searock (searock) wrote :

@Syd @mac9416 If you both agree, Syd can you share your screen with mac9416? May be with team viewer or Skype or vnc. I am saying this because it might be little difficult for mac9416 to replicate the error because both of you have different environments even if you are using same version of linux. I am not an expert but I thought it might help. May be this may not be possible because you both are in different timezones.

mac9416 (mac9416) wrote :

No bother, Syd! That's what the bug page is for. :-)

That's a darn weird issue with the fonts... I should have time this weekend to try to reproduce it.

I missed at first that you were using Lubuntu, not Ubuntu. I'll try with that soon.

Should be no need for a screen share. The screenshots are very informative.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers