Unbundle qtsingleapplication

Bug #1243955 reported by Johu-h on 2013-10-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inactive kdocker (moved to https://github.com/user-none/KDocker)
Won't Fix
Undecided
Unassigned

Bug Description

Bundle libs have high risk for security issues. Its better to use a external version. See attached patch which unbundles qtsingleapplication.

See downstream bug for reference:
https://bugs.gentoo.org/show_bug.cgi?id=489146

Johu-h (johu-h) wrote :
Changed in kdocker:
status: New → Won't Fix
John Schember (user-none) wrote :

Qt Solutions are not packaged by the vast majority of distros. It doesn't make sense to require a dependency that isn't available by must consumers of KDocker.

Johu-h (johu-h) wrote :

Depending on external lib would make distros, packaging it. For example it is already in Gentoo available.

Johu-h (johu-h) wrote :

Here is another patch which lets packager control wether internal qtsingleapplication is used or system one. This should work for distributions which are not able to package qtsingleapplication.

John Schember (user-none) wrote :

I'm fine with defaulting to the system install if present. Patch merged in revision 112.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers