Can not login to Windows Live Messenger

Bug #887104 reported by Jente on 2011-11-07
154
This bug affects 28 people
Affects Status Importance Assigned to Milestone
KDE Network
Won't Fix
Medium
Kopete
Won't Fix
Medium
kdenetwork (Ubuntu)
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned
Natty
Undecided
Unassigned
Precise
Undecided
Unassigned
libmsn (Ubuntu)
Undecided
Pau Garcia Quiles
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Pau Garcia Quiles

Bug Description

Since a week or some ago, I can not log in into Windows Live Messenger using Kopete anymore. It keeps saying it is connecting but never does. I tried running Kopete from terminal and it gave me the following error:

[jente@lappy ~]$ kopete(10432)/libkopete Kopete::AccountManager::registerAccount: No identity for account "<censor>@hotmail.com" : falling back to default

I have already tried to delete Kopete's config in ~/.kde/share/config/kopeterc and start fresh, but this didn't work sadly. Neither did purging it and reinstalling. Also, a downgrade from 1.1.2 (from Oneiric) to 1.0.80 (Natty) didn't help. When I then run Kopete from terminal, I get this:

┌─[jente@lappy Downloads][13:59:49]
└─■ kopete(4705)/libkopete Kopete::PluginManager::loadPluginInternal: Unable to find a plugin named ' "" '!

If you need more information, please ask.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kdenetwork (Ubuntu):
status: New → Confirmed
Jari Laamanen (yartsa) wrote :

I can confirm that a diff of the top revision from https://libmsn.svn.sourceforge.net/svnroot/libmsn/trunk/ (as listed in the upstream bug) applies cleanly to the libmsn package from Natty. Rebuilding and installing the patched package solves the issue.

Jari Laamanen (yartsa) wrote :

The updates can be applied also to oneiric, and an updated package can be built as follows:

mkdir tmpmsn
cd tmpmsn/
apt-get source libmsn
sudo apt-get build-dep libmsn
wget http://libmsn.svn.sourceforge.net/viewvc/libmsn/trunk/msn/soap.cpp?revision=121
wget http://libmsn.svn.sourceforge.net/viewvc/libmsn/trunk/msn/soap.h?revision=121
mv soap.cpp\?revision\=121 libmsn-4.1/msn/soap.cpp
mv soap.h\?revision\=121 libmsn-4.1/msn/soap.h
cd libmsn-4.1/
dpkg-buildpackage
cd ..
sudo dpkg -i libmsn0.3_4.1-2ubuntu1_i386.deb

Start kopete and it connects.

Next upgrade will overwrite it, so one can hold the package
sudo aptitude hold libmsn0.3

Holding can be avoided if the version number was changed in libmsn-4.1/debian/changelog (like I actually did).

Jari Laamanen (yartsa) wrote :

The new libmsn 4.2 has this fixed according to the upstream report.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libmsn (Ubuntu):
status: New → Confirmed
Jente (jente-etnej) wrote :

Jari, doing what you said still doesn't work for me on Kubuntu 11.10. What's happening here?

Jari Laamanen (yartsa) wrote :

jente, I have also Kubuntu 11.10 and kde 4.7.3. However, unlike you, my WLM with Kopete still worked two days ago. Maybe your account is at different server and behind another redirection? In that case the bug is not fixed. This bug should be assigned to someone, who is packagin the ubuntu packages for libmsn. I don't know who does that. Compiling libmsn with the redirction patches (the updated soap files in above recipe) fixed the eternal "connecting" for me. Kopete started working right after installing the compiled library.

I have Kubuntu 11.04, Kopete 1.0.80, KDE 4.6.5.
The problem (Kopete doesn't connect to MSN/WLM) affects me since today.
Jaris suggestion doesn't work for me (already the first command returns an error)

Eric Lacombe (goretux) wrote :

I've got the same problem under kubuntu 11.10 and kde 4.7.3.
And the fully detailed solution from Jari works like a charm ;)

Jari Laamanen (yartsa) on 2011-11-09
tags: added: kopete wlm
getaceres (getaceres) wrote :

I've tried fix from Jari in KDE 4.7.3 and it worked. Thanks. I hope it gets to the official packages.

Pau Garcia Quiles (pgquiles) wrote :

libmsn 4.2 is now packaged and will be uploaded to the Debian archive soon:

http://mentors.debian.net/debian/pool/main/libm/libmsn/libmsn_4.2-1.dsc

I've asked for it to be included in oneiric-updates

Changed in libmsn (Ubuntu):
assignee: nobody → Pau Garcia i Quiles (pgquiles)
status: Confirmed → In Progress
Daniel Holbach (dholbach) wrote :

Pau: do you know if anything needs to be changed in kdenetwork or kopete to fix this?

no longer affects: kdenetwork (Ubuntu Oneiric)
Daniel Holbach (dholbach) wrote :

I looked at the version at mentors.d.n and it looks good to me. Are there any more changes planned to this one? I think it'd be better to sync it when it hits unstable?

Thanks a lot everybody to the work you put into this!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libmsn (Ubuntu Oneiric):
status: New → Confirmed
Pau Garcia Quiles (pgquiles) wrote :

Daniel,

No changes required in kdenetwork or kopete, libmsn 4.2 is binary compatible with 4.1.

I'm not expecting any more changes in libmsn. There might be changes in kopete, though, because of this:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648172

I have not looked into that one yet.

Andrew Kohlsmith (akohlsmith) wrote :

Just a note to Yari's comment (https://bugs.launchpad.net/ubuntu/+source/libmsn/+bug/887104/comments/4)

mv newfile msn/oldfile isn't guaranteed to overwrite. I've noticed this on a few of my ubuntu systems. Perhaps some stupid shell option that is enabled.

If you blow away the msn/soap* and then move them to msn, it works fine.

Thank you for the tip.

Toni Helenius (toni-helenius) wrote :

I think this should be patched to every version of Kubuntu still supported! At least the 10.04 LTS (my sister and mom called, so this is confirmed for 10.04) :) And 11.10 for me!

Daniel Holbach (dholbach) wrote :

Pau: is the issue in kopete the same as this one? I'm just wondering how many tasks of this particular Launchpad bug should actually be open or closed. The only action I see so far is syncing libmsn, right?

Pau Garcia Quiles (pgquiles) wrote :

Daniel,

Yes, the "kopete cannot login to WLM" is the libmsn issue. The only action needed is updating to libmsn 4.2.

The "kopete cannot open the WLM inbox" seems to be a different one and I have not looked further into it yet.

Jente (jente-etnej) wrote :

A user on the Ubuntu forums packed the libmsn 4.2 in a .deb and I installed that; still no luck on getting Kopete to connect.
When I made the .deb myself, according to jari's instructions, it doesn't work either.

Kmess does work, however - so it's not my account that's wrong.

Jente (jente-etnej) wrote :

Oops, I spoke too soon. Removing my user account and re-adding it (basically removing all Kopete's config files) did it! I can now log in using Kopete again!

Maurício Severich (mseverich) wrote :

I noticed there was an update for the package "libmsn0.3" available on the official repository, however I believe there was some mistake because the package is dated May 31 and does not solve the problem.
So, I'm still using a "homemade libmsn0.3 package for amd64" with the corrections from the original tarball (http://sf.net/projects/libmsn/files/libmsn/4.2)
p.s.: I apologize for my broken English

Joshua Kugler (jkugler) wrote :

Please also add "natty" as a version that needs to be updated.

Joshua Kugler (jkugler) wrote :

For the record, the solution in comment #4 worked for me.

Jonathan Riddell (jr) on 2011-11-10
Changed in kdenetwork (Ubuntu):
status: Confirmed → Invalid
Changed in kdenetwork (Ubuntu Natty):
status: New → Invalid
Changed in kdenetwork (Ubuntu Maverick):
status: New → Invalid
Changed in kdenetwork (Ubuntu Lucid):
status: New → Invalid
Jonathan Riddell (jr) wrote :
Changed in libmsn (Ubuntu Precise):
status: In Progress → Fix Released
Pau Garcia Quiles (pgquiles) wrote :

Jonathan,

That patch, and the OpenSSL one, convert libmsn 4.1-2ubuntu1 in libmsn 4.2-1. I'd say updating libmsn to 4.2 would be less confusing.

Jonathan Riddell (jr) wrote :
Jonathan Riddell (jr) wrote :

The 4.2 tar contains a lot of developer documentation updates. Ubuntu policy is for stable release updates to have minimal changes for clarity and to prevent adding new issues.

Jonathan Riddell (jr) wrote :
Jonathan Riddell (jr) wrote :
Jonathan Riddell (jr) wrote :

TEST CASE: launch Kopete, connect to an MSN account. Without this update it won't connect, with this update it will.

Jonathan Riddell (jr) wrote :

Packages uploaded to lucid, maverick, natty, oneiric. Awaiting approval by ubuntu-sru

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libmsn (Ubuntu Lucid):
status: New → Confirmed
Changed in libmsn (Ubuntu Maverick):
status: New → Confirmed
Changed in libmsn (Ubuntu Natty):
status: New → Confirmed
Michael Rydén (zynex) wrote :

For Ubuntu Oneiric Ocelot, download v4.2-1 for Precise Pangolin and install it. Works like a charm, and MSN can connect without any problems. You will find the binary download here; https://launchpad.net/ubuntu/+source/libmsn

Use libmsn0.3_4.2-1_amd64.deb or libmsn0.3_4.2-1_i386.deb depending on your architecture.

Hello Jente, or anyone else affected,

Accepted libmsn into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in libmsn (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Hello Jente, or anyone else affected,

Accepted libmsn into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in libmsn (Ubuntu Lucid):
status: Confirmed → Fix Committed
Chris Halse Rogers (raof) wrote :

Hello Jente, or anyone else affected,

Accepted libmsn into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in libmsn (Ubuntu Natty):
status: Confirmed → Fix Committed
Joshua Kugler (jkugler) wrote :

Running Natty. Installed and restarted Kopete. Works for me!

Jonathan Riddell (jr) wrote :

libmsn 4.1-1.2ubuntu1.1 still in maverick-proposed unapproved queue awaiting approval from ubuntu-sru

Martin Pitt (pitti) wrote :

Skipping the usual 7 day waiting period here, as this is rather grave.

tags: added: verification-done-natty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libmsn - 4.1-1.2ubuntu1.2

---------------
libmsn (4.1-1.2ubuntu1.2) natty-proposed; urgency=low

  * Add kubuntu_01_msn_update.diff from upstream to fix connection to MSN
    LP: #887104
 -- Jonathan Riddell <email address hidden> Thu, 10 Nov 2011 22:12:22 +0000

Changed in libmsn (Ubuntu Natty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Hello Jente, or anyone else affected,

Accepted libmsn into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in libmsn (Ubuntu Maverick):
status: Confirmed → Fix Committed
Felix Geyer (debfx) on 2011-11-15
no longer affects: kdenetwork (Ubuntu)
Charles (charles-bl) wrote :

Oneiric, fix works perfectly. Thanks and grats

Kr0m@gn0n (mlamases) wrote :

Fix works in Lucid. Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libmsn - 4.1-0ubuntu1.1

---------------
libmsn (4.1-0ubuntu1.1) lucid-proposed; urgency=low

  * Add kubuntu_01_msn_update.diff from upstream to fix connection to MSN
    LP: #887104
 -- Jonathan Riddell <email address hidden> Thu, 10 Nov 2011 22:12:22 +0000

Changed in libmsn (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libmsn - 4.1-2ubuntu1.1

---------------
libmsn (4.1-2ubuntu1.1) oneiric-proposed; urgency=low

  * Add kubuntu_01_msn_update.diff from upstream to fix connection to MSN
    LP: #887104
 -- Jonathan Riddell <email address hidden> Thu, 10 Nov 2011 22:12:22 +0000

Changed in libmsn (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

That leaves maverick for testing. Thanks!

apt-cache show libmsn0.3
always returns
4.1-1.2ubuntu1
shouldn't it be
4.1-1.2ubuntu1.2
now?
(I suppose yes, since it still doesn't work for me... but I don't know why I don't get the update and why the 'old' version is still present even after I manually reinstalled the packet and even after I manually bulilt and installed it from the source after applying the .diff... what am I doing wrong?)

Ok. I found the .deb which allowed me to get to '4.1-1.2ubuntu1.2'.
But it still won't connect. Same as before.
I'm running natty / Kopete.

After various further attempts I still couldn't get the problem sloved.
According to "apt-cache show libmsn0.3" I have the new version (4.1-1.2ubuntu1.2) but the issue still exists.

Changed in kdenetwork:
importance: Unknown → Medium
status: Unknown → Won't Fix
Changed in kopete:
importance: Unknown → Medium
status: Unknown → Won't Fix
Adolfo Jayme (fitojb) on 2013-06-22
Changed in libmsn (Ubuntu Maverick):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.