update-notifier-kde.py crashed with SIGSEGV in QSocketNotifier::setEnabled()

Bug #334757 reported by Łukasz Kuryło on 2009-02-26
560
This bug affects 53 people
Affects Status Importance Assigned to Milestone
KDE Bindings
Confirmed
High
python-qt4 (Ubuntu)
High
Scott Kitterman
Precise
High
Scott Kitterman

Bug Description

Binary package hint: update-notifier-kde

Crashed when disabled WIFI and BT using laptop button. kbluetooth4 crashed in the same time.

ProblemType: Crash
Architecture: amd64
CrashCounter: 1
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/share/python-support/update-notifier-kde/update-notifier-kde.py
InterpreterPath: /usr/bin/python2.5
Package: update-notifier-kde 0.14
PackageArchitecture: all
ProcCmdline: python /usr/bin/update-notifier-kde
ProcEnviron:
 LANGUAGE=pl_PL:pl:en_GB:en
 PATH=(custom, user)
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: update-notifier-kde
StacktraceTop:
 QSocketNotifier::setEnabled ()
 ?? ()
 ?? ()
 QMetaObject::activate ()
 QSocketNotifier::activated ()
Title: update-notifier-kde.py crashed with SIGSEGV in QSocketNotifier::setEnabled()
Uname: Linux 2.6.28-8-generic x86_64
UserGroups: adm admin cdrom dialout lp lpadmin plugdev sambashare

Łukasz Kuryło (lukasz-kurylo) wrote :

StacktraceTop:QSocketNotifier::setEnabled ()
?? ()
?? ()
QMetaObject::activate ()
QSocketNotifier::activated ()

Changed in update-notifier-kde:
importance: Undecided → Medium
Jonathan Thomas (echidnaman) wrote :

Looks like a python-qt4-dbus bug.

Changed in python-qt4 (Ubuntu):
status: New → Confirmed

Am Mittwoch 25 März 2009 18:06:36 schrieb Jonathan Thomas:
> Looks like a python-qt4-dbus bug.
>
> ** Changed in: python-qt4 (Ubuntu)
> Status: New => Confirmed
>
> ** Changed in: python-qt4 (Ubuntu)
> Sourcepackagename: update-notifier-kde => python-qt4
Thanks, for the answere,, there were some blocked updates for my
system. I think they are needed to fix some problems, i've installed
them and hope it is fixed now.

regards dennis

Alan Weeks (aweeks1) wrote :

Ubuntu v9.04 upgraded from 8.04

This fault occurred during the night when PC was unattended.

Changed in kdebindings:
status: Unknown → Confirmed
Changed in kdebindings:
importance: Unknown → High
Alejandro J. Cura (alecu) wrote :

This seems to be a bug with the DBus PyQt mainloop.

I'm attaching a python script that reproduces this bug.
On my Precise Beta 2, amd64, it segfaults like above 4 out of 10 runs.

Alejandro J. Cura (alecu) wrote :
Scott Kitterman (kitterman) wrote :

Fixed upstream. I have a patch from upstream and will upload the proposed fix shortly.

Scott Kitterman (kitterman) wrote :

I think this is RC for Ubuntu now due to it's impact on UbuntuOne. I'll upload to precise-proposed and then the release team can let it in for release if they want to.

Changed in python-qt4 (Ubuntu):
importance: Medium → High
status: Confirmed → In Progress
assignee: nobody → Scott Kitterman (kitterman)
Changed in python-qt4 (Ubuntu Precise):
milestone: none → ubuntu-12.04
Scott Kitterman (kitterman) wrote :

Uploaded to precise-proposed for release team review.

Changed in python-qt4 (Ubuntu Precise):
status: In Progress → Fix Committed
Alejandro J. Cura (alecu) wrote :

I've installed the package from -proposed, and my script to reproduce the bug is not segfaulting anymore.
Thanks Scott for working on this!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-qt4 - 4.9.1-2ubuntu1

---------------
python-qt4 (4.9.1-2ubuntu1) precise-proposed; urgency=low

  * Fix dbus related PyQt application crashes (LP: #334757)
    - Add debian/patches/dbus.patch from upstream
 -- Scott Kitterman <email address hidden> Sat, 14 Apr 2012 16:12:34 -0400

Changed in python-qt4 (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.