libqt4-dbg causing kde 4.4 install to fail for amd64 packages

Bug #523779 reported by JW on 2010-02-18
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KDE 4 Backports
Undecided
Unassigned

Bug Description

System Summary:
Kubuntu 9.10 amd64
KDE PPA enabled (for 4.4.0)
Linux 2.6.31-19-generic #56-Ubuntu SMP Thu Jan 28 02:39:34 UTC 2010 x86_64 GNU/Linux

Issue 'Summary':
I added the kubuntu ppa to my sources.lst and proceeded to perform an update from the CLI. Of course, there were many packages held back, so I then did an install for all of those packages. The process then got hung up on libqt4-dbg.

=== === ===
Errors were encountered while processing:
 /var/cache/apt/archives/libqt4-dbg_4%3a4.6.1-1ubuntu2~karmic1~ppa2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
=== === ===

I ran "sudo apt-get upgrade" again and received the following set of issues:

=== === ===
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  kaddressbook: Depends: kdepimlibs5 (>= 4:4.4.0) but 4:4.3.5-0ubuntu1~karmic1 is installed
                Depends: libkdepim4 (= 4:4.4.0-0ubuntu1~karmic1~ppa2) but 4:4.3.5-0ubuntu1~karmic1 is installed
  kdebase-runtime: Depends: libssh-4 (>= 0.3.91) but it is not installed
                   Depends: oxygen-icon-theme (>= 4:4.2.90) but it is not installed
                   Recommends: icoutils but it is not installed
                   Recommends: virtuosoconverter but it is not installed
  kdepim-groupware: Depends: kdepimlibs5 (>= 4:4.4.0) but 4:4.3.5-0ubuntu1~karmic1 is installed
                    Depends: libkdepim4 (= 4:4.4.0-0ubuntu1~karmic1~ppa2) but 4:4.3.5-0ubuntu1~karmic1 is installed
  kdepim-kresources: Depends: kdepimlibs5 (>= 4:4.4.0) but 4:4.3.5-0ubuntu1~karmic1 is installed
                     Depends: libkdepim4 (= 4:4.4.0-0ubuntu1~karmic1~ppa2) but 4:4.3.5-0ubuntu1~karmic1 is installed
  kdepim-wizards: Depends: kdepimlibs5 (>= 4:4.4.0) but 4:4.3.5-0ubuntu1~karmic1 is installed
                  Depends: libkdepim4 (= 4:4.4.0-0ubuntu1~karmic1~ppa2) but 4:4.3.5-0ubuntu1~karmic1 is installed
  kmail: Depends: kdepimlibs5 (>= 4:4.4.0) but 4:4.3.5-0ubuntu1~karmic1 is installed
         Depends: libkdepim4 (= 4:4.4.0-0ubuntu1~karmic1~ppa2) but 4:4.3.5-0ubuntu1~karmic1 is installed
  libkleo4: Depends: kdepimlibs5 (>= 4:4.4.0) but 4:4.3.5-0ubuntu1~karmic1 is installed
  libqt4-dbg: Depends: libqtcore4 (= 4.5.3really4.5.2-0ubuntu1) but 4:4.6.1-1ubuntu2~karmic1~ppa2 is installed
E: Unmet dependencies. Try using -f.
=== === ===

I then tried exactly that: sudo apt-get -f install and received the following output (sharing all):

=== === ===
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  xlibmesa-gl-dev libqt4-phonon-dev libglu1-xorg-dev libssl-dev libpq-dev libsqlite0-dev libxmlrpc-core-c3
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  akregator kalarm kdepimlibs-data kdepimlibs-dbg kdepimlibs5 knotes kontact korganizer ktimetracker libkdepim4 libqt4-dbg libssh-4 oxygen-icon-theme
Suggested packages:
  kttsd gnokii kjots knode
The following packages will be REMOVED:
  libkabcommon4 libkontactinterfaces4
The following NEW packages will be installed:
  libssh-4 oxygen-icon-theme
The following packages will be upgraded:
  akregator kalarm kdepimlibs-data kdepimlibs-dbg kdepimlibs5 knotes kontact korganizer ktimetracker libkdepim4 libqt4-dbg
11 upgraded, 2 newly installed, 2 to remove and 140 not upgraded.
59 not fully installed or removed.
Need to get 0B/122MB of archives.
After this operation, 201MB of additional disk space will be used.
Do you want to continue [Y/n]?
(Reading database ... 235289 files and directories currently installed.)
Preparing to replace libqt4-dbg 4.5.3really4.5.2-0ubuntu1 (using .../libqt4-dbg_4%3a4.6.1-1ubuntu2~karmic1~ppa2_amd64.deb) ...
Unpacking replacement libqt4-dbg ...
dpkg: error processing /var/cache/apt/archives/libqt4-dbg_4%3a4.6.1-1ubuntu2~karmic1~ppa2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/debug/usr/bin/qvfb', which is also in package qt-x11-free-dbg 3:3.3.8-b-5ubuntu3
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Selecting previously deselected package libssh-4.
Unpacking libssh-4 (from .../libssh-4_0.4.0-1ubuntu1~karmic1~ppa1_amd64.deb) ...
Selecting previously deselected package oxygen-icon-theme.
Unpacking oxygen-icon-theme (from .../oxygen-icon-theme_4%3a4.4.0-0ubuntu1~karmic1~ppa_all.deb) ...
Replacing files in old package kde-icons-oxygen ...
Preparing to replace kdepimlibs-dbg 4:4.3.5-0ubuntu1~karmic1 (using .../kdepimlibs-dbg_4%3a4.4.0-0ubuntu1~karmic1~ppa1_amd64.deb) ...
Unpacking replacement kdepimlibs-dbg ...
Errors were encountered while processing:
 /var/cache/apt/archives/libqt4-dbg_4%3a4.6.1-1ubuntu2~karmic1~ppa2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
=== === ===

I tried running "sudo apt-get remove libqt4-dbg" and that did not work. I ran "sudo dpkg -r libqt4-dbg" and that successfully removed the package but upon running "sudo apt-get upgrade" again, it gave me the same original error.

What kung-fu trick am I missing here to get this to install?

JW (arch0njw) wrote :

I think I filed this wrong originally. I have now selected kde4-backports which I believe is the correct project.

affects: launchpad → kde4-backports
summary: - libqt4-dbg causing kde 4.4 install to fail
+ libqt4-dbg causing kde 4.4 install to fail for amd64 packages
JW (arch0njw) wrote :

I think I managed to fix this.

First, I uninstalled all *-dbg packages.

$ dpkg -l | grep dbg | grep ii
$ sudo dpkg -r graphicsmagick-dbg kdebase-dbg kdebase-workspace-dbg kdegraphics-dbg kdelibs-dbg kdenetwork-dbg kdepim-dbg kdeplasma-addons-dbg libc6-dbg libcurl3-dbg qt-x11-free-dbg libqt4-dbg

Then I ran "sudo apt-get upgrade" (aliased to "upgrade") and continued uninstalling debug packages until it worked.

  700 upgrade
  701 sudo dpkg -r kdelibs5-dbg kdepimlibs-dbg
  702 upgrade
  703 sudo dpkg -r kdebase-runtime-dbg
  704 upgrade
  705 sudo dpkg -r kscreensaver-xsavers

I also had to uninstall kscreensaver-xsavers, but could install it again after the upgrade was complete.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers