0.7.x does not work with apps under KDE 4.x

Bug #357469 reported by Michael B. Trausch on 2009-04-08
10
Affects Status Importance Assigned to Milestone
AllTray
Medium
Unassigned
KDE Base
Confirmed
Medium

Bug Description

Found in: AllTray trunk (0.7.2dev+ from lp:alltray r39)

It would appear that KDE applications don't do some of the things that apps from other environments do, and AllTray doesn't work with them as a result. This doesn't appear to be a bug with AllTray itself; AllTray works with xterm and non-GNOME applications, as well as GNOME applications. AllTray does not catch or dock KDE applications when they are running under GNOME, either. It is possible that this is related to bug 357468, however, this is currently unknown.

For applications that AllTray *does* work with under KDE 4 (e.g., xterm, firefox, evince), the windows are not hidden from the task-switcher (engaged by pressing ALT+TAB) despite the window being removed from the view of the taskbar.

Investigation needs to occur to figure out what causes this and if there is a decent way to work around this for KDE, with potentially a bug report being put into KDE as a result. This will require someone with some expertise with KDE applications and the KDE desktop environment itself.

Changed in alltray:
importance: Undecided → Medium
status: New → Confirmed
Michael B. Trausch (mtrausch) wrote :

Have opened a bug with KDE to request a longer-term fix (at least for the latter part of this bug) than a workaround. Still need to find a way to work around this issue in the short-term, though. Hopefully the former half of the bug (that KDE apps behave strangely by detaching from the terminal and being hard to “capture”) can be resolved the fix for bug 356516.

Changed in kdebase:
status: Unknown → New
Michael B. Trausch (mtrausch) wrote :

As it turns out this is a known regression in KDE; this is KDE 179723:

  http://bugs.kde.org/show_bug.cgi?id=179723

I don't know if LP will automatically start watching that bug since the one linked from here already has been marked a duplicate of that one. If it isn't updated next time LP updates the external bug status, I'll add it manually.

Michael B. Trausch (mtrausch) wrote :

To clarify; the KDE window switcher bug is a regression. KDE applications are a different story; I am still working on determining a fix for those.

Changed in kdebase:
status: New → Invalid
Michael B. Trausch (mtrausch) wrote :

Switch bug watch to the real upstream bug.

Changed in kdebase:
status: Invalid → Unknown
Changed in kdebase:
status: Unknown → Confirmed
summary: - 0.7.x does not work with KDE 3.x & 4.x apps
+ 0.7.x does not work with apps under KDE 4.x
Michael B. Trausch (mtrausch) wrote :

Marking this bug as invalid, as it is not actually a bug in AllTray. When the KDE project feels that it is important enough to fix this bug, they will; I've not the time to try to come up with a patch for KDE at the moment.

Changed in alltray:
status: Confirmed → Invalid
Michael B. Trausch (mtrausch) wrote :

After getting bug 301636 closed, I thought I'd check to see if that happened to fix it for KDE, as well. It appears to; 0.7.3dev+ (current trunk in lp:alltray) now works properly on KDE 4 in Jaunty; that fix will be available in 0.7.4dev, which looks to be sooner than I thought it might be. :-)

Changed in alltray:
status: Invalid → Fix Committed
Michael B. Trausch (mtrausch) wrote :

Fix was released as of AllTray 0.7.4dev.

Changed in alltray:
status: Fix Committed → Fix Released
hasi (whynot-nurfuerspam) wrote :

The fix does not apply for the KDE window switcher problem, which appears to be a KDE4 problem, correct? I am still seeing this problem in karmic 32bit/alltray 0.74dev. I also added a small comment to the KDE bug in order get more attention to this problem.

Michael B. Trausch (mtrausch) wrote :

@hasi: Can you tell me what stack you're using? Is this on Ubuntu or something else? I can try to replicate the issue and see if there's a way to work around it or not; I did have it working with KDE 4.3 on Jaunty.

Changed in kdebase:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.