Dolphin & Konqueror do not support browsing workgroups with spaces in their name

Bug #340106 reported by Vladimir Hidalgo on 2009-03-09
Affects Status Importance Assigned to Milestone
KDE Base
kdebase-runtime (Ubuntu)

Bug Description

Binary package hint: dolphin

Dolphin & Konqueror do not support workgroups or domains with spaces in their name.

I think this is a bug (as Windows can manage them), even if it's a bad practice to put spaces in workgroups names.

Sometimes you can't choose to change the workgroup name, as in my case, because someone in my job decided it long time before, and no one is willing to change every machine's Workgroup just for my Ubuntu Box :P

Vladimir Hidalgo (vlad88sv) wrote :
Vladimir Hidalgo (vlad88sv) wrote :

I forgot to metion I'm using Kubuntu 8.10 with KDE 4.2

description: updated
affects: kdebase-kde4 (Ubuntu) → kdebase (Ubuntu)

Version: 4.3.0 (using KDE 4.3.0)
Compiler: deb jaunty main KDE 4.3.0 downloaded from that PPA.
OS: Linux
Installed from: Ubuntu Packages

I'm in a office network of wich network's domain name was selected long time ago and it included spaces in it. Ej. "Office C.V.".

Problem arises when you try to navigate the network using "smb://Office C.V." but you can actually see the Network if you just type "smb://".

It seems that Konqueror (and Dolphin too) are unable to process the space in the Domain name and fails to open it.

I've had problems mounting shares with spaces in fstab, but that can be worked around by using "\040" instead of the spaces.

I've tried everything in Konqueror/Dolphin to access this network, some attempts are:

* smb://Office\040C.V.
 Konqueror complains about wrong URL format
 Dolphin says it's an invalid URL

* smb://Office+C.V.
 Konqueror & Dolphin says that "server can't be contacted".

This is a big bug for me, as I have to do "smbtree" to find the individuals PC on the network and use "smb://<name>" to skip the domain issue.

But when it comes to someone having spaces in his network's name... well, there I have to use fstab and the \040 trick.

That is impractical to do, it's as impractical as telling everyone to change the domain name just because me.

Well, system crashed and I decided to try Ubuntu, Nautilus does not suffer from this bug and so I don't think I'm going back to KDE while having this inconvenience.

I think I'll not be able to test this anymore.

Jonathan Thomas (echidnaman) wrote :

Thanks for the upstream report.

affects: kdebase (Ubuntu) → kdebase-runtime (Ubuntu)
Changed in kdebase-runtime (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in kdebase:
status: Unknown → New
Changed in kdebase:
importance: Unknown → Medium

*** Bug 246471 has been marked as a duplicate of this bug. ***

*** Bug 195012 has been marked as a duplicate of this bug. ***

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.