Screen Resolution is not being restored after relogin

Bug #268434 reported by Marc Schiffbauer on 2008-09-10
226
This bug affects 21 people
Affects Status Importance Assigned to Milestone
KDE Base
Fix Released
Medium
Nominated for Trunk by Nicolas Moitrier
kdebase-workspace (Ubuntu)
Low
Unassigned
Declined for Karmic by Jonathan Thomas
Declined for Lucid by Jonathan Thomas

Bug Description

K-Menu -> System settings -> Display -> Size & Orientation

You can set a screen resolution here which works fine, but on re-login to KDE the set resolution is not being restored.

Then if you start the Config again it will load the settings immediately on config dialog show-up. But then the panel for example still has the original size.

This way the this settings dialog/applet is completely useless.

Version: (using Devel)
Installed from: Compiled sources
OS: Linux

First, i'm using kde4daily on VirtualBox, updated today

Steps to reproduce:
Open SystemSettings, Screen, change resolution to 640x480 (or any except default), apply it.
Logout (you get the default resolution back).
Login again (the display stays at the default resolution).

Expected behavior: Display changes to the set resolution (640x480).

Note that as you open SystemSettings->Screen after logging back in, the display is set to the needed resolution (640x480).

I have the same problem.
It was marked as resolved in bug 157139.
(kde4.1 beta2 in kubuntu)

Jonathan Thomas (echidnaman) wrote :

What version of KDE are you using?

Changed in kdebase-workspace:
importance: Undecided → Low
status: New → Incomplete
Jonathan Thomas (echidnaman) wrote :

Reported as happening in KDE 4.1.1 in a duplicate report.

Changed in kdebase-workspace:
status: Incomplete → Confirmed
kalyan (kallu-be) wrote :

Yes its happening since 4.1 is released.

Sven Heinicke (svenmh) wrote :

Yesterday, after running krandrtray to reset the resolution it was at least leaving the little desk top menu on the left side (that one that looks like a foot and has the "Add Widgets" & "Lock Widgets" menu). Now, after this mornings updates it leaves the foot in the middle of the screen, looking ugly and buggy.

sven@ibex:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu intrepid (development branch)
Release: 8.10
Codename: intrepid
sven@ibex:~$

Harald Sitter (apachelogger) wrote :

You have a disturbed fantasy, if that is a foot :P ... actually it's referred to as "The Cashew" (which is right behind clocks and gears the most important in KDE ;-)

Anyway, this is a different issue. I guess plasma just doesn't resize the panel properly. Please open a new bug report.

Changed in kdebase-workspace:
status: Confirmed → Triaged
Changed in kdebase:
status: Unknown → New
swerling (sswerling) wrote :

I have the exact same problem. I dont see why a new bug is required as the original description is correct. I will rephrase, in case there was a miscommunication:
1. Resize you desktop, for example from 1024x768 to 1400x1050. Looks great.
2. Restart computer. Login. Display back to 1024x768.
3. Open the Systems Settings > Display panel
3a. Dont do anything. The mere act of opening the display settings panel sets the display to the desired setting of 1400x1050. Looks good again, except the bottom taskbar panel is still sized as if the display was still 1024.

swerling (sswerling) wrote :

btw, my verion is kde 4.1.2, and uname -a:
  Linux r60 2.6.27-9-generic #1 SMP Thu Nov 20 21:57:00 UTC 2008 i686 GNU/Linux

I can confirm this behaviour and have a "bandaid" resolution.

**THE SYSTEM**
I'm running a unstable (~x86) Gentoo Linux system.
I've built KDE from R908976 of the 4.2 SVN branch.
I'm using QT version 4.4.2
I'm using version 6.9.0 of xf86-video-ati on an AGP R420 (Radeon X800)
I'm using version 7.4 of xorg-x11.

**THE BUG**
This behaviour is seen when setting KDE's resolution to anything lower than the display adaptor/monitor's maximum resolution, then logging out, and logging back in.
Repro recipe for a system with a maximum resolution of 1600x1200:
* Start KDE.
* Open the "Display" System Settings applet.
* Set the "Size" of your monitors to something smaller than 1600x1200.
* Click "Apply".
* Close the System Settings window and log out.
* Start KDE.
* Watch the display size be set to 1600x1200.
** Opening the "Display" System Settings applet correctly reset the screen resolution.
** Starting krandrtray also correctly resets the screen resolution.

I've repro'd this with a monitor whose max resolution was 1024x768 and one whose max resolution was 1856x1392. I would imagine that this bug is triggered regardless of max resolution.

**THE PROPOSED BANDAID**
Add krandrtray to the list of applications that get started at default.

**THE RATIONALE**
The prototypical visually-impaired grandma with the 24" CRT that her geeky son set to 1024x768 will have to reconfigure her system each and every time she logs in. This would get really annoying, really fast. (It's annoying when it happens to me, at least.)
Also, -unless the "automatically start Strigi, Nepomuk, and Akonadi" setting is stored somewhere other than ~/.kde4- we're starting Strigi, Nepomuk, and Akonadi on startup as well. I imagine that an average user would care about his desktop resolution decision being constantly ignored long before he worried about file indexing.

And, Half-Left in #kde spoke to Aaron Seigo about it. Siego agreed that it should be started by default.

Let me know if I can provide more info. I'm not afraid of applying patches or experimental code, either!

Rainarrow (rainarrow) wrote :

I can confirm this bug. I'm experiencing exactly the same problem swerling described above.

rainarrow@raw-desktop:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 8.10
Release: 8.10
Codename: intrepid

rainarrow@raw-desktop:~$ uname -a
Linux raw-desktop 2.6.27-9-generic #1 SMP Thu Nov 20 21:57:00 UTC 2008 i686 GNU/Linux

Technowizard (technowizard) wrote :

My girlfriend is having the same problems with KDE 4.2 from ppa. It's quite annoying cause the refresh rate is too low and causes headache and hurts the eyes.

Woah! 640x480! This is a very old resolution and you will see thing so big! Why you want to change to so few resolution?

That annoying bug happened to me from 1st installation of Kubuntu 8.10 with KDE 4.13, then updated to 4.12 Beta2 adn 4.2 RC1 and is not solved! I dont know why so many effects with KWin (that Im affraid to use from fist version for turned black my creen) cause that is MOST IMPORTANT cs evetime I had to set it to my res! I have reolution set to 1024 and Im not "visually-impaired" or have an 24" CRT, Ive a 19"LCD. It si for fonts are very small (size 9) and hard to read, in Konqueror more, this didnt happened in Kubuntu 8.04 with KDE 3.5.9. Iv to force to 96DPI, and this is not fixed too!I like big icons, btw some install the Apple panel that has more big icons...
I started krandrtray in first kde 4 versions but when I reboot disapeared from SysTray and res was set to max. I ran it now on KDE 4.2 but when IO reboot prob I ll get he same error. As I dont know how to add krandrtray to the list of applications that get started at default and I think that is better find a solution at the root of that really fixes the problem to future releses but I dont understand las solution Kenet said:

" **THE RATIONALE**
The prototypical visually-impaired grandma with the 24" CRT that her geeky son
set to 1024x768 will have to reconfigure her system each and every time she
logs in. This would get really annoying, really fast. (It's annoying when it
happens to me, at least.)
Also, -unless the "automatically start Strigi, Nepomuk, and Akonadi" setting is
stored somewhere other than ~/.kde4- we're starting Strigi, Nepomuk, and
Akonadi on startup as well. I imagine that an average user would care about his
desktop resolution decision being constantly ignored long before he worried
about file indexing.

And, Half-Left in #kde spoke to Aaron Seigo about it. Siego agreed that it
should be started by default."

Shaved Wookie (shavedwookie) wrote :

Still getting this today on Jaunty Dev with KDE 4.2 and KDEbase-workspace 4:4.2.0-0ubuntu8.
My plasmoids and panels also reset each time.

Changing screen resolution on every login is gettin old real fast....

Um, I'm getting this even when I *do* set my screen resolution to maximum. (1680 x 1050). The only possible exception I can think of is that I have a second monitor plugged in but not being used. Maybe "maximum resolution" here is defined as using the big desktop (both screens)?

Anyway, I'm still getting this today with Jaunty-Dev using KDE 4.2 and Kdebase-workspace 4:4.2.0-0ubuntu8

You mean, 2 monitors in a graphic card with TV output? Cause my old nVidia FX 5200 has TV output too, but I dont think that is the problem as when I started using Kubuntu 8.10 with KDE 3.5.9 that bug didnt occur..

with the same graphic card I mean.

pga (pga) wrote :

I've got similar problem on my laptop Compaq nx6110
with Intel 915 graphics controller.

I have connected two monitors:
LVDS: 1024x768
VGA: 1280x1024

I need to have switched on only external VGA monitor but after
computer restart I always have both on with resolution 1024x768.

When I open "Screen and orientation" settings VGA automatically
back to correct 1280x1024 resolution but I have to manually
switch off LVDS screen.

I use Kubuntu 8.10 with KDE 4.2.1

vrix (soundchemistry) wrote :

I've got same problem on COMPAQ S710 (CRT-0) Monitor using GeForce FX 5500 PCI video card.
I'm using Ubuntu 8.10 Intrepid Gnome and KDE 4.2.00

Using System Settings->Display then resize it from 1280x1024 to 1024 x 768, then apply would work. But, when I re log-in it will switch back to previous setting.

Solution: Since I installed restricted drivers in Gnome because I'm using NVidia drivers, I have the application NVIDIA X Server Settings. In Nvidia X Server Settings, I clicked X Server Display Configuration->Resolution->1024 x 768->Apply. Then I would Save To X Configuration File in home folder. Then, I would copy the saved xorg.conf file to /etc/X11, then re-login and it will work.

Comment: It seems that the System Settings->Display won't save the file in xorg as root.

hope this helps.

I can confirm this bug on KDE 4.2.1. (openSUSE 11.1 64 bit, KDE4 Factory Desktop repository).

I'd brought a new monitor. Initially, the old monitor's resolution was set to 1280x1024 (max. resolution). Then I installed this new LCD, changed the settings in System Settings Display applet to 1680x1050 (max. resolution). After restart the resolution was 1280x1024, but when I start the Display applet (after every restart) the resolution automatically changes to 1680x1050.

*** This bug has been confirmed by popular vote. ***

Changed in kdebase:
status: New → Confirmed
Danny Daemonic (dannydaemonic) wrote :

Upstream, the proposed bandaid is to make KRandRTray start at log in. This is an easy fix, I mean EASY. There's no reason this fix shouldn't be included in the 9.04 release if a proper fix isn't available (and it doesn't look promising).

Just put the KRandRTray.desktop file in $KDEDIR/share/autostart and it will run for anyone who logs in. In Ubuntu I believe this is currently the /usr/share/autostart directory. Keep in mind that you can only put .desktop files in $KDEDIR/share/autostart.

I can confirm that his bandaid is working for me.

liame (yhotgme) wrote :

hi, first time trying to report something (be kind)

i think i have the same problem, but when it changes back the screen is not maximized.

liame@hatzuki:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu jaunty (development branch)
Release: 9.04
Codename: jaunty
liame@hatzuki:~$ uname -a
Linux hatzuki 2.6.28-11-generic #38-Ubuntu SMP Fri Mar 27 09:00:52 UTC 2009 i686 GNU/Linux

HP pavilion dv6000
LVDS: 1024x768
(sorry, i don't know which intel driver i do have installed)

thank u
:)

liame (yhotgme) wrote :

i forgot to say that it start on the log in, with a resolution like 800x600 and neither maximized

thank u

Craig Magina (craig.magina) wrote :

I am seeing this with Jaunty beta amd64. Fully updated as of a few minutes ago.
KDE 4.2.2
Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
This is on a Lenovo X61 Tablet plugged into the dock. I am not sure if this still occurs when I have it undocked and without an external monitor. I'll try that later to see what happens. The external monitor is a 24" Dell LCD. The resolution it sets my system to is 1152x864. I am also unsure if this only happens at login or if it is a fresh boot thing. I'll attach my X.org.log file in case it holds any bits of useful information.

Tatsu (tatsumaru3) wrote :

I solved this by editing xorg.conf as root and forcing the right video mode as the only one available.

Justin Lawrence (jl-irj) wrote :

I have this same problem but also solved it by leaving randrtray running. this does achieve the resolution change, but leaves the plasma bar at the previous resolution, so i have to resize it each boot.

Konstantin Konev (skfd) wrote :

Tatsu, can you provide more details on what changes you made to xorg.conf?

Tathosh (fedurco) wrote :

I did not change xorg.conf. I just followed these steps:

1. run nvidia-settings -q RefreshRate to find out real refresh rate. It says 60.
2. go to System setting -> Display and change refresh rate. Click Apply.
3. run nvidia-settings -q RefreshRate. I says 75. So refresh rate is changed.
4. reboot the computer
5. after reboot run nvidia-settings -q RefreshRate. It says 60. So refresh rate is not remembered.
6. again go to System setting -> Display. When clicking on Display icon, the monitor will blink. Don't change anything there.
7. again run nvidia-settings -q RefreshRate. It say 75.
8. reboot the computer and run nvidia-settings -q RefreshRate. It says 60.

Enclosed you will find my xorg.conf. I have not manually edited this file.

obiazzi (obiazzi) wrote :

Same problem here.

Brand new Kubuntu 9.04 ( downloaded and installed yesterday )

nvidia gforce 5200

Will try the krandrtray workaround.

Tathosh (fedurco) wrote :

I can confirm that krandrtray workaround works. I just clicked on KRandRTray.desktop file (located in usr/share/applications/kde4) and a new application "Screen resize & rotate" appeared in the panel. If user will not close this application, it is automatically loaded when the computer is booted.

The downside of this workaround is that the monitor blinks when loading KDE desktop.

I was having the same problem described here, exactly. The krandrtray workaround worked; running xrandr -s 1680x1050 (in my case) worked; but I didn't like the way the login started out wrong, and then flickered a bit after logging in before the resolution was right.

However, I managed to solve the problem. In my case I didn't have my native resolution listed in xorg.conf; the first problem was that I didn't have the right modeline defined. I did some searching and found a discussion where it was pointed out that since X was getting the right settings eventually, the correct modeline ended up in my X logs (/var/logs/Xorg.0.log in my case). There were multiple log lines that looked like the following:

(II) intel(0): Modeline "1680x1050"x0.0 119.23 1680 1728 1760 1840 1050 1052 1058 1080 -hsync -vsync

...which is very close to the format needed for xorg.conf. Here's what I ended up with in xorg.conf, showing only the relevant lines; I only added the ModeLine line and the "1680x1050" mode (the rest was already there from a configuration utility I used):

Section "Monitor"
  Identifier "Monitor0"
    Option "DPMS" "true"
  HorizSync 28.0 - 96.0 # Warning: This may fry old Monitors
  VertRefresh 50.0 - 75.0 # Very conservative. May flicker.
  ModeLine "1680x1050" 119.23 1680 1728 1760 1840 1050 1052 1058 1080 -HSync -Vsync # added this
EndSection

Section "Screen"
  Identifier "Screen0"
  Device "Card0"
  Monitor "Monitor0"
  DefaultColorDepth 16
  SubSection "Display"
    Depth 1
    Modes "1680x1050" "1024x768" "800x600" "640x480" # added "1680x1050" - the rest were here
  EndSubSection
  # more subsections like the above, but repeated for color depths of 4, 8, 15, 16, 24, and 32
EndSection

(I fully realize that no one else will need these exact settings--but hopefully the general idea proves useful to someone.)

Anyway, once I (a) had the correct modeline in xorg.conf, and (b) added the new mode to the "Screen" section, my resolution was correct from the login screen, with no workarounds necessary and no resetting of the resolution. The problem was gone.

I'm running Arch (just installed); I don't know how other distributions handle xorg.conf stuff. (I tried looking at an xorg.conf from Ubuntu, but it was practically empy...they must do it somewhere else.) But regardless of how you do it, I think that if you can get your xorg setup to recognize the resolution from the get-go, it won't keep switching back to something else until you open the Display panel in System Settings.

Vladimir Prus (vladimir.prus) wrote :

Reproduces in brand new 9.10 install on a Dell Latitude D620 (with 1440x90 internal screen and 1680x1050 external). Would be nice if this were fixed.

Is there any progress with resolving this bug? Because right now the settings made in Display section at System Settings are totally useless. It doesn't matter what I set, because it doesn't get working after each logout->login, until I open the System Settings -> Display again.

Is there a fast way for the screen config(.kde4/share/config/krandrrc I think it was) to gets loaded right after each login in kde4? It is good solution for me if I should add it as a Startup script in kde4 configuration.

KDE 4.3.3

vbsampath (vbsampath) wrote :

Im using kubuntu 9.10 with kdebase 4.3.4 and I still have this bug
I have 1600x1200 resolution in my xorg.conf but kde login starts with only 1024x768 everytime ..so I have to change resolution everytime I login

linux fan (linuxscratch) wrote :

Reproduces with kde 4.3.4.
A work around.

(1) xrandr -q
 determine desired screen size (under SZ column) and refresh rate (under refresh rate column)
 Suppose desired SZ: is 0 and refresh rate is 70,
 then to produce that:
 xrandr -s 0 -r 70

(2) Make a desktop file in /usr/share/applications e.g., xrandr-70.desktop
[Desktop Entry]
Type=Application
Exec=xrandr -s 0 -r 70
Icon=
Terminal=false
Name=xrandr 70
Categories=System;
StartupNotify=false

(3) Setings->System Settings->Advanced->Autostart
 Add program
 select xrandr 70

Works, but why cannot Size and Rotation accomplish that?

Kim Tucker (ktucker) wrote :

Hi all,

In case this is still an issue for lucid, using karmic and kde3, the instructions here worked for me:

http://www.thinkwiki.org/wiki/Xorg_RandR_1.2

i.e.

Version of xrandr:

$ xrandr -v
Server reports RandR version 1.3

$ xrandr -q

note what screens are connected and substitute for VGA1 and LVDS1 in the indicated text for 45custom_xrandr-settings

$ sudo kate /etc/X11/Xsession.d/45custom_xrandr-settings

paste the indicated text from the above site and edit it for your VGA and LVDS devices and save.

Kim

TGP1994 (tgp1994) wrote :

Yup, same issue. NVIDIA GeForce FX 5500 Graphics card. I think an update should be released, rather than work arounds :S

Harald Sitter (apachelogger) wrote :

I take it that you will create an update then. Great. Thanks.

TGP1994 (tgp1994) wrote :

Any time :) I'll just stumble through the code and insert random characters wherever I feel they should go.

Plínio Silva (plinioesilva) wrote :

I have just installed Kubuntu 10.04, on a laptop with an intel GM965/GL960 video card, with all packages updated as of this moment. The same problem still happens, every time I reboot the laptop I have to open the display settings app and reconfigure it, it doesn't even remember the config I set last time like it does for others. To make it worse, I have an external monitor on this laptop and on boot the only screen shown is the one without the plasma panel (it defaults to cloned) so I have to add a K menu widget to the desktop and open from there. I don't have any settings on xorg.conf, in fact I don't even have that file.

TGP1994 (tgp1994) wrote :

I accidentally rebooted my computer during the distro upgrade, but I'll take your word for it that this bug is still around. I don't really understand how other bugs have gotten bumped up in the queue, to cause this bug to exist for nearly a year and half.

(In reply to comment #9)
> Is there any progress with resolving this bug? Because right now the settings
> made in Display section at System Settings are totally useless.

I agree! And I can confirm this bug- have had the issue under jaunty, karmic and now lucid. I am running kubuntu 10.04 with the 31-22 kernel and kde 4.4.3 on a Toshiba Satellite w P4-M 2.0 ghz, nvidia geforce 460 go (using default drivers not nvidia drivers) and 1gb ram.

From surfing around it appears that this bug has been known for about 18 months and seems to be independent of video card (ati, nvidia, intel) as well as indifferent to native resolution and secondary displays.

cheers, ransom

I'm seeing this issue (restoration of the wrong resolution* on login) only since the update to KDE 4.4.3, but it's still annoying to have to change the resolution to the preferred one on login.

I'm on Debian testing (Squeeze).

* I thirst thought KRandR restores always the default resolution of the screen on login, but by accident I've discovered, that it seems to keep/restore the resolution in which KDM ran. And KDM starts up (for me) with the default resolution of the screen. But when I logout, KDM is loaded with the last used resolution (that is higher than the default resolution). This higher resolution is kept/restored after I relogin to my account. After a reboot KDM starts with the default resolution again, which is then set for the session itself and not changed by KRandR on its start-up.

This is so annoying.
I'm running KDE4.4.4 inside VirtualBox. I don't want to screen set to its max resolution since then I have to scroll the VirtualBox window.

The workaround I found good at the time (see above) does not work with lucid anymore.

After skimming through the xrandr-links in this bugreport I tried some other workarounds.

This is what helps me under Kubuntu 10.04:

xrandr --output DP2 --mode 1920x1200

added as a desktop entry under systemsettings/autostart

When my Lenovo X200 is not docked this command gets ignored. When docked all is okay the way I want it (and it used to work under 9.04 and maybe some streaks of 9.10).

Krandr left my systemtray since I only clicked on it _once_ after EVERY start when docked.

TGP1994 (tgp1994) wrote :

I have a feeling that that happens because of some power management software that runs automatically when your laptop is not docked. Just an idea.

This bug and some relevant feature reqests have been reported several timeas already (#220079, #235883, #238278 among others). It is annoying and it makes the Display section of the System Settings useless and misleading - "System Settings" sounds very much like something that should be saved and restored when appropriate, while leaving temporary configuration changes (e.g. for use with beamers on laptops) to the KRandRTray and the likes.

Additionally, the assignee, Gustavo Pichorim Boiko, is reportedly no longer an active KDE developer. I've got nothing against the guy, it was his right to quit, but it would be nice if someone stepped up for the task because right now, loads of bug reports related to display configuration are being assigned to a dead email address.

manes (neschmuel) wrote :

I've got the same problem with Ubuntu 10.04 and the new KDE 4.5 packages from ppa:kubuntu-ppa/backports on a Lenovo T400S with Intel graphics (GM45). (Additionally, desktop effects run very slow).

You are welcome to be this somebody.

SVN commit 1170315 by lunakl:

- move the somewhat long krandr setup code from startkde
  into its own separate script that is called from startkde
- use properly krandrrc instead of kcmrandrrc in the script
- implement support for randr1.2 (non-legacy) setup, which
  is done by kcm_krandr simply saving a list of CLI xrandr commands
  and those are executed by the script
- add a buttom to kcm_krandr to save the current setup
  as the default to be used during desktop startup

FEATURE: 157839
FEATURE: 219704
FEATURE: 235883
FEATURE: 238278
FEATURE: 163707
FEATURE: 141999
FEATURE: 229529
BUG: 246298
FEATURE: 183143

 M +5 -0 kcontrol/randr/CMakeLists.txt
 AM kcontrol/randr/krandrstartup
 M +5 -1 kcontrol/randr/legacyrandrconfig.cpp
 M +22 -0 kcontrol/randr/legacyrandrscreen.cpp
 M +1 -0 kcontrol/randr/legacyrandrscreen.h
 M +46 -0 kcontrol/randr/randrconfig.cpp
 M +2 -0 kcontrol/randr/randrconfig.h
 M +8 -1 kcontrol/randr/randrconfigbase.ui
 M +31 -2 kcontrol/randr/randrdisplay.cpp
 M +3 -1 kcontrol/randr/randrdisplay.h
 M +31 -0 kcontrol/randr/randroutput.cpp
 M +1 -0 kcontrol/randr/randroutput.h
 M +11 -0 kcontrol/randr/randrscreen.cpp
 M +1 -0 kcontrol/randr/randrscreen.h
 M +7 -48 startkde.cmake

WebSVN link: http://websvn.kde.org/?view=rev&revision=1170315

Changed in kdebase:
status: Confirmed → Fix Released
YAFU (yafu) wrote :

Is it supposed to KMS should help to identify the native resolution of LCD? Is it supposed to set the resolution from SystemSettings then it must be remembered in next login without any xorg.conf configuration?
If so, this bug still happens in Kubuntu Maverick RC 10.10 to date. The native LCD resolution is not detected, and screen resolution settings are not restored when you re-login.

Craig Magina (craig.magina) wrote :

From what I had read, this is fixed upstream and will arrive in KDE SC 4.6 unless someone backports it. I haven't had a chance to test to see if it is really fixed however. I'll try and test it tonight with my trunk build.

Just upgraded my arch linux to 4.5.2, but krandrtray is still not restoring screen resolutions.
Did this fix go into 4.5.2?
Is there anything special to do to make sure it restores screen resolutions?

Apparently, the 1170315 fix is sadly NOT included for kde-4.5.2, in Gentoo or any other distro I've used. I'm extremely disappointed, as this has gone on for so long it's becoming a kde deal-breaker for me. As far as I'm concerned there's no excuse. No use repeating it all here, so anyone interested see my posts (wrc1944) on the Gentoo forum praising this fix in kde-live (svn), and my rant about this long standing problem not being addressed in any 4.x.x release for almost 2 years. http://forums.gentoo.org/viewtopic-t-844013-start-0.html

Unfortunately it is not fixed here too, in KDE 4.5.2 (with Kubuntu).

1170315 does work great on my kde-live (4.6 svn) install on the Gentoo kde overlay. I was considering trying to untar.bz2 the released 4.5.2 /workspace/kcontrol/krandr source file and copy over all the relevant 1170315 files from my kde-live source files, replacing the 4.5.2 versions. However, it probably isn't as simple as that, and might cause a bunch of other problems with related 4.5.2 packages. I read that it won't be in until kde-4.6.x (maybe something to do with qt-4.7?). I am successfully using qt-4.7 on my kde-live install. But even if 1170315 files worked on 4.5.2, you'd have to do it on 4.5.3, and 4.5.4, until 4.6.0 was actually released (next March?). Not sure it's worth the trouble, but I sure can't see running kde-live 4.6 on all my kde installs, either Gentoo or other distros.

*** Bug 253792 has been marked as a duplicate of this bug. ***

Any results on your tests?
Thanks in advance...

Jonathan Thomas (echidnaman) wrote :

Fix committed for KDE 4.6. The fix (really a new feature) is quite invasive, so it is not a candidate for a Stable Release Update for any existing Kubuntu release. The fix will be available in the 4.6 (pre)release packages for maverick, as they become available.

Changed in kdebase-workspace (Ubuntu):
status: Triaged → Fix Committed
Changed in kdebase:
importance: Unknown → Medium

This is not working for me as line 9 in krandrstartup is wrong:

$ cat test
#!/bin/sh
krandrrc_display_startupcommands="xrandr --output "VGA1" --pos 0x0 --mode 1680x1050 --refresh 59.9543\nxrandr --noprimary"
echo -e "$krandrrc_display_startupcommands" | \
while read command; do
   echo "$command"
done

$ ./test
-e xrandr --output VGA1 --pos 0x0 --mode 1680x1050 --refresh 59.9543
xrandr --noprimary

As you can see, the "-e" is included in $command which then obviously fails.
If I remove the "-e" it sort of works, but I still have the wrong resolution in kdm

Murz (murznn) wrote :

I have use Maverick and KDE 4.6.1 with two monitors. I do the configuration, apply, and after pressing "Save as default" and reboot, settings go back to default.

manes (neschmuel) wrote :

For me the bug is semi-fixed (KDE 4.6.2): I configured the external screen with resolution 1920x1200, internal screen off. At the next login the external screen is at the correct resolution, but the internal screen is not off. Starting monitor settings turns the screen off and everything is as it should be.

Stefan, that issue was reported in #275360.

Leandro Morgado (lmorgado) wrote :

I'm running Kubuntu Natty with KDE 4.6.2 (ati board) and I still get the same behaviour as post:

"Murz wrote on 2011-03-23: #42
I have use Maverick and KDE 4.6.1 with two monitors. I do the configuration, apply, and after pressing "Save as default" and reboot, settings go back to default."

Issue is still not fixed. I tried it here with openSUSE 11.4, Tumbleweed repository and KDE 4.6.5.

Changing the resolution to 1680x1050, logging out and in again brings back the native resolution of 1920x1080.

All changes have been made with the KDE system controls.

Dennis Bernardy (denn1s) wrote :

I can confirm this bug in Kubuntu 10.04 with KDE 4.4.2.

I can't save the settings for DualView in the System Settings, and i haven't any button to click "save as default".

Harald Sitter (apachelogger) wrote :

If you still have this bug past 4.6, please report a new bug at bugs.kde.org.

Thanks.

Changed in kdebase-workspace (Ubuntu):
status: Fix Committed → Fix Released
michealPW (michealpw) wrote :

Hey everyone.

I've recently installed KUbuntu v12.04 (KDE v4.8.4) and experienced similiar issues with the "Display and Monitor".

Here's what I've found in my testing/research. First, the "Display and Monitor" KCM can be used to generate an ~/.kde/share/config/.krandrrc file which is used to save your resolution/refresh rate settings.

The trick is, this file is NOT created when you click "Apply", you must click "Save as default" after clicking "Apply" to generate this file.

Since Xorg no longer uses an xorg.conf by default, there's really no other way for the system to persist resolution/rate changes except in the .krandrrc script (Generated by the "Save as default" button in the "Display and Monitor" KCM.)

I've read all the bug-report submissions and all the reproduction methods skip this button. They set their resolution, click "Apply" and then observe the new resolution change. They restart and then observe the old resolution... The problem, I think I've found, is we're not clicking "Save as default" after clicking "Apply"

I think a logical solution is to have the "Apply" button's handler function also call the handler function for "Save as default" which will eliminate this unexpected behavior for all new KDE users.

Thanks for your time.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.