blank screen with kwin effects

Bug #182288 reported by Andrew Manson (real_ate)
48
This bug affects 3 people
Affects Status Importance Assigned to Milestone
KDE Base
New
Undecided
Unassigned
kdebase-workspace (Ubuntu)
Medium
Rich Johnson

Bug Description

Binary package hint: kdebase-kde4

When i turned on the kwin effects for the first time i got a black screen that was flashing ( as if it was trying to do stuff ) and it settled to a blank ( black ) screen without a mouse. after restarting the x server i get a login screen but after loging in and trying to load the desktop all this happens again every time i log in.
The set up for that was a Dell 1501 laptop that uses a Radeon Xpress 1100 graphics card and all i had were the drivers included ubuntu.

so i went off and installed the fglrx non free drivers ( version 8.443.1 for my card ) and tried again to login to the session again with success! the effects were fantastic, but were a bit hard on my old laptop so i tried to turn them off and the desktop went haywire! only half drawing everything, sometimes having active windows drawn but others not drawing all of it. when draging the windows they seemed to do alright.

so i restart the x session and everything is ok again. i mess around with everything else and decide to test each of the desktop effects to see which are slowing me down the most, so i go and enable only the advanced window managment ones ( and one other but i don't remember which one it was, it was enabled the first time though and worked then ) and i have the same blank screen.

this time i have the right drivers and no matter how many times i restart the x session it won't show anything after logging in. i also restarted and then logged in with the same result.

Enough info for you guys?

Revision history for this message
PaBi3 (pavolbiely) wrote :

Same problem with my ATI Radeon X1250 (integrated in motherboard ASUS M2A-VM HDMI) and fglrx drivers. After enabling all special effects I got a black screen (but it was not flashing).

Revision history for this message
Stephan (stephan-h) wrote :

Different card (nVidia GeForce4) but same effect.

Specifically:
+ with driver "nv": enabling special effects: black screen, showing only the mouse pointer.
   I tried individual effects, and it suffices to enable "Desktop Grid" to trigger the bug.
+ with driver "nvidia" from nvidia-glx: no black screen, but none of the effects actually worked,
   i.e., after enabling nothing had changed.

Between tests I removed ${HOME}/.kde4, but it would be great to know more specifically
which files need to be reset, because naturally I don't want to discard all my personally
settings n-times.

Since I've seen the effects on another machine (with i810 driver) I know how cool they are ;-)

Revision history for this message
Rich Johnson (nixternal) wrote :

Confirming due to comments. I have a few machines here with Intel, NVidia, and ATI graphics cards and I have been able to get the kwin effects working on all of them. I have only experienced this type of issue with the ATI card and not having it properly configured in order to do the compositing. Doesn't KDE 4 tell you now that your system doesn't support the compositing if you attempt to enable it in the settings?

Changed in kdebase-kde4:
assignee: nobody → nixternal
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
Stephan (stephan-h) wrote :

I just had the same issue on a machine where previously kwin effects worked OK.
After narrowing down which change actually produced the black screen I found
the following combination to reproducibly trigger the bug:
+ On tab "General" enable desktop effects
+ On tab "All Effects" disable "Login/Login visual effect"
At your next login the screen will stay black.

(It smells like: login with effects enabled switches to a black screen and only
the login effect will turn the light back on, doesn't it??)

So the workaround might be as easy as avoiding the above combination.

BTW: I came into this situation while searching for a set of effects that doesn't
slow me down too much. Since I do a lot of desktop switching (mostly using
keyboard shortcuts), 4 seconds of repaint after each switch wasn't making me happy.
Any hints on which particular effect causes repaint of all windows after desktop switching?
Or is it compositing in general that causes additional repaints?

Revision history for this message
Mr. Wep (subscribe-volny) wrote :

Hi all, I have a similar problem.
I'm running Kubuntu Hardy and have a Nvidia 8800GTS graphics card, drivers up to date, system updated as well.
When I activate desktop effects, everything works, they look gorgeous and seem to work nearly flawlessly. But... when I log out and attempt to log in once more, I get a nice black screen with only the mouse cursor visible. I can see that the system is running in the background, I can start an application with alt+f2, e.g. konsole, and then the cursor even changes when navigating to the area where the window should be.
In my case, I do not think it is a single desktop effect that causes the problem. Only checking "enable desktop effects" causes the problem for me, everything else can remain unchecked, it still happens after re-login. I tried all sorts of combinations, both OpenGL and XRender, all the different modes, none had any results though.

For those experiencing a similar problem and not knowing how to fix it in order to keep going without desktop effects, I have a few suggestions:
Note that I have an Nvidia video card and it will not be exactly the same with ATI or others.

Option A:
1) When booting, in GRUB instead of the normal option, choose recovery mode.
2) When this loads, choose the third option - run xfix, this will modify your xorg.conf and set it to defaults.
3) Then choose the first option - normal boot - your system will boot up without your nvidia drivers and this will stop desktop effects from starting resulting in a black screen. It will be a bit slow and laggy but you can survive the minute.
4) Then just open System settings as you are used to and disable desktop effects.
5) Once they are off, you have to get your nvidia drivers back - you do this by simply executing "sudo nvidia-xconfig" in a shell.

Option B:
You do not have to reboot to fix it, you can do the work xfix does manually.
1) Log in using a failsafe session or even console login.
2) Open your /etc/X11/xorg.conf in an editor (e.g. "sudo nano /etc/X11/xorg.conf") - you have to have permissions to modify it.
3) Replace:
Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
EndSection

With:
Section "Device"
 Identifier "Configured Video Device"
EndSection
4) Start the xserver - in console login, just type "startx", if in failsafe, ctrl+alt+backspace logs you out and there you can just log in as you would normally.
5) Carry on with step 3 in option A.

Option C:
Another way of fixing would be renaming or removing your .kde4 directory, but like that you would loose all your settings, like this they stay in place.

I hope this gets resolved soon because the effects look really nice and I really look forward to having them on and working.
If you require any further information please ask.

Richard

Revision history for this message
tacsko (peter-ferenc-hajdu) wrote :

I've experienced almost the same things as Mr. Wep. I've got a Nvidia 7600GS, and using the nvidia module from nvidia-glx-new package. According to the Xorg log everything is fine, but when I set SystemSettings/Desktop/DesktopEffects/AdvancedOptions/CompositionType from XRender to OpenGL, the whole screen gets black, and the system behaves just as Mr. Wep described. So now I'm using kde4 without the desktop effects.

some additional information:
Hardy kubuntu kde4 edition

lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation G73 [GeForce 7600 GS] (rev a2)

xdpyinfo | grep Composite
Composite

Glx extension works fine as well.

Peter

Revision history for this message
Mr. Wep (subscribe-volny) wrote :

Hey! A temporary solution that lets you use desktop effects!
I found it at http://ubuntuforums.org/showthread.php?t=676148
In the "All effects" tab enable "Present Windows" in the "Appearance" section. Click onto Settings and at the top select an option to activate the effect when the cursor is moved to a certain location on the screen. Apply everything. Now you can log out and try to log in again. You'll get the black screen... but... if you move the mouse cursor to where you set it to activate the effect, the effect will start up and everything will be back to normal.
This of course is only temporary, there's still a bug somewhere, but for those who want the effects this should work for the time being.
Richard

Revision history for this message
Ivan Baykov (freecoder77) wrote :

Hello!
I think, the better solution is to edit file ~/.kde4/share/config/kwinrc and to replace

       [Compositing]
       Enabled=true

with

       [Compositing]
       Enabled=false

After saving the file, just restart xserver ang customize effects with System settings > Desktop

Ivan

Revision history for this message
Andrew McNicol (mcnicolandrew) wrote :

Ivan Baykov: Your simple solution worked perfectly for me.

I played around with visualisation settings in KDE4 and, when logging back in, I was greeted with a black screen and a white mouse cursor. Everything functioned as normal, but I just couldn't see anything. Changing the compositing setting and restarting the X server fixed this.

I'm not certain whether this is the same problem Andrew Manson (original poster) was having, but it did seem very similar to the symptoms of other commenters here.

I haven't tried playing around with effects again, and I probably won't for a while. I'm using an ATI card in an ASUS laptop and I understand they're not the most reliable cards for KDE . . . yet.

Revision history for this message
Jonathan Thomas (echidnaman) wrote :

This bug was fixed in 4.1.

Changed in kdebase-workspace:
status: Confirmed → Fix Released
Revision history for this message
Craig Magina (craig.magina) wrote :

The latest updates to kubuntu intrepid ibex seem to make this situation the default. I performed a fresh install of Alpha 5 on my desktop, which has an ATI HD3870, ran the updater in adept then rebooted the machine. KDM loads fine but after I enter my credentials, I get a white screen followed by a black screen, which only shows the cursor. I do not see this same issue on my laptop, which is running an Intel GM965. It appears an update is making the effects the default but doesn't perform any testing to ensure the system supports them. The effects work fine on the Intel, hence why it doesn't show this issue, whereas the open source radeon driver does not support the effects and does not enable dri or acceleration for my hardware. I would install the fglrx drivers but I believe they do not agree with the intrepid kernel. That might have changed since the last time I tried however.

Revision history for this message
Craig Magina (craig.magina) wrote :

I just added the
[Compositing]
Enabled=false
to my .kde/config/kwinrc and it now loads the desktop just fine.

Revision history for this message
TWO (two) wrote :

Jonathan Thomas, I'm not so sure that the bug has been fixed with 4.1. When I ran KDE4 under Hardy Heron 8.04 and had desktop effects enabled, logging in was never a problem. However, I have found that with Intrepid Ibex 8.10 Beta and KDE 4.1.2, attempting a log-in after a session in which desktop effects have been enabled results in me being completely unable to do anything once having logged in. The only keyboard shortcuts to work are those that reset the X window system, and those that change between using KDM and the command line. In that situation, changing to the command line gives me nothing but a flashing cursor. I am unable to do anything.

After reinstalling,I later found that when having windows effects enabled, sometimes Kubuntu would fail to even get passed the boot screen after the GRUB menu. In order to get passed the boot screen in that situation, I would need to boot into the recovery console then proceed to the 'resume' option.

My system is a Dell Inspiron 1300, with a Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
display controller. The drivers are all provided by Ubuntu.

I haven't as off yet tried the:
[Compositing]
Enabled=false

workaround that has been suggested but will try to do so soon.

Revision history for this message
Dann S. Washko (dann) wrote :

I can verify that this problem exists for nvidia cards and intrepid. I enabled compositing on two seperate systems with nvidia cards and after hitthing the apply button in some cases I was presented with a black screen and mouse cursor. On the second system, I don't recall enabling compositing effects but I must have tripped something because when I logged back into kde I received the black screen. I had to edit the kwinrc file and set [Compositing] Enabled=False to fix it.

Compiz desktop effects work fine in Gnome and compositing works fine in Xfce4.

Revision history for this message
Alexander Rødseth (alexanro) wrote :

I use KDE 4.1 on Intrepid and every KDE-session I've had so far has ended with a completely black screen and no reaction when moving the mouse. I have a Radeon HD3850 with a working fglrx driver.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers