Kazam countdown window text is transparent in Ubuntu 10.10 Maverick Meerkat

Bug #635772 reported by Alin Andrei
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Kazam Screencaster
High
Unassigned

Bug Description

This is occuring ever since I've tried using Kazam in Ubuntu 10.10 Maverick Meerkat but I forgot to report it (as well as another but I'll also report now): the Kazam countdown window text is transparent in Ubuntu 10.10 Maverick Meerkat. See the attached screenshot.

This does not occur in Ubuntu 10.04 Lucid Lynx!

Revision history for this message
Alin Andrei (nilarimogard) wrote :
Revision history for this message
travisman1994 (travisman1994) wrote :

Happens with me too.

Andrew (and471)
Changed in kazam:
status: New → Confirmed
importance: Undecided → Low
Andrew (and471)
Changed in kazam:
milestone: none → 0.11
Revision history for this message
Andrew (and471) wrote :

@Alin
Is there any output in the Terminal?

Revision history for this message
Alin Andrei (nilarimogard) wrote :
Download full text (8.1 KiB)

I don't think it's going to help, but here's the output:

andrei@andrei-desktop:~/Desktop$ kazam
`menu_proxy_module_load': /usr/bin/python: undefined symbol: menu_proxy_module_load
/usr/lib/python2.6/dist-packages/kazam/utils.py:75: GtkWarning: Failed to load type module: (null)

  self.builder.add_from_file(path)
`menu_proxy_module_load': /usr/bin/python: undefined symbol: menu_proxy_module_load
`menu_proxy_module_load': /usr/bin/python: undefined symbol: menu_proxy_module_load
`menu_proxy_module_load': /usr/bin/python: undefined symbol: menu_proxy_module_load
/usr/lib/python2.6/dist-packages/kazam/frontend/widgets/comboboxes.py:36: GtkWarning: Failed to load type module: (null)

  super(EasyComboBox, self).__init__()
Xlib.protocol.request.QueryExtension
`menu_proxy_module_load': /usr/bin/python: undefined symbol: menu_proxy_module_load
`menu_proxy_module_load': /usr/bin/python: undefined symbol: menu_proxy_module_load
/usr/lib/python2.6/dist-packages/kazam/frontend/indicator.py:43: GtkWarning: Failed to load type module: (null)

  self.menu = gtk.Menu()
FFmpeg version 0.6-4:0.6-2ubuntu3, Copyright (c) 2000-2010 the FFmpeg developers
  built on Sep 17 2010 20:53:09 with gcc 4.4.5
  configuration: --extra-version=4:0.6-2ubuntu3 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-gpl --enable-postproc --enable-x11grab --enable-libdc1394 --enable-shared --disable-static
  WARNING: library configuration mismatch
  libavutil configuration: --extra-version=4:0.6-2ubuntu1 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libdirac --enable-libgsm --enable-libopenjpeg --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-libmp3lame --enable-gpl --enable-postproc --enable-x11grab --enable-libfaad --enable-libxvid --enable-libx264 --enable-librtmp --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
  libavcodec configuration: --extra-version=4:0.6-2ubuntu1 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libdirac --enable-libgsm --enable-libopenjpeg --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-libmp3lame --enable-gpl --enable-postproc --enable-x11grab --enable-libfaad --enable-libxvid --enable-libx264 --enable-librtmp --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
  libavformat configuration: --extra-version=4:0.6-2ubuntu1 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libdirac --enable-libgsm --enable-libopenjpeg --enable-...

Read more...

Revision history for this message
Alin Andrei (nilarimogard) wrote :

Oh and when I click the record button (when the transparent notification text is displayed), this is what's added to the output:

`menu_proxy_module_load': /usr/bin/python: undefined symbol: menu_proxy_module_load
/usr/lib/python2.6/dist-packages/kazam/frontend/indicator.py:43: GtkWarning: Failed to load type module: (null)

  self.menu = gtk.Menu()

Andrew (and471)
Changed in kazam:
milestone: 0.11 → none
Revision history for this message
travisman1994 (travisman1994) wrote :

FIx this please. Ubuntu 10.10 comes out very soon. Fix it by time it comes out

Revision history for this message
Andrew (and471) wrote :

Are you running Compiz? Are you running Metacity (if so, with compositing?)? which graphic drivers are you using, which graphics card do you have?

Andrew (and471)
Changed in kazam:
milestone: none → 0.11
importance: Low → High
Revision history for this message
Andrew (and471) wrote :

Scratch that, thanks to the helpful guys in #cairo, I have it fixed! The fix is in trunk and should find its way into the PPA very shortly

Changed in kazam:
status: Confirmed → Fix Committed
Revision history for this message
Alin Andrei (nilarimogard) wrote :

Great, thanks for your work! I'll be waiting for the package in the PPA.

I was running Compiz btw.

Revision history for this message
Andrew (and471) wrote :

@Alin

Because of Maverick's release it may take a while for the PPA to update, as all the builders have been set to build for Ubuntu, however you can still get it in the trunk branch :)

Revision history for this message
Alan Pope 🍺🐧🐱 🦄 (popey) wrote :

Builders seem pretty quiet now :)

https://launchpad.net/builders

Revision history for this message
Andrew (and471) wrote :

Hmm that is strange, on the daily build recipe page, it says 'No suitable builders'. I'll go make a nuisance of myself and see if I can get it working...

Revision history for this message
Andrew (and471) wrote :

And what do you know I got it working :) The ld Daily Build Recipe had got stuck and so I created a new one and it now all works. The new version is now in the PPA :)

Revision history for this message
Alin Andrei (nilarimogard) wrote :

The new version in the PPA fixes this. Thank you!

Changed in kazam:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments