After upgrade to 20.04, sound recording does not work.

Bug #1875530 reported by David on 2020-04-28
64
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Kazam Screencaster
Undecided
Unassigned

Bug Description

Upgraded to the base Ubuntu 20.04 (from Ubuntu 19.10). Prior to upgrade, I was able to record either from the Laptops speakers/mic or my Jabra headset/mic. Now, under Preferences, I see nothing for Speaker and "Unknown" for microphone.

I am using an older Dell Latitude Core i5 laptop.

Cyprien Accard (supercyprien) wrote :

Same for me.

I tried with 2 computers (self made computer and Dell Inspiron Core i7).

I'm not sure than it happened when I upgraded to ubuntu 20.04 (worked fine with 19.10) but since yesterday, no speaker and unknown microphone.

Mohamed Ramadan (sudofix) wrote :

same here too

andrew@drup.org (andrew-drup) wrote :

I am getting exactly the same thing.
As reported, it happened when I upgraded to 20.04
It now does not record from speakers or microphone.
Using a Lenovo T480 laptop

Debid Magar (linkwithdm) wrote :

same here too
no speaker and unknown microphone

Jevon Longdell (jevon-longdell) wrote :

Exactly the same here, other audio recording seems to work fine after the upgrade (zoom in particular). I've attached the output of a "pactl list" command and a screenshot just in case that helps.

Cyprien Accard (supercyprien) wrote :

Some errors when launching it in a terminal, if it can help :

WARNING Kazam - Failed to correctly detect operating system.

/usr/lib/python3/dist-packages/kazam/app.py:145: Warning: value "((GtkIconSize) 32)" of type 'GtkIconSize' is invalid or out of range for property 'icon-size' of type 'GtkIconSize'
  self.builder.add_from_file(os.path.join(prefs.datadir, "ui", "kazam.ui"))

(kazam:11791): Gtk-WARNING **: 14:33:47.881: Can't set a parent on widget which has a parent

(kazam:11791): Gtk-WARNING **: 14:33:47.910: Can't set a parent on widget which has a parent

WARNING Prefs - Unable to find any audio devices.

When opening preferences :

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/kazam/frontend/preferences.py", line 256, in cb_audio2_changed
    pa_audio2_idx = prefs.mic_sources[prefs.audio2_source][0]
IndexError: list index out of range

dansamara (dan-samara) wrote :

The code in pulseaudio.py call time.clock() func. But it deprecated from Python v3.3 - https://docs.python.org/3.7/library/time.html#time.clock

All time.clock() calls must be replaced with time.perf_counter() - https://docs.python.org/3.7/library/time.html#time.perf_counter

dansamara (dan-samara) wrote :

Worked version for Python 3.8 of the pulseaudio.py file in attach

dansamara (dan-samara) wrote :

Patch

Romuald (romuntu) wrote :

Thanks for the patch, it will save my time !

andrew@drup.org (andrew-drup) wrote :

Does anyone know when this patch might be applied? Things are getting critical for me here.

APW (a-p-willis) wrote :

Thank you so much!
Upgrade to Ubuntu 20.04 broke mic in Kazam just when I desperately needed it.
Replacing /usr/lib/python3/dist-packages/kazam/pulseaudio/pulseaudio.py
with version in #8 fixed it for me.

bg4mms (klw2267) wrote :

pulseaudio.py和pulseaudio.py.diff复制到下的文件

/usr/lib/python3/dist-packages/kazam/pulseaudio

I clean install ubuntu-20.04,
then install kazam using apt command.

sudo apt -y install kazam

kazam 1.4.5-3 install successfully,
but file -> preferences operation, then crushed.
I send crush report.

Also on Ubuntu 20.10 - file -> preferences -> crash
I have a .crash file but problem not sent.
Attached my .crash file

Also on Ubuntu 20.10 - file -> preferences -> crash
I have a .crash file but problem not sent.
Attached my .crash file

Patch from post #8 applied on Ubuntu 20.04 and 20.10: WORKS FINE
thanks a lot
also crash on file -> preferences disappeared

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers