LiveSearch Content Drop Down Menu Doesn't Work in IE

Bug #986373 reported by Nat Katin-Borland on 2012-04-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KARL3
Medium
JimPGlenn

Bug Description

The LiveSearch content selector drop down menu doesn't seem to work in IE (8 or 9). If you click on the menu it drops down for a slit second, but then folds back up right away, so you're unable to actually make your selection. See screenshot to see the selector that I'm talking about.

Nat Katin-Borland (nborland) wrote :

This is a good one to report, thanks!

--Paul

On Apr 20, 2012, at 4:25 PM, Nat Katin-Borland wrote:

> ** Attachment added: "ux2 livesearch content drop down.JPG"
> https://bugs.launchpad.net/bugs/986373/+attachment/3096354/+files/ux2%20livesearch%20content%20drop%20down.JPG
>
> --
> You received this bug notification because you are subscribed to KARL3.
> https://bugs.launchpad.net/bugs/986373
>
> Title:
> LiveSearch Content Drop Down Menu Doesn't Work in IE
>
> Status in KARL3:
> New
>
> Bug description:
> The LiveSearch content selector drop down menu doesn't seem to work in
> IE (8 or 9). If you click on the menu it drops down for a slit
> second, but then folds back up right away, so you're unable to
> actually make your selection. See screenshot to see the selector that
> I'm talking about.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/karl3/+bug/986373/+subscriptions

Paul Everitt (paul-agendaless) wrote :

Blaise, perhaps this is one you can tackle.

Changed in karl3:
assignee: nobody → blaflamme (blaise-laflamme)
importance: Undecided → Medium
milestone: none → m100
Changed in karl3:
milestone: m100 → m101
blaflamme (blaise-laflamme) wrote :

The select box works under ie9, however under ie8 it's impossible to get a selection with the pointer, only by using arrow keys. Those popups are kind of a weird hack to mask the real popup and put a span over with a different styling. Looks like the event is not well trapped under ie, I would suggest to use a javascript solution instead of a tacky css one.

http://dl.dropbox.com/u/124192/websites/selectbox/index.html

Changed in karl3:
assignee: blaflamme (blaise-laflamme) → JimPGlenn (jpglenn09)
status: New → In Progress
JimPGlenn (jpglenn09) on 2012-05-07
Changed in karl3:
milestone: m101 → m102
Paul Everitt (paul-agendaless) wrote :

Jim, can you confirm if this is a bug in production also?

JimPGlenn (jpglenn09) wrote :

It is still broke on production.

Paul Everitt (paul-agendaless) wrote :

Is it broken in production for ux1, under IE?

--Paul

On May 9, 2012, at 12:05 PM, JimPGlenn wrote:

> It is still broke on production.
>
> --
> You received this bug notification because you are subscribed to KARL3.
> https://bugs.launchpad.net/bugs/986373
>
> Title:
> LiveSearch Content Drop Down Menu Doesn't Work in IE
>
> Status in KARL3:
> In Progress
>
> Bug description:
> The LiveSearch content selector drop down menu doesn't seem to work in
> IE (8 or 9). If you click on the menu it drops down for a slit
> second, but then folds back up right away, so you're unable to
> actually make your selection. See screenshot to see the selector that
> I'm talking about.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/karl3/+bug/986373/+subscriptions

JimPGlenn (jpglenn09) wrote :

It works fine for ux1 on production.

JimPGlenn (jpglenn09) on 2012-05-14
Changed in karl3:
milestone: m102 → m103
JimPGlenn (jpglenn09) on 2012-05-21
Changed in karl3:
milestone: m103 → m104
JimPGlenn (jpglenn09) wrote :

This is broken on production ux2 not ux1, it is also broken on dev/osf/ux2

JimPGlenn (jpglenn09) wrote :

Sorry I was not more specific in last comment. IE9 works across the board; IE8 does not in UX2 on production or dev/ux2/osf but ux1 works for both ie8 and ie9 on production.

Changed in karl3:
assignee: JimPGlenn (jpglenn09) → blaflamme (blaise-laflamme)
Changed in karl3:
milestone: m104 → m105
JimPGlenn (jpglenn09) on 2012-05-29
tags: added: ux2
blaflamme (blaise-laflamme) wrote :

Could be related to balazs fixing bug with ie8 and been fixed when he found the solution or related to how fields are masked and js events are fired up.

Changed in karl3:
milestone: m105 → m106
Paul Everitt (paul-agendaless) wrote :

Jim, could you test this in IE8/IE9 on karlstaging and see if it is still broken?

Changed in karl3:
assignee: blaflamme (blaise-laflamme) → JimPGlenn (jpglenn09)
JimPGlenn (jpglenn09) wrote :

It is fixed on staging ux2

Paul Everitt (paul-agendaless) wrote :

If it is fixed on karlstaging then it is fixed. Yay!

Changed in karl3:
status: In Progress → Fix Committed
tags: added: tested
JimPGlenn (jpglenn09) on 2012-06-06
tags: added: r3.88
JimPGlenn (jpglenn09) wrote :

done

Changed in karl3:
status: Fix Committed → Fix Released
Nat Katin-Borland (nborland) wrote :

LiveSearch in UX2 is still broken in IE8. It really doesn't work at all. No text shows up as you type (though the cursor does move), not livesearch results box comes and nothing happens if when you click the search icon to trigger the advanced results page.

Paul Everitt (paul-agendaless) wrote :

I'm going to re-open this but assign to Jim, as I think Balazs has fixed something in a related ticket.

Changed in karl3:
milestone: m106 → m108
status: Fix Released → In Progress
Paul Everitt (paul-agendaless) wrote :

Jim, I will let you decide if you want to mark as Fix Committed while you are waiting to test it, or remove the "tested" tag, etc.

JimPGlenn (jpglenn09) wrote :

I cannot get this to fail. It works for IE8 IE9 and FF.

JimPGlenn (jpglenn09) wrote :

Alright, I kept trying and it is broken with the same error that Balazs has just fixed in dev. see screenshot.

tags: removed: r3.88 tested
Paul Everitt (paul-agendaless) wrote :

This now works on karldev.

Changed in karl3:
status: In Progress → Fix Committed
JimPGlenn (jpglenn09) wrote :

the drop down works for IE8, IE9 and FF under UX1 and UX2. It is much slower on UX2 than UX1 but no errors.

JimPGlenn (jpglenn09) on 2012-06-25
tags: added: r3.89 tested
JimPGlenn (jpglenn09) on 2012-06-26
Changed in karl3:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers