My Communities Portlet Formatting Issue in IE

Bug #950961 reported by Nat Katin-Borland on 2012-03-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KARL3
Medium
JimPGlenn

Bug Description

The My Communities portlet has a formatting issue in IE (see screenshot). It floats in the middle of the page, doesn't have rounded edges, etc.

Nat Katin-Borland (nborland) wrote :
Changed in karl3:
importance: Undecided → Medium
milestone: none → m94
JimPGlenn (jpglenn09) on 2012-03-14
summary: - [UX2] My Communities Portlet Formatting Issue in IE
+ My Communities Portlet Formatting Issue in IE
tags: added: ux2
JimPGlenn (jpglenn09) on 2012-03-14
tags: added: community
tags: added: my-communities
removed: community
Changed in karl3:
assignee: nobody → Carlos de la Guardia (cguardia)
milestone: m94 → m95
Changed in karl3:
milestone: m95 → m97
Carlos de la Guardia (cguardia) wrote :

I don't have a Windows machine available to test IE problems right now. Can someone else do this one?

Changed in karl3:
assignee: Carlos de la Guardia (cguardia) → Paul Everitt (paul-agendaless)
Carlos de la Guardia (cguardia) wrote :

I don't have a Windows machine at the moment for testing IE bugs. Can someone else handle this one?

Paul Everitt (paul-agendaless) wrote :

Jim, can you check to see if this ticket is still a problem?

Changed in karl3:
assignee: Paul Everitt (paul-agendaless) → JimPGlenn (jpglenn09)
Paul Everitt (paul-agendaless) wrote :

Handing it to Blaise. I don't believe rounded corners are finished, so there's at least that part that needs to be done.

Changed in karl3:
assignee: JimPGlenn (jpglenn09) → blaflamme (blaise-laflamme)
JimPGlenn (jpglenn09) wrote :

I have added a screen capture from IE7. IE 8 has squared boxes rather than round but IE7 is a lot worse.

As a note, IE7 is not supported for UX2. We're breaking from the past.

--Paul

On Apr 3, 2012, at 12:04 PM, JimPGlenn wrote:

> I have added a screen capture from IE7. IE 8 has squared boxes rather
> than round but IE7 is a lot worse.
>
> ** Attachment added: "scree_capture UX2.JPG"
> https://bugs.launchpad.net/karl3/+bug/950961/+attachment/2997015/+files/scree_capture%20UX2.JPG
>
> --
> You received this bug notification because you are subscribed to KARL3.
> https://bugs.launchpad.net/bugs/950961
>
> Title:
> My Communities Portlet Formatting Issue in IE
>
> Status in KARL3:
> New
>
> Bug description:
> The My Communities portlet has a formatting issue in IE (see
> screenshot). It floats in the middle of the page, doesn't have
> rounded edges, etc.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/karl3/+bug/950961/+subscriptions

JimPGlenn (jpglenn09) wrote :

So if IE8 & IE9 are what we are testing I thought a screen shot from at least IE8 might help.

blaflamme (blaise-laflamme) wrote :

On my side it looks good, probably fixed in another update. It also has rounded corners now, see screenshot attached.

Changed in karl3:
assignee: blaflamme (blaise-laflamme) → JimPGlenn (jpglenn09)
status: New → In Progress
JimPGlenn (jpglenn09) wrote :

What version of IE is your screenshot taken. Mine is from IE8 and has no rounded edges.

Changed in karl3:
assignee: JimPGlenn (jpglenn09) → blaflamme (blaise-laflamme)
blaflamme (blaise-laflamme) wrote :

it's IE8, however to activate those changes you need to add a small config to your etc/karlserve.ini until chrisrossi finds the best way to integrate it.

bottlecap.use_css_pie = true

Changed in karl3:
assignee: blaflamme (blaise-laflamme) → JimPGlenn (jpglenn09)
Paul Everitt (paul-agendaless) wrote :

I can confirm that rounded edges work. However, the buttons for "Set Preferred" and "Edit preferred" and "Show all" don't show up as buttons. (Nor does the [All | Active] selector on communities_view)

Changed in karl3:
assignee: JimPGlenn (jpglenn09) → blaflamme (blaise-laflamme)
blaflamme (blaise-laflamme) wrote :

all buttons now work under ie8 and fixed list header+footer

Changed in karl3:
assignee: blaflamme (blaise-laflamme) → JimPGlenn (jpglenn09)
status: In Progress → Fix Committed
JimPGlenn (jpglenn09) on 2012-04-07
tags: added: tested
JimPGlenn (jpglenn09) on 2012-04-18
tags: added: r3.83
JimPGlenn (jpglenn09) on 2012-04-20
Changed in karl3:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers