Change calendar listing to pure chronological listing

Bug #839035 reported by Nat Katin-Borland on 2011-09-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KARL3
Medium
Balazs Ree

Bug Description

One of the essential features of the universal calendar is the need for a purely chronological arrangement of events in the List view. This means sorting events by date regardless of category. This is not happening and in the list view events are still being sorted chronologically with each category (see screenshot).

Nat Katin-Borland (nborland) wrote :
Paul Everitt (paul-agendaless) wrote :

Hmm, this is news to me. I thought the spec said, all the content areas were the same, just bigger. Is this really what you want (meaning, a fork between the community calendar and universal calendar for this view)?

Or, do you want the community calendar to also get this behavior?

Changed in karl3:
assignee: nobody → niels boeing (nbo)
importance: Undecided → Medium
milestone: none → m71
assignee: niels boeing (nbo) → Nat Katin-Borland (nborland)

This is one of the features that we definitely need, so if it means changing this community calendars as well, then I think that's fine. I actually think staff would much prefer pure chronological listings anyway!

-Nat

--
Nathaniel Katin-Borland
Support Specialist
Knowledge Management Initiative
KARL Support Team

Open Society Foundations - New York Office
400 West 59th Street
New York, NY 10019
Email: <email address hidden>
Phone: 212-547-6984
http://www.soros.org/
http://www.karlproject.org
-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Paul Everitt
Sent: Friday, September 02, 2011 8:24 AM
To: Nathaniel Katin-Borland
Subject: [Bug 839035] Re: Universal Calendar Not Sorting Across Categories

Hmm, this is news to me. I thought the spec said, all the content areas were the same, just bigger. Is this really what you want (meaning, a fork between the community calendar and universal calendar for this view)?

Or, do you want the community calendar to also get this behavior?

** Changed in: karl3
   Importance: Undecided => Medium

** Changed in: karl3
    Milestone: None => m71

** Changed in: karl3
     Assignee: (unassigned) => niels boeing (nbo)

** Changed in: karl3
     Assignee: niels boeing (nbo) => Nat Katin-Borland (nborland)

--
You received this bug notification because you are subscribed to the bug report.
https://bugs.launchpad.net/bugs/839035

Title:
  Universal Calendar Not Sorting Across Categories

Status in KARL3:
  New

Bug description:
  One of the essential features of the universal calendar is the need
  for a purely chronological arrangement of events in the List view.
  This means sorting events by date regardless of category. This is not
  happening and in the list view events are still being sorted
  chronologically with each category (see screenshot).

To manage notifications about this bug go to:
https://bugs.launchpad.net/karl3/+bug/839035/+subscriptions

Balazs, if you read the comment history, you'll see this is a change for both calendars.

Changed in karl3:
assignee: Nat Katin-Borland (nborland) → Balazs Ree (ree)
milestone: m71 → m72
status: New → Confirmed
summary: - Universal Calendar Not Sorting Across Categories
+ Change calendar listing to pure chronological listing
Changed in karl3:
milestone: m72 → m73
Changed in karl3:
milestone: m73 → m74
Balazs Ree (ree) wrote :

This is fixed now on master (branch1).

Maybe Chris should have a look: if there is a magical way to do this search directly from the catalog, without a sort() in the end, then it should be changed to the more effective way.

Changed in karl3:
status: Confirmed → Fix Committed
Nat Katin-Borland (nborland) wrote :

This is still a bug. The List view is sorted by category and needs to be sorted purely chronologically. We had also discussed repeating multi-day events on each day that they appear on the list view and not doing listing a multi-day event as just a date range since this prevents users from getting a purely chronological view.

Changed in karl3:
status: Fix Committed → In Progress
Changed in karl3:
milestone: m74 → m75
Paul Everitt (paul-agendaless) wrote :

Moving to next week. Need extreme focus for this week.

Changed in karl3:
milestone: m75 → m76
Balazs Ree (ree) on 2011-09-29
Changed in karl3:
status: In Progress → Fix Committed
status: Fix Committed → In Progress
Balazs Ree (ree) wrote :

Nat, this should be already committed and working on trunk. Could you please check if so, and let me know if it is not working?

Also, can you please explain your second paragraph because I am not sure to understand what it means: "We had also discussed repeating multi-day events on each day that they appear on the list view and not doing listing a multi-day event as just a date range since this prevents users from getting a purely chronological view."

-- Could you please be more specify and point out what is done wrong currently, and how it should be done instead?

Balazs Ree (ree) on 2011-09-30
Changed in karl3:
status: In Progress → Incomplete
Balazs Ree (ree) on 2011-09-30
Changed in karl3:
status: Incomplete → In Progress
assignee: Balazs Ree (ree) → Nat Katin-Borland (nborland)

This looks fixed now.

--
Nathaniel Katin-Borland
Support Specialist
Knowledge Management Initiative
KARL Support Team

Open Society Foundations - New York Office
400 West 59th Street
New York, NY 10019
Email: <email address hidden>
Phone: 212-547-6984
http://www.soros.org/
http://www.karlproject.org

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Balazs Ree
Sent: Friday, September 30, 2011 7:30 AM
To: Nathaniel Katin-Borland
Subject: [Bug 839035] Re: Change calendar listing to pure chronological listing

** Changed in: karl3
       Status: In Progress => Incomplete

--
You received this bug notification because you are subscribed to the bug report.
https://bugs.launchpad.net/bugs/839035

Title:
  Change calendar listing to pure chronological listing

Status in KARL3:
  Incomplete

Bug description:
  One of the essential features of the universal calendar is the need
  for a purely chronological arrangement of events in the List view.
  This means sorting events by date regardless of category. This is not
  happening and in the list view events are still being sorted
  chronologically with each category (see screenshot).

To manage notifications about this bug go to:
https://bugs.launchpad.net/karl3/+bug/839035/+subscriptions

Nat Katin-Borland (nborland) wrote :

For Multi-Day events int he list view they are listed as a range on the first day of the event.

For Example: May 1-5 Event 1
                         May 2 Event 2
                         May 3 Event 3

This is a bit misleading because if you look quickly at the list, it's not obvious that Event 1 actually spans several days. So as you scroll down the events in the list view and move forward chronologically events aren't listed even though they are still going on.

Changed in karl3:
assignee: Nat Katin-Borland (nborland) → Balazs Ree (ree)
Balazs Ree (ree) wrote :

Nat,

I understand from your description why the current way may be misleading.

How should it be instead? Do you want the multi-day events listed once for each day? In the above example:

May 1 Event 1
May 2 Event 1
May 2 Event 2
May 3 Event 1
May 3 Event 3
May 4 Event 1
May 5 Event 1

But, in my eyes this can be the same disturbing as the currently implemented version. Do you have this in your mind as a solution, or something else? Could you specify, what you want to see displayed, with your above example?

Nat Katin-Borland (nborland) wrote :

Hi Balazs,

You have the right idea of what I'm after, but I don't think we need to repeat the date - each day should have it's own list of events. So the listing should look something like this:

May 1 Event 1
May 2 Event 1
            Event 2
May 3 Event 1
            Event 3
May 4 Event 1

Does this make more sense now?

Changed in karl3:
milestone: m76 → m78
Changed in karl3:
milestone: m78 → m79
JimPGlenn (jpglenn09) on 2011-11-05
Changed in karl3:
milestone: m79 → m81
JimPGlenn (jpglenn09) on 2011-11-14
Changed in karl3:
milestone: m81 → m82
Changed in karl3:
milestone: m82 → m83
Changed in karl3:
milestone: m83 → m84
Paul Everitt (paul-agendaless) wrote :

Balazs suggested that, rather than filing bugs to iterate on a spec, we do a final mockup. Perhaps we can do this when I am up there.

Changed in karl3:
assignee: Balazs Ree (ree) → Nat Katin-Borland (nborland)
milestone: m84 → m86
Nat Katin-Borland (nborland) wrote :

Sounds good!

--
Nathaniel Katin-Borland
Support Specialist
Knowledge Management Initiative
KARL Support Team

Open Society Foundations - New York Office
400 West 59th Street
New York, NY 10019
Email: <email address hidden>
Phone: 212-547-6984
http://www.soros.org/
http://www.karlproject.org
-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Paul Everitt
Sent: Friday, December 02, 2011 7:24 AM
To: Nathaniel Katin-Borland
Subject: [Bug 839035] Re: Change calendar listing to pure chronological listing

Balazs suggested that, rather than filing bugs to iterate on a spec, we do a final mockup. Perhaps we can do this when I am up there.

** Changed in: karl3
    Milestone: m84 => m86

** Changed in: karl3
     Assignee: Balazs Ree (ree) => Nat Katin-Borland (nborland)

--
You received this bug notification because you are subscribed to the bug report.
https://bugs.launchpad.net/bugs/839035

Title:
  Change calendar listing to pure chronological listing

Status in KARL3:
  In Progress

Bug description:
  One of the essential features of the universal calendar is the need
  for a purely chronological arrangement of events in the List view.
  This means sorting events by date regardless of category. This is not
  happening and in the list view events are still being sorted
  chronologically with each category (see screenshot).

To manage notifications about this bug go to:
https://bugs.launchpad.net/karl3/+bug/839035/+subscriptions

Paul Everitt (paul-agendaless) wrote :

Moving out of the way to let us do a chameleon2 release.

Changed in karl3:
milestone: m86 → m87
Changed in karl3:
milestone: m87 → m88
Changed in karl3:
milestone: m88 → m90
Paul Everitt (paul-agendaless) wrote :

Nat, I think we forgot to work on this when I was up there last. What's a good way for us to mock something up? Can you hand-draw something on paper, take a picture with your camera, and send it to me?

Nat Katin-Borland (nborland) wrote :

Here's a sketch that shows what a pure chronological event list would look like in the Calendar List view. Let me know if this gives you general idea or if you need more clarification.

Paul Everitt (paul-agendaless) wrote :

Balazs, is this enough detail for you?

Changed in karl3:
assignee: Nat Katin-Borland (nborland) → Balazs Ree (ree)
Paul Everitt (paul-agendaless) wrote :

(Sorry, I meant, the attachment Nat just made as part of comment #17)

Balazs Ree (ree) wrote :

Ready for testing on ree-fix-calendar-listing-multiday branch. I used octomotron,

Some notes for testing:

1. I made it sure that _which_ events are shown in a particular List view, did not change during this fix. It still select shows the same events as currently in KARL production. Only the rendering of the events is altered (and, one event is shown multiple times, for each day spans. According to spec.)

2. There is another type of event that we have to handle similar to all day events, and we did not think of this, neither wrote up any specs for it. These are events that are _not_ all day, but still span more days. Currently these events are _not_ shown many times but shown just as earlier.

  -- I would propose to handle these events similarly to multi-day all-day events, but I need the exact specification of what to display as dates, in this case. (We cannot display "all day" and neither the starting/finishing date, so we have to define a sensible way to display these events. You see an example in the screenshot I attach.)

The current fix can go to deployment this way, or, can wait until the non-all-day multi-day events are handled, but either way is same good for the sake of system stability.

Balazs Ree (ree) wrote :

Let's deploy what we have.

Jim, could you make a new LP ticket, referencing this one, in M92, for the unfinished part Balazs mentions below?

--Paul

On Feb 7, 2012, at 8:20 AM, Balazs Ree wrote:

> Ready for testing on ree-fix-calendar-listing-multiday branch. I used
> octomotron,
>
>
> Some notes for testing:
>
> 1. I made it sure that _which_ events are shown in a particular List
> view, did not change during this fix. It still select shows the same
> events as currently in KARL production. Only the rendering of the events
> is altered (and, one event is shown multiple times, for each day spans.
> According to spec.)
>
> 2. There is another type of event that we have to handle similar to all
> day events, and we did not think of this, neither wrote up any specs for
> it. These are events that are _not_ all day, but still span more days.
> Currently these events are _not_ shown many times but shown just as
> earlier.
>
> -- I would propose to handle these events similarly to multi-day all-
> day events, but I need the exact specification of what to display as
> dates, in this case. (We cannot display "all day" and neither the
> starting/finishing date, so we have to define a sensible way to display
> these events. You see an example in the screenshot I attach.)
>
> The current fix can go to deployment this way, or, can wait until the
> non-all-day multi-day events are handled, but either way is same good
> for the sake of system stability.
>
> --
> You received this bug notification because you are subscribed to KARL3.
> https://bugs.launchpad.net/bugs/839035
>
> Title:
> Change calendar listing to pure chronological listing
>
> Status in KARL3:
> In Progress
>
> Bug description:
> One of the essential features of the universal calendar is the need
> for a purely chronological arrangement of events in the List view.
> This means sorting events by date regardless of category. This is not
> happening and in the list view events are still being sorted
> chronologically with each category (see screenshot).
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/karl3/+bug/839035/+subscriptions

Changed in karl3:
milestone: m90 → m92
Balazs Ree (ree) wrote :

This is already finished, new followup ticket is in effect.

Changed in karl3:
status: In Progress → Fix Committed
Paul Everitt (paul-agendaless) wrote :

Balazs, can you email Jim and let him know which branch to test?

JimPGlenn (jpglenn09) wrote :

This was continued in 928361 and appears to be fixed.

JimPGlenn (jpglenn09) on 2012-02-23
tags: added: r3.82
JimPGlenn (jpglenn09) wrote :

fixed

Changed in karl3:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers