(OXFAM Prod) utf8 error in jquery_tag_search

Bug #626833 reported by Jim B. Glenn on 2010-08-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KARL3
Low
Carlos de la Guardia

Bug Description

ENTRY
Fri Aug 27 13:26:50 2010
Exception when processing https://karl.oxfam.org.uk/jquery_tag_search?val=Excelente###%20felici
Traceback (most recent call last):
  File "/opt/karl/oxfam/3.5.1-0/src/karl/karl/errorlog.py", line 15, in middleware
    return app(environ, start_response)
  File "/opt/karl/oxfam/3.5.1-0/eggs/repoze.zodbconn-0.11-py2.5.egg/repoze/zodbconn/connector.py", line 21, in __call__
    result = self.next_app(environ, start_response)
  File "/opt/karl/oxfam/3.5.1-0/eggs/repoze.retry-0.9.4-py2.5.egg/repoze/retry/__init__.py", line 88, in __call__
    app_iter = self.application(environ, replace_start_response)
  File "/opt/karl/oxfam/3.5.1-0/eggs/repoze.tm2-1.0a5-py2.5.egg/repoze/tm/__init__.py", line 23, in __call__
    result = self.application(environ, save_status_and_headers)
  File "/opt/karl/oxfam/3.5.1-0/eggs/Paste-1.7.2-py2.5.egg/paste/registry.py", line 350, in __call__
    app_iter = self.application(environ, start_response)
  File "/opt/karl/oxfam/3.5.1-0/eggs/repoze.who-1.0.15-py2.5.egg/repoze/who/middleware.py", line 107, in __call__
    app_iter = app(environ, wrapper.wrap_start_response)
  File "/opt/karl/oxfam/3.5.1-0/eggs/repoze.browserid-0.3-py2.5.egg/repoze/browserid/middleware.py", line 127, in __call__
    return self.app(environ, start_response)
  File "/opt/karl/oxfam/3.5.1-0/eggs/repoze.bfg-1.2-py2.5.egg/repoze/bfg/router.py", line 130, in __call__
    response = view_callable(context, request)
  File "/opt/karl/oxfam/3.5.1-0/eggs/repoze.bfg-1.2-py2.5.egg/repoze/bfg/configuration.py", line 1753, in _secured_view
    return view(context, request)
  File "/opt/karl/oxfam/3.5.1-0/src/karl/karl/views/tags.py", line 113, in jquery_tag_search_view
    prefix = request.params['val'].lower()
  File "/opt/karl/oxfam/3.5.1-0/eggs/WebOb-0.9.8.0_osi1-py2.5.egg/webob/multidict.py", line 317, in __getitem__
    return self._decode_value(self.multi.__getitem__(self._encode_key(key)))
  File "/opt/karl/oxfam/3.5.1-0/eggs/WebOb-0.9.8.0_osi1-py2.5.egg/webob/multidict.py", line 305, in _decode_value
    value = value.decode(self.encoding, self.errors)
  File "/opt/python2.5//lib/python2.5/encodings/utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xa1 in position 9: unexpected code byte

Paul Everitt (paul-agendaless) wrote :

Most likely a duplicate of the one I just sent to you but I'll let you decide that.

Changed in karl3:
assignee: nobody → Carlos de la Guardia (cguardia)
importance: Undecided → Low
milestone: none → m48
Paul Everitt (paul-agendaless) wrote :

Carlos, is this one also a duplicate?

Carlos de la Guardia (cguardia) wrote :

No, this one seems legit. The cod ein question hasn't been touched in a while.

Changed in karl3:
status: New → Fix Committed
JimPGlenn (jpglenn09) wrote :

fixed

Changed in karl3:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers